speech-tools_2.4~release-1build1_i386.deb


Advertisement

Description

speech-tools - Edinburgh Speech Tools - user binaries

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name speech-tools
Package version 2.4~release
Package release 1build1
Package architecture i386
Package type deb
Installed size 699 B
Download size 162.12 KB
Official Mirror archive.ubuntu.com
This package contains the various highly useful utility programs that use and
accompany the Edinburgh Speech Tools Library. Audio software and some basic
signal processing software is included in this package.
The following programs are available:
na_play: generic playback program for use with net_audio and CSTR ao.
ch_wave: Waveform file conversion program.
ch_lab: label file conversion program.
ch_track: Track file conversion program.
wagon: a CART tree build and test program
See /usr/share/doc/speech-tools/README for detail list of programs available.

Alternatives

Package Version Architecture Repository
speech-tools_2.4~release-1build1_amd64.deb 2.4~release amd64 Ubuntu Universe
speech-tools - - -

Requires

Name Value
libc6 >= 2.11
libestools2.4 -
libgcc1 >= 1:3.0
libstdc++6 >= 4.4.0
perl -

Conflicts

Name Value
speech-tools-bin -

Replaces

Name Value
speech-tools-bin -

Download

Type URL
Binary Package speech-tools_2.4~release-1build1_i386.deb
Source Package speech-tools

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install speech-tools deb package:
    # sudo apt-get install speech-tools

Files

Path
/usr/bin/bcat
/usr/bin/ch_lab
/usr/bin/ch_track
/usr/bin/ch_utt
/usr/bin/ch_wave
/usr/bin/dp
/usr/bin/make_wagon_desc
/usr/bin/na_play
/usr/bin/na_record
/usr/bin/ngram_build
/usr/bin/ngram_test
/usr/bin/ols
/usr/bin/ols_test
/usr/bin/pda
/usr/bin/pitchmark
/usr/bin/raw_to_xgraph
/usr/bin/resynth
/usr/bin/scfg_make
/usr/bin/scfg_parse
/usr/bin/scfg_test
/usr/bin/scfg_train
/usr/bin/sig2fv
/usr/bin/sigfilter
/usr/bin/simple-pitchmark
/usr/bin/spectgen
/usr/bin/tilt_analysis
/usr/bin/tilt_synthesis
/usr/bin/viterbi
/usr/bin/wagon
/usr/bin/wagon_test
/usr/bin/wfst_build
/usr/bin/wfst_run
/usr/share/doc/speech-tools/README.gz
/usr/share/doc/speech-tools/changelog.Debian.gz
/usr/share/doc/speech-tools/copyright
/usr/share/man/man1/bcat.1.gz
/usr/share/man/man1/ch_lab.1.gz
/usr/share/man/man1/ch_track.1.gz
/usr/share/man/man1/ch_utt.1.gz
/usr/share/man/man1/ch_wave.1.gz
/usr/share/man/man1/dp.1.gz
/usr/share/man/man1/make_wagon_desc.1.gz
/usr/share/man/man1/na_play.1.gz
/usr/share/man/man1/na_record.1.gz
/usr/share/man/man1/ngram_build.1.gz
/usr/share/man/man1/ngram_test.1.gz
/usr/share/man/man1/ols.1.gz
/usr/share/man/man1/ols_test.1.gz
/usr/share/man/man1/pda.1.gz
/usr/share/man/man1/pitchmark.1.gz
/usr/share/man/man1/raw_to_xgraph.1.gz
/usr/share/man/man1/resynth.1.gz
/usr/share/man/man1/scfg_make.1.gz
/usr/share/man/man1/scfg_parse.1.gz
/usr/share/man/man1/scfg_test.1.gz
/usr/share/man/man1/scfg_train.1.gz
/usr/share/man/man1/sig2fv.1.gz
/usr/share/man/man1/sigfilter.1.gz
/usr/share/man/man1/simple-pitchmark.1.gz
/usr/share/man/man1/spectgen.1.gz
/usr/share/man/man1/speech-tools.1.gz
/usr/share/man/man1/tilt_analysis.1.gz
/usr/share/man/man1/tilt_synthesis.1.gz
/usr/share/man/man1/viterbi.1.gz
/usr/share/man/man1/wagon.1.gz
/usr/share/man/man1/wagon_test.1.gz
/usr/share/man/man1/wfst_build.1.gz
/usr/share/man/man1/wfst_run.1.gz

Changelog

2016-02-07 - Matthias Klose <doko@ubuntu.com>
speech-tools (1:2.4~release-1build1) xenial; urgency=medium
* No-change rebuild for ncurses6 transition.
2015-05-03 - Samuel Thibault <sthibault@debian.org>
speech-tools (1:2.4~release-1) unstable; urgency=medium
[ Sergio Oller ]
* New upstream version 2.4-release
- Rename libestools2.1 into 2.4 accordingly.
- Rename libestools2.1-dev into libestools-dev.
* Removed README.source (Not needed)
[ Samuel Thibault ]
* control: Set maintainer to debian-accessibility team.  Add myself as
uploader.
* watch: Generalize URL.
* Bump Standards-Version to 3.9.6 (no changes).
2014-08-22 - Samuel Thibault <sthibault@debian.org>
speech-tools (1:2.1~release-8) unstable; urgency=medium
[ Samuel Thibault ]
* Team upload.
[ Sergio Oller ]
* Use dh with debian/compat=9 for hardening
- Drop Build-depends: hardening-wrapper
- Honor CFLAGS, CXXFLAGS, LDFLAGS
- Use dh --with autoreconf
* Add patch wrong-default-declaration.diff by Alexander to be able to
build with clang. Closes: #756335
2014-04-20 - Samuel Thibault <sthibault@debian.org>
speech-tools (1:2.1~release-7) unstable; urgency=low
[ Samuel Thibault ]
* Team upload.
* rules: Remove config/config on clean.
* Bump Standards-Version to 3.9.5 (no changes).
* patches/doc-doc.diff: Fix build when libestools is not installed yet.
* rules: Do not install refman.pdf, it does not build.
[ Sergio Oller ]
* EST_Tokenstream: Add support to read from istream to reduce
Festival HTS disk input/output usage.
* Add several methods to EST_WaveFile and EST_Wave to write waves
by parts (header and data separately) in order improve text2wave
performance in festival package on long texts.
* rules: dh_auto_clean must depend on dh_auto_configure to clean safely.
* Check fread worked when loading files: (Closes: #715728, #716618,
#716578, #716193, #716464)
* Build -dbg packages.
* Build speech-tools-doc package.
* Allow "-pc LONGEST" in ch_wave. (LP: #723854)
2013-05-04 - Peter Drysdale <drysdalepete@gmail.com>
speech-tools (1:2.1~release-6) unstable; urgency=low
[ Peter Drysdale ]
* gcc 4.8 compliance a by-product of EsounD removal. (Closes: #701362)
* Add patch to enable compiling of with clang 3.0.
* Stop clobbering compiler/ld flags in festival build, it is not polite.
* Remove support for EsounD which has been deprecated by Gnome
* Fix Lintian flagged spelling error.
* Add missing dependency on libaudiofile-dev. Thanks
to Alessio Treglia.  (Closes: #657603)
[ Sergio Oller ]
* Add patch to enable native PulseAudio support. Original implementation by
Matthias Clasen.
* Add patch to enable native ALSA support. (Closes: #638394)
* Original work on release-5 bug fast-tracked to wheezy.
2013-01-14 - Peter Drysdale <drysdalepete@gmail.com>
speech-tools (1:2.1~release-5) unstable; urgency=low
* Add Conflicts libestools2.0-dev, libestools1.2-dev
to ensure smooth upgrades (closes: #694059)
2012-03-26 - Samuel Thibault <sthibault@debian.org>
speech-tools (1:2.1~release-4) unstable; urgency=low
[ Samuel Thibault ]
* control:
- Bump Standards-Version to 3.9.3 (no changes).
- Set libestools2.1 multi-arch: same.
* rules: Install libraries to multi-arch path.
[ Peter Drysdale ]
* Add Pre-Depend on multiarch-support as flagged by lintian
* Add qualification to unqualified method calls in templates
allowing compiling with gcc>=4.7.
* Remove old compiler switch fno-shared-data which is not present
after gcc>=4.0.

See Also

Package Description
speechd-el-doc-cs_2.7-1_all.deb speechd-el documentation in Czech
speechd-el_2.7-1_all.deb Emacs speech client using Speech Dispatcher
speechd-up_0.5~20110719-5_i386.deb Interface between Speech Dispatcher and SpeakUp
speedcrunch_0.10.1-4_i386.deb High precision calculator
speedometer_2.8-1_all.deb measure and display the rate of data across a network connection
speedpad_1.0-2_all.deb ncurses tool to test, train, and increase typing speed
speedtest-cli_0.3.4-1_all.deb Command line interface for testing internet bandwidth using speedtest.net
speex_1.2~rc1.2-1ubuntu1_i386.deb The Speex codec command line tools
spek_0.8.2-3.2build1_i386.deb acoustic spectrum analyser
spell_1.0-24_i386.deb GNU Spell, a clone of Unix `spell'
spellutils_0.7-7_i386.deb Utilities to spell-check selectively
spew_1.0.8-1build2_i386.deb I/O performance measurement and load generation tool
spf-milter-python_0.8.18-2_all.deb RFC 4408 compliant SPF Milter for Sendmail and Postfix
spf-tools-perl_2.9.0-4_all.deb SPF tools (spfquery, spfd) based on the Mail::SPF Perl module
spf-tools-python_2.0.12t-1_all.deb sender policy framework (SPF) tools for Python
Advertisement
Advertisement