spatialite-gui_2.0.0~devel2-2_i386.deb


Advertisement

Description

spatialite-gui - user-friendly graphical user interface for SpatiaLite

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name spatialite-gui
Package version 2.0.0~devel2
Package release 2
Package architecture i386
Package type deb
Installed size 3.73 KB
Download size 860.92 KB
Official Mirror archive.ubuntu.com
spatialite-gui is a Graphical User Interface (GUI) for SpatiaLite.
SpatiaLite is a SQLite extension that enables support of spatial (geometry)
data in a way conformant to OpenGis specifications, with both WKT and WKB
formats.
Spatialite also includes Virtualshape and Virtualtext to enable accessing
shapefiles and csv/text files as virtual tables.

Alternatives

Package Version Architecture Repository
spatialite-gui_2.0.0~devel2-2_amd64.deb 2.0.0~devel2 amd64 Ubuntu Universe
spatialite-gui - - -

Requires

Name Value
libc6 >= 2.7
libfreexl1 >= 0.0.2~beta20110817
libgcc1 >= 1:4.1.1
libgeos-c1v5 >= 3.4.2
libproj9 >= 4.8.0
librasterlite2-1 >= 1.0.0~rc0+devel
libspatialite7 >= 4.3.0~rc0
libsqlite3-0 >= 3.6.11
libstdc++6 >= 5.2
libwxbase3.0-0v5 >= 3.0.2+dfsg
libwxgtk3.0-0v5 >= 3.0.2+dfsg

Download

Type URL
Binary Package spatialite-gui_2.0.0~devel2-2_i386.deb
Source Package spatialite-gui

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install spatialite-gui deb package:
    # sudo apt-get install spatialite-gui

Files

Path
/usr/bin/spatialite-gui
/usr/share/applications/spatialite-gui.desktop
/usr/share/doc/spatialite-gui/changelog.Debian.gz
/usr/share/doc/spatialite-gui/copyright
/usr/share/lintian/overrides/spatialite-gui
/usr/share/menu/spatialite-gui

Changelog

2015-08-29 - Bas Couwenberg <sebastic@debian.org>
spatialite-gui (2.0.0~devel2-2) unstable; urgency=medium
* Update Vcs-Browser URL to use HTTPS.
* Override dh_install to use --list-missing.
* Rebuild for geos transition.
2015-07-22 - Bas Couwenberg <sebastic@debian.org>
spatialite-gui (2.0.0~devel2-1) unstable; urgency=medium
* Move from experimental to unstable.
2015-07-01 - Bas Couwenberg <sebastic@debian.org>
spatialite-gui (2.0.0~devel2-1~exp1) experimental; urgency=medium
* New upstream pre-release.
* Drop patches applied upstream.
* Bump minimum required libspatialite-dev to 4.3.0.
2015-06-27 - Bas Couwenberg <sebastic@debian.org>
spatialite-gui (2.0.0~devel1-1~exp1) experimental; urgency=medium
* New upstream pre-release.
* Update copyright file, changes:
- Update copyright years
- Drop .0 from GPL license shortnames.
* Drop patches applied upstream, refresh remaining patches.
* Bump minimum required libspatialite-dev to 4.3.0~rc1.
* Bump minimum required librasterlite2-dev to 1.0.0~rc0+devel.
* Add patch to fix -Wformat & -Werror=format-security issues.
* Update desktop file to use the %f Exec variable for a single file name.
2015-06-19 - Bas Couwenberg <sebastic@debian.org>
spatialite-gui (1.7.1-6) unstable; urgency=medium
* Add upstream metadata.
* Update Vcs-Browser URL to use cgit instead of gitweb.
* Add license & copyright for Silk icons.
* Update my email to @debian.org address.
* Bump Standards-Version to 3.9.6, no changes.
* Also support -devel pre-releases in watchfile uversionmangle.
2014-10-02 - Ross Gammon <rossgammon@mail.dk>
spatialite-gui (1.7.1-5) unstable; urgency=medium
[ Ross Gammon ]
* Team upload.
* Add patch to fix crash when loading shapefiles.
Thanks to Alessandro Furieri (Closes: #761629)
* Add .gitignore file to ignore quilt files
[ Bas Couwenberg ]
* Reorder and refrash patches.
2014-05-29 - Bas Couwenberg <sebastic@xs4all.nl>
spatialite-gui (1.7.1-4) unstable; urgency=medium
[ Olly Betts ]
* Update to use wxWidgets 3.0.
(closes: #748085)
[ Bas Couwenberg ]
* Drop lintian override for no-upstream-changelog,
shouldn't override pedantic tags.
2014-03-17 - Bas Couwenberg <sebastic@xs4all.nl>
spatialite-gui (1.7.1-3) unstable; urgency=low
* Add gbp.conf to use pristine-tar by default.
* Move from experimental to unstable.
2013-12-14 - Bas Couwenberg <sebastic@xs4all.nl>
spatialite-gui (1.7.1-2) experimental; urgency=low
* Bump Standards-Version to 3.9.5, no changes required.
* Require at least librasterlite version 1.1g-3.
* Require at least libspatialite version 4.1.1-5 for libxml2 support.
* Re-enable building with libxml2 support.
2013-09-30 - Bas Couwenberg <sebastic@xs4all.nl>
spatialite-gui (1.7.1-1) experimental; urgency=low
* New upstream version. (closes: #688328)
* Add myself to Uploaders.
* Update watch file, incorporate sepwatch changes and handle common mistakes.
* Update Homepage URL.
* Use canonical URLs in Vcs-* fields.
* Update minimum libspatialite version to 4.1.0.
* Update minimum libgaiagraphics version to 0.5.
* Add build dependency on libxml2-dev.
* Add patch to link properly link sqlite3.
* Disable libxml2 support, libgaiagraphics doesn't support the functions yet.
* Add lintian override for no upstream changelog, link to timeline.
* Add lintian override for missing man page, not useful for GUI program.
* Add Keywords entry to desktop file.
* Update copyright file.
* Change priority to optional, keep priority extra for -dbg package.

See Also

Package Description
spawn-fcgi_1.6.4-1_i386.deb FastCGI process spawner
spd_1.3.0-1ubuntu1_i386.deb Synchrotron image corrections and azimuthal integration
spe_0.8.4.h-3.2_all.deb Stani's Python Editor
speakup-doc_3.1.6.dfsg.1-3_all.deb Documentation for speakup kernel modules
speakup-tools_0.0~git20121016.1-2_all.deb Tools to customize speakup module
spectacle_0.25-1_all.deb RPM Spec file generator and management tool
specto_0.3.1-0ubuntu3_all.deb Unobtrusive update notification program
spectools_201108r1-7_i386.deb Utilities for using the Wi-Spy USB spectrum analyzer hardware
spectrwm_2.6.0-1ubuntu2_i386.deb dynamic tiling window manager
speech-dispatcher-doc-cs_0.8.3-1ubuntu3_all.deb Speech Dispatcher documentation in Czech
speech-dispatcher-festival_0.8.3-1ubuntu3_i386.deb Festival support for Speech Dispatcher
speech-dispatcher-flite_0.8.3-1ubuntu3_i386.deb Speech Dispatcher: Flite output module
speech-tools-doc_2.4~release-1build1_all.deb Documentation for the Edinburgh Speech Tools
speech-tools_2.4~release-1build1_i386.deb Edinburgh Speech Tools - user binaries
speechd-el-doc-cs_2.7-1_all.deb speechd-el documentation in Czech
Advertisement
Advertisement