soprano-daemon_2.9.4+dfsg1-0ubuntu3_i386.deb


Advertisement

Description

soprano-daemon - daemon for the Soprano RDF framework

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: soprano-daemon
Package version: 2.9.4+dfsg1
Package release: 0ubuntu3
Package architecture: i386
Package type: deb
Installed size: 538 B
Download size: 156.64 KB
Official Mirror: archive.ubuntu.com
Soprano is a pluggable RDF storage, parsing, and serialization framework based on Qt 4. Soprano is targeted at desktop applications that need to store RDF data. Its API has been optimized for simplicity and ease of use, while its modular structure allows it to use various different RDF storage implementations as its backend. This package contains the Soprano daemon, D-Bus service, parser plugins, and a storage plugin for the Redland RDF Application Framework. This package is not intended to be neither directly installed nor used by end users. It will be installed automatically whenever needed.

Alternatives

Replaces

  • libsoprano-dev << 2.3.0+dfsg.1-1
  • libsoprano4 << 2.3.0+dfsg.1-1

    Download

    Source package: soprano

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install soprano-daemon deb package:
      # sudo apt-get install soprano-daemon

    Files

    • /usr/bin/onto2vocabularyclass
    • /usr/bin/sopranocmd
    • /usr/bin/sopranod
    • /usr/lib/soprano/libsoprano_nquadparser.so
    • /usr/lib/soprano/libsoprano_nquadserializer.so
    • /usr/lib/soprano/libsoprano_raptorparser.so
    • /usr/lib/soprano/libsoprano_raptorserializer.so
    • /usr/lib/soprano/libsoprano_redlandbackend.so
    • /usr/lib/soprano/libsoprano_virtuosobackend.so
    • /usr/share/doc/soprano-daemon/changelog.Debian.gz
    • /usr/share/doc/soprano-daemon/copyright
    • /usr/share/soprano/plugins/nquadparser.desktop
    • /usr/share/soprano/plugins/nquadserializer.desktop
    • /usr/share/soprano/plugins/raptorparser.desktop
    • /usr/share/soprano/plugins/raptorserializer.desktop
    • /usr/share/soprano/plugins/redlandbackend.desktop
    • /usr/share/soprano/plugins/virtuosobackend.desktop
    • /usr/share/soprano/rules/nrl.rules
    • /usr/share/soprano/rules/rdfs.rules

    Changelog

    2015-12-24 - Colin Watson <cjwatson@ubuntu.com> soprano (2.9.4+dfsg1-0ubuntu3) xenial; urgency=medium * Partially sync symbols files with 2.9.4+dfsg-3 in Debian unstable: add optional or arch=m68k tags to many symbols that go missing with newer GCC versions.

    2013-10-14 - William Grant <wgrant@ubuntu.com> soprano (2.9.4+dfsg1-0ubuntu2) saucy; urgency=low * Rebuild with fixed arm64 libqt4-dev.

    2013-10-09 - Rohan Garg <rohangarg@kubuntu.org> soprano (2.9.4+dfsg1-0ubuntu1) saucy; urgency=low * New upstream bugfix release

    2013-07-16 - Philip Muškovac <yofel@kubuntu.org> soprano (2.9.3+dfsg1-0ubuntu1) saucy; urgency=low * New upstream release

    2013-05-10 - Jonathan Riddell <jriddell@ubuntu.com> soprano (2.9.2+dfsg1-0ubuntu1) saucy; urgency=low * New upstream release * Remove doxyfile_generate_tagfile.diff and x11_not_required.diff now upstream

    2013-05-06 - Jonathan Riddell <jriddell@ubuntu.com> soprano (2.9.1+dfsg1-0ubuntu3) saucy; urgency=low * Update .symbols file for armhf

    2013-05-05 - Jonathan Riddell <jriddell@ubuntu.com> soprano (2.9.1+dfsg1-0ubuntu2) saucy; urgency=low * Update .symbols file

    2013-05-05 - Jonathan Riddell <jriddell@ubuntu.com> soprano (2.9.1+dfsg1-0ubuntu1) saucy; urgency=low * New upstream release * Merge with Debian, remaining changes: - Build-depend on libraptor2-dev instead of libraptor1-dev - Use Ubuntu version numbers in debian/libsoprano4.symbols - Do not apply redland_raptor2_support.h, no longer needed. - Build-dep on libvirtodbc0, unixodbc-dev instead of iodbc and add patch no-odbc-dm to build against it - Disable cludene in debian/rules and don't install sopranoindex in libsoprano4.install and libsoprano-dev.install

    2013-03-25 - Sune Vuorela <sune@debian.org> soprano (2.9.0+dfsg1-1) experimental; urgency=low * New upstream release. [ José Manuel Santamaría Lema ] * Update symbols files. * Bump debhelper compatibility level to 9. * Remove dont_use_virtuoso_default_port.diff, applied upstream. * Update symbols files. * Update installed files. * Add lintian override for hardening-no-fortify-functions. [ Daniele E. Domenichelli ] * Update disable_usr_lib_install_rpath.diff. [ Sune Vuorela ] * Release to experimental * Update me in uploaders

    2013-02-05 - José Manuel Santamaría Lema <panfaust@gmail.com> soprano (2.7.6+dfsg.1-3) unstable; urgency=low * Team upload. * Add dont_use_virtuoso_default_port.diff, prevents hangs when installing or running virtuoso as a standalone server.

    Advertisement
    Advertisement