sofa-apps_1.0~beta4-10ubuntu2_i386.deb


Advertisement

Description

sofa-apps - GUI for the Simulation Open Framework Architecture (SOFA)

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: sofa-apps
Package version: 1.0~beta4
Package release: 10ubuntu2
Package architecture: i386
Package type: deb
Installed size: 65 B
Download size: 18.08 KB
Official Mirror: archive.ubuntu.com
SOFA is an Open Source framework primarily targeted at real-time simulation, with an emphasis on medical simulation. It is mostly intended for the research community to help develop newer algorithms, but can also be used as an efficient prototyping tool. This package contains the SOFA main application.

Alternatives

    Download

    Source package: sofa-framework

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install sofa-apps deb package:
      # sudo apt-get install sofa-apps

    Files

    • /usr/bin/sofa
    • /usr/lib/sofa-framework/sofa
    • /usr/share/applications/sofa.desktop
    • /usr/share/doc/sofa-apps/README.Debian
    • /usr/share/doc/sofa-apps/changelog.Debian.gz
    • /usr/share/doc/sofa-apps/copyright
    • /usr/share/man/man1/sofa.1.gz
    • /usr/share/pixmaps/sofa.xpm

    Changelog

    2015-12-01 - Graham Inggs <graham@nerve.org.za> sofa-framework (1.0~beta4-10ubuntu2) xenial; urgency=medium * No-change rebuild against suitesparse 1:4.4.5-2

    2015-11-16 - Steve Langasek <steve.langasek@ubuntu.com> sofa-framework (1.0~beta4-10ubuntu1) xenial; urgency=low [ Ubuntu Merge-o-Matic ] * Sync from Debian unstable. * Revert rename of library package for g++5 ABI transition, not required in Debian. Conflicts/Replaces/Provides against the reverted name; this change can be dropped after the xenial release.

    2015-09-07 - Anton Gladky <gladk@debian.org> sofa-framework (1.0~beta4-10) unstable; urgency=medium * Team upload. * Remove libqglviewer-dev from Build-Depends. Not used in the build.

    2015-11-11 - Steve Langasek <steve.langasek@ubuntu.com> sofa-framework (1.0~beta4-9ubuntu2) xenial; urgency=medium * No-change rebuild against libglew1.13

    2015-08-04 - Iain Lane <iain@orangesquash.org.uk> sofa-framework (1.0~beta4-9ubuntu1) wily; urgency=medium * Rename library packages for g++5 ABI transition.

    2014-09-09 - Andreas Tille <tille@debian.org> sofa-framework (1.0~beta4-9) unstable; urgency=medium * Apply patches by Martin Steghöfer <martin@steghoefer.eu> to build with gcc-4.9 (thanks to Martin) Closes: #746910 * d/compat: s/8/9/ * cme fix dpkg-control * DEP5

    2013-07-10 - Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com> sofa-framework (1.0~beta4-8) unstable; urgency=low * Team upload. * Drop "-mt" suffix from boost lib, in the 50_all_changes.diff (Closes: #701288) * Add missing include which causes undefined symbols (Closes: #560104) (Closes: #701360)

    2013-05-20 - Anton Gladky <gladk@debian.org> sofa-framework (1.0~beta4-7.1) unstable; urgency=low * Non-maintainer upload. * Remove build-dep on quilt. * Change build-dep from libqglviewer-qt4-dev to libqglviewer-dev. * Remove obsolete DM-Upload flag. * Fix FTBFS against libpng1.5. (Closes: #650568)

    2012-05-31 - Andreas Tille <tille@debian.org> sofa-framework (1.0~beta4-7) unstable; urgency=low * debian/watch: also seek for https URLs * debian/get-orig-source: - Fetch any new version not only one hard coded version - Make sure also versioned external library sources will be removed * debian/rules - debian/*.{install,manpages} (make more use of dh_* helper files) - Fixed clean target - use short dh to simplify further packaging including hardening * debian/control: - Build-Depends: libeigen3-dev, libqglviewer-qt4-dev, libsuitesparse-dev - Build-Depends: s/libpng12-dev/libpng-dev/ Closes: #662508 - Standards-Version: 3.9.3 (no changes needed) - Do not build sofa-doc by default (see README.source) * debian/copyright: ensure DEP5 by fixing using cme fix dpkg-copyright * debian/patches/sofa-framework-gcc-4.7.diff: Fix gcc-4.7 build issue Thanks to Matej Vela <vela@debian.org> for the patch Closes: #673841 * debian/README.source: - delete remark about quilt which is redundant these days - add remark why sofa-doc is not builded any more and how the package could be build for private use * debhelper 9 (control+compat)

    2012-05-29 - Matthias Klose <doko@debian.org> sofa-framework (1.0~beta4-6.1) unstable; urgency=low * Non maintainer upload. * Fix build failure with GCC 4.7 (Matej Vela). Closes: #673841.

    Advertisement
    Advertisement