snimpy_0.8.8-1build1_all.deb


Advertisement

Description

snimpy - interactive SNMP tool with Python

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: snimpy
Package version: 0.8.8
Package release: 1build1
Package architecture: all
Package type: deb
Installed size: 30 B
Download size: 6.42 KB
Official Mirror: archive.ubuntu.com
Snimpy is a Python-based tool providing a simple interface to build SNMP queries. This interface aims at being the most Pythonic possible: you grab scalars using attributes and columns are like dictionaries. Snimpy can either be used interactively through its console (derived from Python own console or from IPython if available) or by writing snimpy scripts which are just Python scripts with some global variables available.

Alternatives

    Download

    Source package: snimpy

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install snimpy deb package:
      # sudo apt-get install snimpy

    Files

    • /usr/bin/snimpy
    • /usr/share/doc/snimpy/changelog.Debian.gz
    • /usr/share/doc/snimpy/copyright
    • /usr/share/doc/snimpy/examples/add-vlan.py
    • /usr/share/doc/snimpy/examples/disable-port-ingress-filtering.py
    • /usr/share/doc/snimpy/examples/enable-lldp.py
    • /usr/share/doc/snimpy/examples/get-serial.py
    • /usr/share/doc/snimpy/examples/list-interfaces.py
    • /usr/share/doc/snimpy/examples/list-routes.py
    • /usr/share/doc/snimpy/examples/rename-vlan.py
    • /usr/share/doc/snimpy/examples/set-syslog-ntp.py
    • /usr/share/doc/snimpy/examples/vlan-and-interfaces.py
    • /usr/share/man/man1/snimpy.1.gz

    Changelog

    2016-01-19 - Matthias Klose <doko@ubuntu.com> snimpy (0.8.8-1build1) xenial; urgency=medium * No-change rebuild to drop python3.4 support.

    2015-11-16 - Vincent Bernat <bernat@debian.org> snimpy (0.8.8-1) unstable; urgency=medium * New upstream release. * Remove runtime requirement on python-cffi. * Build-Depends on python{,3}-vcversioner.

    2015-09-21 - Vincent Bernat <bernat@debian.org> snimpy (0.8.6-2) unstable; urgency=medium * Let python-cffi generate the appropriate dependencies.

    2015-06-25 - Vincent Bernat <bernat@debian.org> snimpy (0.8.6-1) unstable; urgency=medium * New upstream release.

    2015-06-20 - Vincent Bernat <bernat@debian.org> snimpy (0.8.5-4) unstable; urgency=medium * Add entry for `docs/_themes` in debian/copyright.

    2015-06-18 - Vincent Bernat <bernat@debian.org> snimpy (0.8.5-3) unstable; urgency=medium * Fix debian/watch file.

    2015-04-26 - Vincent Bernat <bernat@debian.org> snimpy (0.8.5-2) unstable; urgency=medium * Conversion to dh. * Ships both python-snimpy and python3-snimpy. Closes: #782961. * Build the documentation as well.

    2015-04-26 - Vincent Bernat <bernat@debian.org> snimpy (0.8.5-1) unstable; urgency=medium * New upstream release. * Bump Standards-Version.

    2014-08-20 - Vincent Bernat <bernat@debian.org> snimpy (0.8.3-1) unstable; urgency=medium * New upstream release.

    2014-01-31 - Vincent Bernat <bernat@debian.org> snimpy (0.8.1-2) unstable; urgency=low * Depends on the exact upstream version of python-cffi we built upon. Closes: #737196. * Bump Standards-Version.

    Advertisement
    Advertisement