sndfile-programs_1.0.25-10_i386.deb


Advertisement

Description

sndfile-programs - Sample programs that use libsndfile

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: sndfile-programs
Package version: 1.0.25
Package release: 10
Package architecture: i386
Package type: deb
Installed size: 242 B
Download size: 31.35 KB
Official Mirror: archive.ubuntu.com
This package contains simple programs which use libsndfile for operating on sound files. Programs include: - sndfile-cmp : compare the audio data of two files - sndfile-concat : concatenate two or more files - sndfile-convert : convert between sound file formats - sndfile-info : print information about files - sndfile-metadata-get/set : get and set file metadata - sndfile-play : play a sound file

    Download

    Source package: libsndfile

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install sndfile-programs deb package:
      # sudo apt-get install sndfile-programs

    Files

    • /usr/bin/sndfile-cmp
    • /usr/bin/sndfile-concat
    • /usr/bin/sndfile-convert
    • /usr/bin/sndfile-deinterleave
    • /usr/bin/sndfile-info
    • /usr/bin/sndfile-interleave
    • /usr/bin/sndfile-metadata-get
    • /usr/bin/sndfile-metadata-set
    • /usr/bin/sndfile-play
    • /usr/share/doc/sndfile-programs/changelog.Debian.gz
    • /usr/share/doc/sndfile-programs/copyright
    • /usr/share/man/man1/sndfile-cmp.1.gz
    • /usr/share/man/man1/sndfile-concat.1.gz
    • /usr/share/man/man1/sndfile-convert.1.gz
    • /usr/share/man/man1/sndfile-deinterleave.1.gz
    • /usr/share/man/man1/sndfile-info.1.gz
    • /usr/share/man/man1/sndfile-interleave.1.gz
    • /usr/share/man/man1/sndfile-metadata-get.1.gz
    • /usr/share/man/man1/sndfile-metadata-set.1.gz
    • /usr/share/man/man1/sndfile-play.1.gz
    • /usr/share/man/man1/sndfile-salvage.1.gz

    Changelog

    2015-11-10 - Erik de Castro Lopo <erikd@mega-nerd.com> libsndfile (1.0.25-10) unstable; urgency=low * debian/patches : - Add 02_sd2_buffer_read_overflow.diff (CVE-2014-9496, closes: #774162). - Add 03_file_io_divide_by_zero.diff (CVE-2014-9756, closes: #804447). - Add 04_fix_aiff_heap_overflow.diff (CVE-2015-7805, closes: #804445). * debian/control: Standards version 3.9.6. No changes needed.

    2014-01-29 - Erik de Castro Lopo <erikd@mega-nerd.com> libsndfile (1.0.25-9) unstable; urgency=low * debian/rules: Switch from autotools-dev to dh-autoreconf. * debian/control Standards-Version 3.9.5.

    2013-12-17 - Erik de Castro Lopo <erikd@mega-nerd.com> libsndfile (1.0.25-8) unstable; urgency=low [Wookey <wookey@debian.org>] * Ensure config.sub/guess are up to date (Closes: #732346). [Erik de Castro Lopo] * debian/control: - Standards version 3.9.4. No changes needed. - Set 'Multi-Arch: same' for -dbg package.

    2013-07-13 - Erik de Castro Lopo <erikd@mega-nerd.com> libsndfile (1.0.25-7) unstable; urgency=low * debian/control debian/rules Create -dbg versions of libsndfile1 and sndfile-programs binary packages.

    2013-06-28 - Erik de Castro Lopo <erikd@mega-nerd.com> libsndfile (1.0.25-6) unstable; urgency=low * debian/patches/01_sd2_rsrc_segfault.diff : Patch from upstream git. * debian/rules : Remove cruft at end of ifeq line. * debian/control : Remove DM-Upload-Allowed which no longer works.

    2012-06-18 - Erik de Castro Lopo <erikd@mega-nerd.com> libsndfile (1.0.25-5) unstable; urgency=low * debian/libsndfile1-dev: Do not install libsndfile.la (Closes: #670420). * debian/control: Standards version 3.9.3. No changes needed.

    2012-01-06 - Erik de Castro Lopo <erikd@mega-nerd.com> libsndfile (1.0.25-4) unstable; urgency=low * Patch from Moritz Muehlenhoff enabling harden build flags (Closes: #654831).

    2011-08-13 - Erik de Castro Lopo <erikd@mega-nerd.com> libsndfile (1.0.25-3) unstable; urgency=low * Patch from Steve Langasek to enable multiarch (Closes: #637585).

    2011-07-19 - Erik de Castro Lopo <erikd@mega-nerd.com> libsndfile (1.0.25-2) unstable; urgency=low * debian/control: Use linux-any dpkg architecture wildcard (Closes: #634492).

    2011-07-18 - Erik de Castro Lopo <erikd@mega-nerd.com> libsndfile (1.0.25-1) unstable; urgency=low * New upstream. * debian/control: Update standards version (no changes needed). * debian/rules: Add build-indep and build-arch targets.

    Advertisement
    Advertisement