sludge-compiler_2.2.1-1build2_i386.deb


Advertisement

Description

sludge-compiler - Compiler for SLUDGE adventure games

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: sludge-compiler
Package version: 2.2.1
Package release: 1build2
Package architecture: i386
Package type: deb
Installed size: 141 B
Download size: 48.47 KB
Official Mirror: archive.ubuntu.com
SLUDGE is an open source adventure game engine. It combines a scripting language with IDE tools. This package contains the command line SLUDGE compiler and is mainly intended as build dependency for SLUDGE game packages. Developers can use the Project Manager included in the Dev Kit for compiling games.

Alternatives

Conflicts

  • sludge-devkit <= 2.1.1-1

Replaces

  • sludge-devkit <= 2.1.1-1

    Download

    Source package: sludge

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install sludge-compiler deb package:
      # sudo apt-get install sludge-compiler

    Files

    • /usr/bin/sludge-compiler
    • /usr/share/doc/sludge-compiler/changelog.Debian.gz
    • /usr/share/doc/sludge-compiler/copyright
    • /usr/share/man/man1/sludge-compiler.1.gz

    Changelog

    2016-01-07 - Colin Watson <cjwatson@ubuntu.com> sludge (2.2.1-1build2) xenial; urgency=medium * Rebuild against libvpx3.

    2015-07-24 - Iain Lane <iain@orangesquash.org.uk> sludge (2.2.1-1build1) wily; urgency=medium * No-change rebuild against new libvpx

    2014-05-03 - Tobias Hansen <thansen@debian.org> sludge (2.2.1-1) unstable; urgency=medium * New upstream release. * debian/patches/fix-gcc-4.7-build.patch: - Removed. Was applied upstream. * debian/patches/fix-out-of-order-guard-bug.patch: - Removed. Was applied upstream.

    2014-03-19 - Tobias Hansen <thansen@debian.org> sludge (2.2-2) unstable; urgency=medium * Fix a bug that made it impossible to finish Out Of Order (Closes: #737472). * Bump Standards-Version to 3.9.5. * Change my mail address in Uploaders.

    2012-05-08 - Tobias Hansen <tobias.han@gmx.de> sludge (2.2-1) unstable; urgency=low * New upstream release. (Closes: #647501, #672038) * Change Build-Depends libpng12-dev to libpng-dev. (Closes: #662506) * Adopt new standards: - Standards-Version 3.9.3 - debhelper compat level 9 - copyright format 1.0 * Enable all hardening build flags. * debian/patches/fix-gcc-4.7-build.patch: - Added. Minor changes to fix build with gcc 4.7. * debian/patches/fix-endianness-check.patch: - Removed. Was applied upstream. * debian/copyright: - Add entry for eglport.

    2011-10-24 - Tobias Hansen <tobias.han@gmx.de> sludge (2.1.2-3) unstable; urgency=low * New upstream release. * Move sludge-compiler to separate package. * Fix check for big-endian byte ordering. * Remove full stops from synopses. * Update Vcs-* fields in control file.

    2011-05-03 - Tobias Hansen <tobias.han@gmx.de> sludge (2.1.1-1) unstable; urgency=low * Initial release (Closes: #612862)

    Advertisement
    Advertisement