slpd_1.2.1-11_i386.deb


Advertisement

Description

slpd - OpenSLP server (slpd)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name slpd
Package version 1.2.1
Package release 11
Package architecture i386
Package type deb
Installed size 173 B
Download size 62.94 KB
Official Mirror archive.ubuntu.com
Service Location Protocol is an IETF standard protocol that is used to
discover/advertise services on the network. You can use SLP for anything
from locating a suitable printer on your floor to discovering what LDAP
directories are available in your organization.
This package provides slpd, the OpenSLP daemon, which provides an
SLPv2 (RFC 2608) compliant Service Agent and Directory Agent.

Alternatives

Package Version Architecture Repository
slpd_1.2.1-11ubuntu0.16.04.1_i386.deb 1.2.1 i386 Ubuntu Updates Universe
slpd_1.2.1-11ubuntu0.16.04.1_amd64.deb 1.2.1 amd64 Ubuntu Updates Universe
slpd_1.2.1-11_amd64.deb 1.2.1 amd64 Ubuntu Universe
slpd - - -

Requires

Name Value
libc6 >= 2.15

Download

Type URL
Binary Package slpd_1.2.1-11_i386.deb
Source Package openslp-dfsg

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install slpd deb package:
    # sudo apt-get install slpd

Files

Path
/etc/slp.conf
/etc/slp.reg
/etc/slp.spi
/etc/init.d/slpd
/usr/sbin/slpd
/usr/share/doc/slpd/AUTHORS
/usr/share/doc/slpd/NEWS.gz
/usr/share/doc/slpd/README
/usr/share/doc/slpd/THANKS
/usr/share/doc/slpd/changelog.Debian.gz
/usr/share/doc/slpd/copyright
/usr/share/man/man8/slpd.8.gz

Changelog

2015-09-04 - Alessandro Ghedini <ghedo@debian.org>
openslp-dfsg (1.2.1-11) unstable; urgency=high
* QA upload from the Security Team
* Fix double free as per CVE-2015-5177
2014-07-25 - Guillem Jover <guillem@debian.org>
openslp-dfsg (1.2.1-10) unstable; urgency=low
* QA upload.
* Bump Standards-Version to 3.9.5 (no changes needed).
* Bump debhelper compatibility level to 9.
* Switch to machine-parseable copyright format.
* Reorder binary package stanzas in debian/control.
* Split common and specific package descriptions into distinct paragraphs
so that translations are easier.
* Reword package summaries.
* Mark slpd and slptool as Multi-Arch:foreign, libslp1 and libslp-dev as
Multi-Arch:same. Closes: #755935
* Clean up debian/rules:
- Explicitly set DEB_HOST_GNU_TYPE.
- Remove unused DEB_BUILD_GNU_SYSTEM and DEB_BUILD_GNU_CPU assignments.
- Remove commented out debhelper commands.
- Do not pass any argument to update-rc.d via dh_installinit.
- Pass --host and --build to configure only when cross-compiling.
- Pass --disable-silent-rules to configure, preemptively.
- Enable hardening build flags.
* Clean up init script:
- Update LSB header descriptions.
- Add LSB status action support.
- Rename debian/init.d to debian/slpd.init.
- Add new PIDFILE variable.
* Remove unnecessary debian/dirs, dh_installinit takes care of creating the
etc/init.d directory.
* Remove debian/preinst, as it was wrongly using start-stop-daemon directly,
and invoke-rc.d is already being injected by debhelper to stop the daemon
on upgrade.
* Remove «set -x» from slpd postinst.
* Namespace stray debhelper files with «slpd.» in debian/ filenames.
* Remove trailing spaces from debian/ files.
* Change the libcrypto configure-time checks conditional on whether it is
going to be used at build time, so that we can remove the libssl-dev
Build-Conflicts.
* Add a debian/watch file.
* Add a basic symbols file for libslp1.
* Fix a typo in slptool's program output message.
* Fix a typo in an automake coditional in the code, that was not properly
disabling the code (ENABLE_SLPV2_SECURITY → ENABLE_SLPv2_SECURITY).
* Fix handling of string-list in common/slp_common.c by not increasing
the item pointer past the string-list pointer, and letting '\\' only
escape the item separator ','. Although not reproduced it should in
theory fix CVE-2012-4428. Closes: #687597
2012-02-06 - Regis Boudin <regis@debian.org>
openslp-dfsg (1.2.1-9) unstable; urgency=low
* QA upload.
* Drop 99_auroreconf patch, use dh-autoreconf instead. Ajust build-depends
accordingly.
* Bump Standards-Version to 3.9.2.
* Drop duplicate Section and Priority fields from debian/control.
* Move to dh_install instead of dh_movefiles.
* Switch to format 3.0 (quilt).
* Call make disclean in clean target, stop finishing the cleanup manually.
* Enable building of the static lib, and ship it in libslp1-dev.
* Stop shipping the .la file.
* Bump debhelper compat version to 8. Ajust build-depends accordingly.
* Drop build-depends on debconf.
* Remove manual calls to ldconfig, debhelper adds them for us.
* Stop the debconf abuse, ship a README.Debian with libslp1 instead.
Closes: #613472.
* Drop now unneeded BSD-specific tricks from debian/rules.
2011-12-19 - Moritz Muehlenhoff <jmm@debian.org>
openslp-dfsg (1.2.1-8) unstable; urgency=low
* Orphan the package, setting maintainer to Debian QA group
* Fix CVE-2010-3609 (Closes: #623551, Closes: #621030)
2010-07-31 - Christian Perrier <bubulle@debian.org>
openslp-dfsg (1.2.1-7.8) unstable; urgency=low
* Non-maintainer upload.
* Bump debhelper compatibility to 7
* As a consequence of the former, replace deprecated "dh_clean -k"
by dh_prep
* Fix pending l10n issues. Debconf translations:
- Danish (Joe Hansen).  Closes: #581056

See Also

Package Description
slptool_1.2.1-11_i386.deb OpenSLP command line tool
slrn_1.0.2-4build1_i386.deb threaded text-mode news reader
slrnface_2.1.1-7_i386.deb shows X-Faces from a newsposting on an X11 terminal emulator
slrnpull_1.0.2-4build1_i386.deb pulls a small newsfeed from an NNTP server
slsh_2.3.0-2ubuntu1_i386.deb Interpreter for S-Lang language
slt_0.0.git20140301-1_i386.deb TLS reverse-proxy with SNI multiplexing (TLS virtual hosts)
sludge-compiler_2.2.1-1build2_i386.deb Compiler for SLUDGE adventure games
sludge-devkit_2.2.1-1build2_i386.deb Development tools for creating SLUDGE adventure games
sludge-doc_2.2.1-1build2_all.deb Documentation for SLUDGE
sludge-engine_2.2.1-1build2_i386.deb Runtime engine for playing SLUDGE adventure games
slugimage_0.1+20160202.fe8b64a-1_all.deb NSLU2 firmware image manipulation utility
sluice_0.02.02-1_i386.deb rate limiting data piping tool
slurm-client-emulator_15.08.7-1build1_i386.deb SLURM client side commands for the emulator
slurm-client_15.08.7-1build1_i386.deb SLURM client side commands
slurm-drmaa-dev_1.0.7-1build3_i386.deb PSNC DRMAA for SLURM - devel
Advertisement
Advertisement