slirp_1.0.17-8_i386.deb


Advertisement

Description

slirp - SLIP/PPP emulator using a dial up shell account

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: slirp
Package version: 1.0.17
Package release: 8
Package architecture: i386
Package type: deb
Installed size: 491 B
Download size: 164.04 KB
Official Mirror: archive.ubuntu.com
Slirp is a TCP/IP emulator which turns an ordinary shell account into a (C)SLIP/PPP account. This allows shell users to use all the funky Internet applications like Netscape, Mosaic, CUSeeMe, etc. Please note that maybe your ISP really doesn't like you using slirp, because they want to charge more for a ppp connection, so use it at your own risk.

Alternatives

Requires

    Download

    Binary package: slirp_1.0.17-8_i386.deb
    Source package: slirp

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install slirp deb package:
      # sudo apt-get install slirp

    Files

    • /usr/bin/slirp
    • /usr/bin/slirp-fullbolt
    • /usr/share/doc/slirp/CONFIG.gz
    • /usr/share/doc/slirp/CONTRIB
    • /usr/share/doc/slirp/Changes-1.0.17
    • /usr/share/doc/slirp/HOWTO-TEST.gz
    • /usr/share/doc/slirp/README
    • /usr/share/doc/slirp/README.Debian
    • /usr/share/doc/slirp/README.NEXT.gz
    • /usr/share/doc/slirp/TODO
    • /usr/share/doc/slirp/TODO.old
    • /usr/share/doc/slirp/alt.dcom.slip-emulators.FAQ.gz
    • /usr/share/doc/slirp/changelog.Debian.gz
    • /usr/share/doc/slirp/copyright
    • /usr/share/doc/slirp/slirp.doc.gz
    • /usr/share/man/man1/slirp-fullbolt.1.gz
    • /usr/share/man/man1/slirp.1.gz

    Changelog

    2015-06-25 - Roberto Lumbreras <rover@debian.org> slirp (1:1.0.17-8) unstable; urgency=low * Fix FTBFS with GCC 5.0 (Closes: #778124) * Updated standards.

    2012-08-16 - Roberto Lumbreras <rover@debian.org> slirp (1:1.0.17-7) unstable; urgency=low * Fix IPCP negotiation fails for 64-bit hosts (Closes: #685056) * Set debhelper compat to 9.

    2012-03-05 - Roberto Lumbreras <rover@debian.org> slirp (1:1.0.17-6) unstable; urgency=low * Apply ``real full bolt'' patch. (Closes: #658359) * Updated standards.

    2011-06-06 - Roberto Lumbreras <rover@debian.org> slirp (1:1.0.17-5) unstable; urgency=low * Don't delete *.p files and don't run 'mkpro' perl script anymore to automatically regenerate prototypes, as it stopped working somehow, resulting in FTBFS. (Closes: #628280) * Updated standards. * Add -Wl,--as-needed to LDFLAGS.

    2010-07-04 - Roberto Lumbreras <rover@debian.org> slirp (1:1.0.17-4) unstable; urgency=low * Fix crash on amd64 when enabling file logging. (Closes: #587907) * Updated standards. * Switch to dpkg-source 3.0 (quilt) format. * Fix watch file.

    2009-08-29 - Roberto Lumbreras <rover@debian.org> slirp (1:1.0.17-3) unstable; urgency=low * Updated standards. * Fix arguements spelling-error-in-binary (lintian). * debian/HOWTO-TEST: use "ssh -t" to force tty allocation. (Closes: #544124)

    2007-08-14 - Roberto Lumbreras <rover@debian.org> slirp (1:1.0.17-2) unstable; urgency=low * Clean up compilation warnings and a few snprintf changes. Use addrlen as socklen_t instead of int. Tested on amd64 and it works. (Closes: #29245) * Switch to cdbs.

    2006-05-18 - Roberto Lumbreras <rover@debian.org> slirp (1:1.0.17-1) unstable; urgency=low * New upstream version. (Closes: #175079) * Add slirp-fullbolt manpage. (Closes: #223920) * Updated standards (no changes).

    2006-01-16 - Roberto Lumbreras <rover@debian.org> slirp (1:1.0.16-3) unstable; urgency=high * Add an epoch to fix hijacking of package by Debian JED group. (Closes: #339578) * Updated standards (no changes).

    2005-03-01 - Roberto Lumbreras <rover@debian.org> slirp (1.0.16-2) unstable; urgency=high * Fix ttyname segfault. Added -fno-strict-aliasing to CFLAGS to avoid incorrect code generation with gcc >= 3.3. (closes:#295832)

    Advertisement
    Advertisement