slice_1.3.8-12_all.deb


Advertisement

Description

slice - Extract out pre-defined slices of an ASCII file

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: slice
Package version: 1.3.8
Package release: 12
Package architecture: all
Package type: deb
Installed size: 84 B
Download size: 19.91 KB
Official Mirror: archive.ubuntu.com
The slice program reads an input file and divide its prepared ASCII contents into possibly overlapping slices. These slices are determined by enclosing blocks which are defined by begin and end delimiters which have to be already in the file. The final output gets calculated by a slice term consisting of slice names, set theory operators and optional round brackets.

Alternatives

    Download

    Binary package: slice_1.3.8-12_all.deb
    Source package: slice

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install slice deb package:
      # sudo apt-get install slice

    Files

    • /usr/bin/slice
    • /usr/share/doc/slice/README
    • /usr/share/doc/slice/changelog.Debian.gz
    • /usr/share/doc/slice/copyright
    • /usr/share/man/man1/slice.1.gz

    Changelog

    2013-05-28 - Axel Beckert <abe@debian.org> slice (1.3.8-12) unstable; urgency=low * Remove non-used include paths (Closes: #690824) * Bump debhelper compatibility to 9 + Update versioned debhelper build-dependency * Switch to source format "3.0 (quilt)" + Remove quilt build-dependency and quilt usage from debian/rules * Revamp debian/rules: + Use dh_auto_{configure,build,install,clean} + Move dh_installdocs parameter to debian/docs + Remove redundant dh_installchangelogs parameter + Finally switch to a dh7 style debian/rules file * Bump Standards-Version to 3.9.4 (no changes) * Fix lintian warning vcs-field-not-canonical * Fix dpkg-gencontrol warning "unused substitution variable ${perl:Depends}" * Update homepage header to point to web.archive.org's version of the Slice homepage. * Clean up debian/copyright + Mention myself as current maintainer. + Update links to external download sources * Remove alternative build-dependency on ancient (if ever existent) perl5 * Apply wrap-and-sort.

    2011-12-18 - Axel Beckert <abe@debian.org> slice (1.3.8-11) unstable; urgency=low * Enable upstream test suite at build time via dh_auto_test * Fix version string in man-page (Closes: #639546) * Bump Standards-Version to 3.9.2 (no changes) * Remove Felipe Augusto van de Wiel (faw) from Uploaders on his own request. * Fix the following lintian warnings: + debian-rules-missing-recommended-target + copyright-refers-to-symlink-license

    2010-06-03 - Axel Beckert <abe@debian.org> slice (1.3.8-10) unstable; urgency=low * Move to collaborative maintenance * Bump Standards-Version to 3.8.4 - Add Vcs-* fields - Add Homepage field - Added support for DEB_BUILD_OPTIONS=noopt * Move over to quilt patch management - Added build dependency on quilt - Added configure target and target dependencies to debian/rules - Added README.source pointing to /usr/share/doc/quilt/README.source - Added debian/source/format containing "1.0" to prevent unwanted automatic conversion to 3.0 source format. * Bump debhelper compatibility to 7 * Fixed the following Lintian warnings: - debhelper-but-no-misc-depends - copyright-without-copyright-notice - spelling-error-in-manpage (debian/patches/fix-spelling-errors.diff)

    2008-01-23 - Luk Claes <luk@debian.org> slice (1.3.8-9) unstable; urgency=low * Remove me as Maintainer.

    2006-10-02 - Luk Claes <luk@debian.org> slice (1.3.8-8) unstable; urgency=medium * Fix build process so that everything gets installed (Closes: #390631).

    2006-09-30 - Luk Claes <luk@debian.org> slice (1.3.8-7) unstable; urgency=low * New maintainers. * Bumped Standards-Version to 3.7.2. * Updated debian/watch to version=3 and new upstream location. * Add debian/compat for debhelper 4. * Completed debian/copyright.

    2003-09-12 - Denis Barbier <barbier@debian.org> slice (1.3.8-6) unstable; urgency=low * Output files are opened via IO::File as are input files. Closes: Bug#179485 Thanks to Eduard Bloch * debian/control: Old homepage is no more maintained, remove it from the description. * Bump Standards-Version: 3.6.1 and convert this changelog file to UTF-8.

    2002-09-17 - Denis Barbier <barbier@debian.org> slice (1.3.8-5) unstable; urgency=low * Bit::Vector is now a Debian package, so add a Depends and Build-Depends-Indep against libbit-vector-perl. * Replace Architecture: 'any' by 'all', since slice does no more ship compiled modules. * There is also no need to depend on perl 5.8 (Closes: #161132)

    2002-08-25 - Denis Barbier <barbier@debian.org> slice (1.3.8-4) unstable; urgency=low * Rebuild with perl 5.8

    2002-04-21 - Denis Barbier <barbier@debian.org> slice (1.3.8-3) unstable; urgency=low * File operations are checked, and slice aborts if an error is detected.

    Advertisement
    Advertisement