slashem_0.0.7E7F3-7build1_i386.deb


Advertisement

Description

slashem - variant of Nethack

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: slashem
Package version: 0.0.7E7F3
Package release: 7build1
Package architecture: i386
Package type: deb
Installed size: 2.34 KB
Download size: 931.79 KB
Official Mirror: archive.ubuntu.com
Super Lotsa Added Stuff Hack - Extended Magic (SLASH'EM) is a role-playing game where you control a single character. The interface and gameplay are similar in style to Rogue, ADOM, Angband and, of course, Nethack. You control the actions through the keyboard and view the world from an overhead perspective. The problem: The Amulet of Yendor has been stolen. Not only that but it appears that the Wizard of Yendor (not a nice person), who took the amulet, is hiding in the Dungeons of Doom (not a friendly place). This package contains the basic ASCII interface. For more fancy graphical interfaces see slashem-x11 - Simple graphic interface using Xaw slashem-sdl - Graphical interface usnig SDL slashem-gtk - Graphical interface usnig Gtk

Alternatives

    Download

    Source package: slashem

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install slashem deb package:
      # sudo apt-get install slashem

    Files

    • /usr/games/slashem
    • /usr/lib/games/slashem/slashem
    • /usr/share/doc/slashem/changelog.Debian.gz
    • /usr/share/doc/slashem/copyright
    • /usr/share/doc/slashem/readme.txt.gz
    • /usr/share/doc/slashem/strategy.txt.gz
    • /usr/share/menu/slashem

    Changelog

    2016-02-07 - Matthias Klose <doko@ubuntu.com> slashem (0.0.7E7F3-7build1) xenial; urgency=medium * No-change rebuild for ncurses6 transition.

    2014-05-11 - Vincent Cheng <vcheng@debian.org> slashem (0.0.7E7F3-7) unstable; urgency=medium [ Evgeni Golov ] * Correct Vcs-* URLs to point to anonscm.debian.org [ Vincent Cheng ] * Fix broken macro causing LINUX to not be defined on Linux systems. (Closes: #747274) * Fix FTBFS with clang. (Closes: #741371) * Add native systemd support. - Factor out the recovery logic from the slashem-common init script into a new script /usr/lib/games/slashem/recover-all. - Add a slashem-common.service invoking recover-all. This service uses ConditionPathExistsGlob to only launch when files exist to recover, avoiding any extra processes at startup in the common case. - Build-Depends: debhelper (>= 9.20130504) for systemd support in dh_installinit. - Changes based on Josh Triplett's patchset for nethack systemd support. * Update my email address. * Update to Standards version 3.9.5.

    2012-05-18 - Vincent Cheng <Vincentc1208@gmail.com> slashem (0.0.7E7F3-6) unstable; urgency=low * Modify debian/patches/slashem-debian.patch to link explicitly with -lm to fix FTBFS on hurd. * Add lintian override for menu-command-not-in-package in slashem-x11 (unintentionally removed in last upload).

    2012-05-17 - Vincent Cheng <Vincentc1208@gmail.com> slashem (0.0.7E7F3-5) unstable; urgency=low * Modify debian/patches/slashem-debian.patch to fix FTBFS on kfreebsd (and maybe on hurd). (Closes: #672810) - Workaround FTBFS by disabling optimization (on non-Linux archs). * Add DEP-3 patch headers to existing patches. * Switch to dh 7 "rules.tiny" style debian/rules. * Enable build hardening. * Remove unused lintian overrides (menu-icon-missing).

    2012-05-10 - Vincent Cheng <Vincentc1208@gmail.com> slashem (0.0.7E7F3-4) unstable; urgency=low * Add debian/patches/fix-libpng15-ftbfs.patch to fix FTBFS with libpng 1.5. (Closes: #649807) * Replace build-depends on libpng12-dev with libpng-dev. (Closes: #662505) * Add build-depends on zlib1g-dev. * Update Format header in debian/copyright to latest DEP-5 revision. * Fix syntax errors caught by lintian in debian/copyright. * Update Standards version from 3.9.2 to 3.9.3, no changes required. * Update debhelper compatiblity level from 8 to 9.

    2011-07-13 - Vincent Cheng <Vincentc1208@gmail.com> slashem (0.0.7E7F3-3) unstable; urgency=low * Adopt package; change maintainer field in debian/control to: Debian Games Team <pkg-games-devel@lists.alioth.debian.org>. (Closes: #632995) * Add myself to uploaders. * Update debian/copyright to conform to DEP-5. * Add Vcs-* entries in debian/control. * Added Homepage: field in debian/control. * Update source format to "3.0 (quilt)". * Migrate existing diff to quilt (debian/patches/slashem-debian.patch). * Update Standards version from 3.8.3 to 3.9.2, no changes required. * Update debhelper compatiblity level from 7 to 8. * Fix existing lintian errors/warnings. - To fix template-uses-unsplit-choices, a versioned build dependency on po-debconf (>= 1.0) has been added. - A new patch named "spelling-error.patch", added to debian/patches/. * Include Danish translation of slashem's debconf template, thanks to Joe Dalton. (Closes: #603212) * Fix a small typo in slashem-x11's desktop entry file. (Closes: #626768)

    2009-10-14 - Xavier Oswald <xoswald@debian.org> slashem (0.0.7E7F3-2) unstable; urgency=low * New maintainer is me (Closes: #516883) Thanks Peter Makholm for your work. * debian/control: - Bump Standards-Version to 3.8.3 - Update debelper to 7 * Update debian/compat to 7 * Remove old and uneeded debian/NEWS * Add debian/watch file * Fix segfault using X11 mode (Closes: #142435) * Fix floating point exception (Closes: #80637) * Fix wrong X11 debian menu entry (Closes: #234260)

    Advertisement
    Advertisement