skytools3_3.2.6-4_i386.deb


Advertisement

Description

skytools3 - Skype tools for PostgreSQL replication, londiste and PGQ

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: skytools3
Package version: 3.2.6
Package release: 4
Package architecture: i386
Package type: deb
Installed size: 1.27 KB
Download size: 139.00 KB
Official Mirror: archive.ubuntu.com
This is a package of tools in use in Skype for replication and failover. It contains the Londiste and PGQ services and scripts to run.

Alternatives

    Download

    Source package: skytools3

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install skytools3 deb package:
      # sudo apt-get install skytools3

    Files

    • /etc/skytools.ini
    • /etc/init.d/skytools3
    • /usr/bin/data_maintainer3
    • /usr/bin/londiste3
    • /usr/bin/qadmin
    • /usr/bin/queue_mover3
    • /usr/bin/queue_splitter3
    • /usr/bin/scriptmgr3
    • /usr/bin/simple_consumer3
    • /usr/bin/simple_local_consumer3
    • /usr/bin/skytools_upgrade3
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/__init__.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/compare.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/exec_attrs.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/handler.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/playback.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/repair.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/setup.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/syncer.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/table_copy.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/util.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/handlers/__init__.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/handlers/applyfn.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/handlers/bulk.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/handlers/dispatch.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/handlers/multimaster.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/handlers/qtable.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/handlers/shard.py
    • /usr/lib/python2.7/dist-packages/skytools-3.0/londiste/handlers/vtable.py
    • /usr/share/doc/skytools3/README.Debian
    • /usr/share/doc/skytools3/changelog.Debian.gz
    • /usr/share/doc/skytools3/copyright
    • /usr/share/doc/skytools3/londiste3.html
    • /usr/share/doc/skytools3/qadmin.html
    • /usr/share/doc/skytools3/queue_mover3.html
    • /usr/share/doc/skytools3/queue_splitter3.html
    • /usr/share/doc/skytools3/scriptmgr.html
    • /usr/share/doc/skytools3/simple_consumer3.html
    • /usr/share/doc/skytools3/simple_local_consumer3.html
    • /usr/share/doc/skytools3/skytools3.html
    • /usr/share/doc/skytools3/skytools_upgrade.html
    • /usr/share/man/man1/londiste3.1.gz
    • /usr/share/man/man1/qadmin.1.gz
    • /usr/share/man/man1/queue_mover3.1.gz
    • /usr/share/man/man1/queue_splitter3.1.gz
    • /usr/share/man/man1/scriptmgr3.1.gz
    • /usr/share/man/man1/simple_consumer3.1.gz
    • /usr/share/man/man1/simple_local_consumer3.1.gz
    • /usr/share/man/man1/skytools_upgrade3.1.gz
    • /usr/share/skytools3/londiste.sql
    • /usr/share/skytools3/londiste.upgrade.sql
    • /usr/share/skytools3/londiste.upgrade_2.1_to_3.1.sql
    • /usr/share/skytools3/pgq.sql
    • /usr/share/skytools3/pgq.upgrade.sql
    • /usr/share/skytools3/pgq.upgrade_2.1_to_3.0.sql
    • /usr/share/skytools3/pgq_coop.sql
    • /usr/share/skytools3/pgq_coop.upgrade.sql
    • /usr/share/skytools3/pgq_ext.sql
    • /usr/share/skytools3/pgq_ext.upgrade.sql
    • /usr/share/skytools3/pgq_node.sql
    • /usr/share/skytools3/pgq_node.upgrade.sql

    Changelog

    2016-01-14 - Martin Pitt <mpitt@debian.org> skytools3 (3.2.6-4) unstable; urgency=medium * Build for PostgreSQL 9.5.

    2015-03-04 - Marco Nenciarini <mnencia@debian.org> skytools3 (3.2.6-3) unstable; urgency=medium * Install missing skytools_upgrade3 command and manpage

    2015-03-02 - Marco Nenciarini <mnencia@debian.org> skytools3 (3.2.6-2) unstable; urgency=medium * Change the init script to create transient data directories owned by the user running the daemon

    2015-02-27 - Marco Nenciarini <mnencia@debian.org> skytools3 (3.2.6-1) unstable; urgency=medium * New upstream version. * Updated watch file. Github repository is the authoritative source. * Remove upstream patch a0f3c0e169ad19ab8486bbb95855132550f905c2 * Configure git-buildpackage to work with submodules. * debian/control: Add myself to Uploaders field * Updated Standards-Version to 3.9.6 (no changes) * Add tests-invalid-echo.patch: Fix invalid "off" value for \set ECHO to "none". Fixes test regression with PostgreSQL 9.4.1. Thanks to Martin Pitt <martin.pitt@ubuntu.com> (Closes: 777524) * Add tests-ticker-missing-installcheck.patch: Fix missing installcheck target in ticker Makefile

    2014-08-13 - Christoph Berg <myon@debian.org> skytools3 (3.2-2) unstable; urgency=medium * Remove /var/{log,run}/skytools on purge. Spotted by piuparts. * Move to dh-python2. Suggested by lintian.

    2014-07-28 - Christoph Berg <myon@debian.org> skytools3 (3.2-1) unstable; urgency=medium * Build against PostgreSQL 9.4. * New upstream version. * Set team as maintainer. * Use "all" in debian/pgversions and B-D on pg-server-dev-all 148. * Generate debian/postgresql-*-pgq3.* at build time. * Pull a0f3c0e169ad19ab8486bbb95855132550f905c2 from upstream to fix londiste regression tests.

    2014-02-26 - Christoph Berg <myon@debian.org> skytools3 (3.1.5-1) unstable; urgency=medium * New upstream version. * Include orig-lib.tar.gz for the libusual submodule. * Add watch file. * Point Vcs at packaging git on git.d.o. * Add "9.3" in debian/pgversions. * Correctly remove alternatives on remove, spotted by Andreas Beckmann. (Closes: #700706) * Run installcheck using autopkgtest (needs trust auth). + Accept alternative londiste_provider result (- vs %2d).

    2013-02-08 - Christoph Berg <myon@debian.org> skytools3 (3.1.3-1) experimental; urgency=low * New upstream version. * Includes packaging fixes from Dimitri and Marko. * Properly uses pg_buildext (Closes: #644540, #694030) * Depends on python-psycopg2 (Closes: #652344)

    2011-10-11 - Dimitri Fontaine <dim@tapoueh.org> skytools3 (3.0~rc2-1) experimental; urgency=low * Fix skytools3-walmgr dependencies (support 9.1) * Bug fixes upstream

    2011-07-06 - Dimitri Fontaine <dim@tapoueh.org> skytools3 (3.0~rc1-2) experimental; urgency=low * Add automake to the Build Depends (Closes: #632574) * Merge with upstream

    Advertisement
    Advertisement