sip-tester_3.2-1.1_i386.deb


Advertisement

Description

sip-tester - Performance testing tool for the SIP protocol

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: sip-tester
Package version: 3.2
Package release: 1.1
Package architecture: i386
Package type: deb
Installed size: 556 B
Download size: 141.75 KB
Official Mirror: archive.ubuntu.com
sip-tester is a test tool and traffic generator for the SIP protocol. It can be used to test SIP equipment like SIP proxies, SIP media servers, etc. and to emulate user agents calling a SIP system. Its features are: * a few basic SipStone user agent scenarios included * custom XML scenario files even for complex call flows * comprehensive set of real-time statistics * TCP and UDP transport * dynamically adjustable call rates - send RTP traffic This software is distributed as SIPp by its authors. SIP is the Session Initiation Protocol, a standard signalling protocol for initiating, modifying, and terminating Internet conferencing, telephony (VoIP - Voice over IP), video, and instant messaging. This package has been built for distributed pauses with the GNU Scientific Libraries.

Alternatives

    Download

    Source package: sip-tester

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install sip-tester deb package:
      # sudo apt-get install sip-tester

    Files

    • /usr/bin/sipp
    • /usr/share/doc/sip-tester/README.Debian
    • /usr/share/doc/sip-tester/README.txt
    • /usr/share/doc/sip-tester/changelog.Debian.gz
    • /usr/share/doc/sip-tester/copyright
    • /usr/share/man/man1/sipp.1.gz

    Changelog

    2016-01-26 - Mattia Rizzolo <mattia@debian.org> sip-tester (1:3.2-1.1) unstable; urgency=medium * Non-maintainer upload. [ Bas Couwenberg ] * Update build dependencies for GSL 2, change libgsl0-dev to libgsl-dev. Closes: #807226

    2011-11-03 - Mark Purcell <msp@debian.org> sip-tester (1:3.2-1) unstable; urgency=low [ Paul Belanger ] * New Upstream Release (Closes: #623915). * Switch to dpkg-source 3.0 (quilt) format * Building with PCAP play. * Switch back to Debhelper. * debian/patches/spelling-error-in-binary: Fix lintian warning [ Mark Purcell ] * Drop pabs from Uploaders: at his request * fix debhelper-overrides-need-versioned-build-depends * fix description-synopsis-starts-with-article

    2010-06-15 - Mark Purcell <msp@debian.org> sip-tester (1:3.1-3) unstable; urgency=low * Fix "pkg-config: command not found" Added Build-Depends: (Closes: #585904)

    2010-06-14 - Mark Purcell <msp@debian.org> sip-tester (1:3.1-2) unstable; urgency=low * Really Build-Depends: libgsl0-dev - thks pabs & Nobuhuro (Closes: #585820) * Refresh enable-gls.patch

    2010-06-13 - Mark Purcell <msp@debian.org> sip-tester (1:3.1-1) unstable; urgency=low * New Upstream Release - (Closes: #510663) * Update debian/watch - (Closes: #450035) * Switch Maintainer: Debian VoIP Team pkg-voip-maintainers - Thanks & Welcome ARAKI Yasuhiro * Switch to cdbs - Added ${misc:Depends} * Update to Standards 3.8.0: - Add Homepage: - Add Vcs- headers - debian/compat -> 7 * Update debian/copyright * debian/patches/include-limits.patch * Drop OpenSSL support - Build-Conflicts: libssl-dev - possible-gpl-code-linked-with-openssl - Fixes "GPL code linked with OpenSSL without permission" (Closes: #581069) * Add resonable man page with help2man - sipp.1 (Closes: #581067) * Enable GLS - Build-Depends: & enable-gsl.patch (Closes: #581335)

    2010-01-23 - ARAKI Yasuhiro <ar@debian.org> sip-tester (3.1.r590-1) unstable; urgency=low * New upstream release

    2009-03-20 - ARAKI Yasuhiro <ar@debian.org> sip-tester (3.1.r577-1) unstable; urgency=low * New upstream release (from svn trunk tree. Version 577).

    2008-05-04 - Nico Golde <nion@debian.org> sip-tester (2.0.1-1.2) unstable; urgency=high * Non-maintainer upload by the Security Team. * CVE-2008-1959: Fix stack-based buffer overflow in the get_remote_video_port_media function * CVE-2008-2085: Fix stack-baseed buffer overflow in the get_remote_ip_media and get_remote_ipv6_media functions which lead to arbitrary code execution (Closes: #479039).

    2008-03-10 - Thomas Viehmann <tv@beamnet.de> sip-tester (2.0.1-1.1) unstable; urgency=low * Non-maintainer upload. * Change ifdef to detect Tru64 unix. Thanks to Falk Hueffner. Closes: #431308

    2007-05-16 - ARAKI Yasuhiro <ar@debian.org> sip-tester (2.0.1-1) unstable; urgency=low * New upstream release

    Advertisement
    Advertisement