simgrid-java_3.11.1-10ubuntu1_i386.deb


Advertisement

Description

simgrid-java - Java bindings for the SimGrid Toolkit

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: simgrid-java
Package version: 3.11.1
Package release: 10ubuntu1
Package architecture: i386
Package type: deb
Installed size: 1.56 KB
Download size: 1.46 MB
Official Mirror: archive.ubuntu.com
SimGrid is a toolkit that provides core functionalities for the simulation of distributed applications in heterogeneous distributed environments. SimGrid can be used as a Grid simulator, a P2P simulator, a Cloud simulator, a MPI simulator, or a mix of all of them. The typical use-cases of SimGrid include heuristic evaluation, application prototyping, and real application development and tuning. This package contains all what you need to use SimGrid from the Java programming language. Note that the jarfile contained in this package will only work on the architecture it is compiled for (as opposed to the jarfile proposed on the project web page that should work on all architecture).

Alternatives

Conflicts

  • simgrid << 3.11

    Download

    Source package: simgrid

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install simgrid-java deb package:
      # sudo apt-get install simgrid-java

    Files

    • /usr/lib/libsimgrid-java.so.3.11
    • /usr/share/doc/simgrid-java/changelog.Debian.gz
    • /usr/share/doc/simgrid-java/copyright
    • /usr/share/java/simgrid.jar

    Changelog

    2015-08-04 - Iain Lane <iain@orangesquash.org.uk> simgrid (3.11.1-10ubuntu1) wily; urgency=medium * Rename library packages for g++5 ABI transition.

    2015-06-29 - Martin Quinson <mquinson@debian.org> simgrid (3.11.1-10) unstable; urgency=medium * Set HTML_TIMESTAMP to NO and gzip -n to make package reproducible. Patch by akira <marivalenm@gmail.com>, many thanks (Closes: #789715).

    2014-12-13 - Martin Quinson <mquinson@debian.org> simgrid (3.11.1-9) unstable; urgency=medium * add some dependencies to really fix #755047: - libsimgrid-dev breaks libsimgrid3.10 and libsimgrid3.11 (<<3.11.1-8) - libsimgrid3.11 breaks+replaces libsimgrid3.10 - This should hint apt about how to solve my mess :-(

    2014-12-09 - Martin Quinson <mquinson@debian.org> simgrid (3.11.1-8) unstable; urgency=medium * d/c: update VCS to not use any deprecated URLs * d/c: improve short descriptions * d/c: libsimgrid-java suggests java-virtual-machine, captain obvious. * Install tesh and graphicator tools as part of the libsimgrid-dev, not as part of libsimgrid3.11 to allow the co-installation of several library versions (Closes: #755047). * d/p/fix-bashism.diff: fix a bashism that mainly appears on Mac OSX (Closes: #772329).

    2014-07-05 - Martin Quinson <mquinson@debian.org> simgrid (3.11.1-7) unstable; urgency=medium * Disable LTO on all non-AMD architectures to circumvent a seemingly bug in gcc 4.9. * Re-enable parallel builds now that LTO issues are (hopefully) fixed.

    2014-06-29 - Martin Quinson <mquinson@debian.org> simgrid (3.11.1-6) unstable; urgency=medium * gcc-ar does not seem to work with LTO on non-amd architectures, so kill our static lib and switch back to regular ar, just to see.

    2014-06-27 - Martin Quinson <mquinson@debian.org> simgrid (3.11.1-5) unstable; urgency=medium * d/p/fix-java-multiple-definitions.diff: fix java files being declared twice on cmd line: this makes some architectures to fail. (patch taken upstream).

    2014-06-26 - Martin Quinson <mquinson@debian.org> simgrid (3.11.1-4) unstable; urgency=medium * d/p/make_doc: diable the generation of pdf documentation as it does not add much over the html documentation, but breaks on hurd. * Disable again the parallel build to see if it helps gcc to have LTO.

    2014-06-22 - Martin Quinson <mquinson@debian.org> simgrid (3.11.1-3) unstable; urgency=medium * Disable LTO on kfreebsd and sparc, gcc keeps failing because of this.

    2014-06-18 - Martin Quinson <mquinson@debian.org> simgrid (3.11.1-2) unstable; urgency=medium * Drop build-dep on libpcre3-dev, long time no use. * Build-depend on texlive-font-utils to have epstopdf. * d/p/fix-swig-constness.diff: fix constness issues on kfreebsd and sparc. (patch taken upstream) * d/p/fix-with-gcc-4.9.diff: use gcc-ar and gcc-ranlib instead of ar and ranlib for gcc >=4.9 (patch taken upstream)

    Advertisement
    Advertisement