sigil_0.9.5+dfsg-0ubuntu1_i386.deb


Advertisement

Description

sigil - multi-platform ebook editor

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: sigil
Package version: 0.9.5+dfsg
Package release: 0ubuntu1
Package architecture: i386
Package type: deb
Installed size: 5.07 KB
Download size: 1.61 MB
Official Mirror: archive.ubuntu.com
Sigil is a free, open source, multi-platform ebook editor. It is designed to edit books in ePub format. Features: * Full UTF-16 support; * Full EPUB 2 spec support; * Multiple Views: Book View, Code View and Preview View; * WYSIWYG editing in Book View; * Complete control over directly editing EPUB syntax in Code View; * Table of Contents generator with multi-level heading support; * Metadata editor with full support for all possible metadata entries (more than 200) with full descriptions for each; * User interface translated into many languages; * Spell checking with default and user configurable dictionaries; * Full Regular Expression (PCRE) support for Find & Replace; * Supports import of EPUB and HTML files, images, and style sheets; * Files can be validated for EPUB compliance with the FlightCrew validator; * HTML Tidy: all imported files have their formatting corrected, and your editing can be optionally cleaned.

Alternatives

    Download

    Source package: sigil

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install sigil deb package:
      # sudo apt-get install sigil

    Files

    • /usr/bin/sigil
    • /usr/lib/sigil/libsigilgumbo.so
    • /usr/lib/sigil/sigil
    • /usr/share/applications/sigil.desktop
    • /usr/share/doc/sigil/changelog.Debian.gz
    • /usr/share/doc/sigil/copyright
    • /usr/share/man/man1/sigil.1.gz

    Changelog

    2016-03-27 - Mattia Rizzolo <mattia@debian.org> sigil (0.9.5+dfsg-0ubuntu1) xenial; urgency=medium * Upload to ubuntu.

    2016-03-27 - Mattia Rizzolo <mattia@debian.org> sigil (0.9.5+dfsg-1) UNRELEASED; urgency=medium * [7ed6c2e] Imported Upstream version 0.9.5+dfsg * debian/control: + [ae08fdf] stop recommending a specific python3 version. Closes: #812602 + [132205e] use https in Vcs-Git. + [ec2d99c] bump Standards-Version to 3.9.7, no changes needed. * [561c379] debian/copyright: update years. * [7967fbb] debian/watch: use the tarball manually uploaded by upstream.

    2016-01-19 - Mattia Rizzolo <mattia@debian.org> sigil (0.9.2+dfsg+dfsg-2) unstable; urgency=medium * [2c7b008] debian/clean: files moved, so update the list of files to remove. * [adca4b7] Use dh_python3 to compute python dependencies, etc. * debian/control: + [9bd47bb] Recommends some python3 modules used by the test plugin. + [b4ef59b] Build using the default python version. Closes: #810872

    2015-12-19 - Mattia Rizzolo <mattia@debian.org> sigil (0.9.2+dfsg+dfsg-1) unstable; urgency=medium * [19a5e34] debian/{control,copyright}: use my @debian.org email address * [4b7b293] Imported Upstream version 0.9.2+dfsg+dfsg + [f0192e8] debian/patches/switch-to-QTemporaryDir: remove.

    2015-12-03 - Mattia Rizzolo <mattia@mapreri.org> sigil (0.9.1+dfsg-2) unstable; urgency=medium * [5c55628] debian/patches/switch-to-QTemporaryDir: take commit from upstream to have a race-free, privacy-ok temporary directory implementation.

    2015-11-29 - Mattia Rizzolo <mattia@mapreri.org> sigil (0.9.1+dfsg-1) unstable; urgency=medium * [5fab6a8] Imported Upstream version 0.9.1+dfsg. * [9d62545] d/patches/{multiarch,reproducible-build}: drop, applied upstream.

    2015-11-19 - Mattia Rizzolo <mattia@mapreri.org> sigil (0.9.0+dfsg-3) unstable; urgency=medium * [1433219] debian/control: remove a bunch of Build-Dependencies not needed anymore. Thanks to KevinH (upstream developer) for noticing. * [d527ac3] debian/patches/multiarch: mark the patch as forwarded. * [155dae8] debian/patches/reproducible-build: apply patch to get sigil build reproducibly. The order of the linking was dependent on readdir() order, so sort the list of sources before everything. Thanks to Reiner Herrmann <reiner@reiner-h.de> for the patch. Closes: #805500

    2015-11-16 - Mattia Rizzolo <mattia@mapreri.org> sigil (0.9.0+dfsg-2) unstable; urgency=medium * [7ecedd6] debian/patch/multarch: allow finding the python lib everywhere, fix FTBFS on !amd64 and !i386. * [b70e6d7] debian/control: Let sigil depend on libhunspell-dev. The plugin system looks for libhunspell.so directly, so we need the symlink provided by this. Closes: #804887 * [5bf179b] debian/rules: fix extra-license-file lintian warning.

    Advertisement
    Advertisement