shibboleth-sp2-utils_2.5.3+dfsg-2.1build1_i386.deb


Advertisement

Description

shibboleth-sp2-utils - Federated web single sign-on system (daemon and utilities)

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: shibboleth-sp2-utils
Package version: 2.5.3+dfsg
Package release: 2.1build1
Package architecture: i386
Package type: deb
Installed size: 232 B
Download size: 62.01 KB
Official Mirror: archive.ubuntu.com
The Shibboleth System is a standards based software package for web single sign-on across or within organizational boundaries. It supports authorization and attribute exchange using the OASIS SAML 2.0 protocol. Shibboleth allows sites to make informed authorization decisions for individual access of protected online resources while allowing users to establish their identities with their local authentication systems. This package contains the daemon that handles attribute requests and maintains session informtion for the SP. It is used internally by the Apache module (libapache2-mod-shib2), but may be useful independently in some circumstances. It also contains some other useful Shibboleth SP utility programs and the FastCGI authorizer and responder.

Alternatives

Replaces

  • libapache2-mod-shib2 << 2.5.3+dfsg

    Download

    Source package: shibboleth-sp2

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install shibboleth-sp2-utils deb package:
      # sudo apt-get install shibboleth-sp2-utils

    Files

    • /etc/default/shibd
    • /etc/init.d/shibd
    • /usr/bin/mdquery
    • /usr/bin/resolvertest
    • /usr/bin/shib-metagen
    • /usr/lib/i386-linux-gnu/shibboleth/shibauthorizer
    • /usr/lib/i386-linux-gnu/shibboleth/shibresponder
    • /usr/sbin/shib-keygen
    • /usr/sbin/shibd
    • /usr/share/doc/shibboleth-sp2-utils/NOTICE.txt
    • /usr/share/doc/shibboleth-sp2-utils/changelog.Debian.gz
    • /usr/share/doc/shibboleth-sp2-utils/copyright
    • /usr/share/man/man1/mdquery.1.gz
    • /usr/share/man/man1/resolvertest.1.gz
    • /usr/share/man/man1/shib-metagen.1.gz
    • /usr/share/man/man8/shib-keygen.8.gz
    • /usr/share/man/man8/shibd.8.gz

    Changelog

    2015-08-10 - Steve Langasek <steve.langasek@ubuntu.com> shibboleth-sp2 (2.5.3+dfsg-2.1build1) wily; urgency=medium * No-change rebuild against libxml-security-c17v5

    2015-07-13 - Matthias Klose <doko@debian.org> shibboleth-sp2 (2.5.3+dfsg-2.1) unstable; urgency=medium * Non maintainer upload. * Call cpp with -P for boost config. Closes: #778117.

    2015-03-24 - Ferenc Wagner <wferi@niif.hu> shibboleth-sp2 (2.5.3+dfsg-2) unstable; urgency=high * Incorporate security fix from V2.5.4 for CVE-2015-2684: authenticated denial of service vulnerability that results in a crash on certain kinds of malformed SAML messages.

    2014-03-31 - Russ Allbery <rra@debian.org> shibboleth-sp2 (2.5.3+dfsg-1) unstable; urgency=medium * New upstream release. - Fix server-side includes and directory indexes with Basic authentication when the Shibboleth module is loaded. - Fix preserved POST data size limit enforcement. - Fix POST data replay if a submit key is present. - Fix support for idpHistoryProps in Sessions. * Split libshibsp-plugins, shibboleth-sp2-common, and shibboleth-sp2-utils packages off of libapache2-mod-shib2, and merge shibboleth-sp2-schemas with shibboleth-sp2-common. shibboleth-sp2-schemas becomes a transitional package. shibboleth-sp2-common contains the configuration, which is also required by the shared library. shibboleth-sp2-utils contains the shibd daemon plus the other utility commands that were in libapache2-mod-shib2. libshibsp-plugins contains the library plugins (which eventually should be installed in a per-SONAME path and then be merged back with the library package). (Closes: #740603) * Move /usr/include/shibsp/paths.h to the architecture-specific include directory, since it varies by architecture. Thanks, Andreas Beckmann. (Closes: #720036) * Disable the forcing of --silent mode in Libtool since Debian build log analysis wants verbose logs. * Stop symlinking the minimized jQuery installed by Doxygen and remove the dependency on libjs-jquery. The Doxygen maintainers recommend against this approach since this file is apparently not just a straight copy of jQuery. * Remove the now-unnecessary dh_builddeb override to use xz compression. * Remove unnecessary dh_installinit parameters. update-rc.d now uses LSB headers exclusively and no longer pays attention to any runlevel information on the command line. * Convert all Debian patches to separate patch files managed via gbp pq. * Update standards version to 3.9.5 (no changes required).

    2013-07-14 - Russ Allbery <rra@debian.org> shibboleth-sp2 (2.5.2+dfsg-2) unstable; urgency=low * Upload to unstable.

    Advertisement
    Advertisement