shake_1.0.2-1_all.deb


Advertisement

Description

shake - Testing engine for the Lua language version 5.1

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: shake
Package version: 1.0.2
Package release: 1
Package architecture: all
Package type: deb
Installed size: 116 B
Download size: 23.27 KB
Official Mirror: archive.ubuntu.com
The shake utility is a simple and transparent test engine for Lua. Shake gives concise reports when the tests succeed, while it prints detailed traces when tests fail. Regular Lua test files, if written using only standard assert and print calls, can be run with shake with no modifications. This package contains the shake command line utility, the Lua modules that implement shake functionalities and the documentation for both.

Alternatives

    Download

    Binary package: shake_1.0.2-1_all.deb
    Source package: shake

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install shake deb package:
      # sudo apt-get install shake

    Files

    • /usr/bin/shake
    • /usr/share/doc/shake/changelog.Debian.gz
    • /usr/share/doc/shake/copyright
    • /usr/share/doc/shake/doc/us/doc.css
    • /usr/share/doc/shake/doc/us/examples.html
    • /usr/share/doc/shake/doc/us/index.html
    • /usr/share/doc/shake/doc/us/license.html
    • /usr/share/doc/shake/doc/us/manual.html
    • /usr/share/doc/shake/doc/us/shake.png
    • /usr/share/lua/5.1/shake.lua
    • /usr/share/lua/5.1/shake/stir.lua
    • /usr/share/man/man1/shake.1.gz

    Changelog

    2012-05-30 - Enrico Tassi <gareuselesinge@debian.org> shake (1.0.2-1) unstable; urgency=low * New upstream snapshot * Packaging moved to git * Transitional packages removed * Depend on lua-leg >= 0.1.3 (Closes: #719374)

    2012-05-30 - Enrico Tassi <gareuselesinge@debian.org> shake (1.0.1-7) unstable; urgency=low * switch to dh 7 * bumped standards-version to 3.9.3, no changes * dependencies fixed

    2011-07-21 - Enrico Tassi <gareuselesinge@debian.org> shake (1.0.1-6) unstable; urgency=low * source format 3.0 quilt * bumped standards-version to 3.9.2, no changes

    2009-07-21 - Enrico Tassi <gareuselesinge@debian.org> shake (1.0.1-5) unstable; urgency=low * bumped standards-version to 3.8.2, no changes * lua -> Lua in control file * added misc:Depends to Depends

    2008-03-19 - Enrico Tassi <gareuselesinge@debian.org> shake (1.0.1-4) unstable; urgency=low * patch to fix the return code sync with upstream

    2008-01-21 - Enrico Tassi <gareuselesinge@debian.org> shake (1.0.1-3) unstable; urgency=low * Use lua5.1 as interpreter and not lua

    2008-01-19 - Enrico Tassi <gareuselesinge@debian.org> shake (1.0.1-2) unstable; urgency=low * better package description * added patch to make the script return 1 if fail count is greater then 0 (Closes: #457786)

    2007-12-20 - Enrico Tassi <gareuselesinge@debian.org> shake (1.0.1-1) unstable; urgency=low * Initial release. (Closes: #457220)

    Advertisement
    Advertisement