selinux_0.11_all.deb


Advertisement

Description

selinux - Security-Enhanced Linux runtime support

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: selinux
Package version: 0.11
Package release:
Package architecture: all
Package type: deb
Installed size: 82 B
Download size: 10.95 KB
Official Mirror: archive.ubuntu.com
This package provides the minimal scripts necessary to run a Security-Enhanced Linux (SELinux) system.

Alternatives

Provides

  • linux-security

Conflicts

  • apparmor
  • linux-security

    Download

    Binary package: selinux_0.11_all.deb
    Source package: selinux

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install selinux deb package:
      # sudo apt-get install selinux

    Files

    • /etc/init/selinux-mounted-dev.conf
    • /etc/init/selinux-mounted-tmp.conf
    • /etc/init/selinux-mounted-varlock.conf
    • /etc/init/selinux-mounted-varrun.conf
    • /etc/init.d/selinux
    • /usr/sbin/update-selinux-config
    • /usr/sbin/update-selinux-policy
    • /usr/share/doc/selinux/README.Debian
    • /usr/share/doc/selinux/changelog.gz
    • /usr/share/doc/selinux/copyright
    • /usr/share/initramfs-tools/scripts/init-bottom/_load_selinux_policy
    • /usr/share/selinux/config.example

    Changelog

    2012-03-14 - Tim Tickel <twt@google.com> selinux (1:0.11) precise; urgency=low * Make update-selinux-policy work when only a base policy module is used. (LP: #955426)

    2011-12-21 - Jamie Strandboge <jamie@ubuntu.com> selinux (1:0.10) precise; urgency=low * Fix unsafe lockfile creation. The scope of this is limited by when this script is run. On Ubuntu 10.10 and higher, Yama blocks exploitation of this issue, but we want to fix this on Ubuntu 10.04 LTS (which doesn't have Yama) and so this package is provided for upgrades. (LP: #876994)

    2010-04-22 - Kees Cook <kees@ubuntu.com> selinux (1:0.9) lucid; urgency=low * mounted-var{run,lock}.upstart, Makefile: add more restorecon calls for tmpfs filesystems, thanks to Stephen Lawrence (LP: #568744).

    2010-04-06 - Kees Cook <kees@ubuntu.com> selinux (1:0.8) lucid; urgency=low * debian/selinux.{preinst,postinst}, Makefile: move /etc/initramfs-tools scripts to /usr/share/initramfs-tools. * load_policy: source functions only in initramfs. * mounted-dev.upstart, Makefile: move restorecon for /dev to upstart job (LP: #556823).

    2010-01-22 - Kees Cook <kees@ubuntu.com> selinux (1:0.7) lucid; urgency=low * Move restorecon for /tmp to an upstart job.

    2009-10-19 - Caleb Case <ccase@tresys.com> selinux (1:0.6) karmic; urgency=low * Recommend policy packages instead of depends to prevent circular dependencies.

    2009-09-09 - Caleb Case <ccase@tresys.com> selinux (1:0.5) karmic; urgency=low * GRUB 2 support, new LSM switching via 'security=' (LP: #428007). * Added ext4 as a valid fs to relabeling script (LP: #371075).

    2009-03-23 - Caleb Case <ccase@tresys.com> selinux (1:0.4) jaunty; urgency=low * Adjusted depends to reflect package rename of selinux-policy-refpolicy to selinux-policy-ubuntu (LP: #352771).

    2008-07-17 - Kees Cook <kees@ubuntu.com> selinux (1:0.3) intrepid; urgency=low * Bump epoch to avoid old Debian "selinux" Conflict in policycoreutils to make selinux installable in Intrepid again.

    2008-02-29 - Caleb Case <ccase@tresys.com> selinux (0.2) hardy; urgency=low * load_policy: - Use load_policy in /sbin instead of /usr/sbin (which may not be mounted yet) (LP: #126415). * update-selinux-policy: - If selinux isn't enabled then do not reload the policy.

    Advertisement
    Advertisement