selinux-utils_2.4-3build2_i386.deb


Advertisement

Description

selinux-utils - SELinux utility programs

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: selinux-utils
Package version: 2.4
Package release: 3build2
Package architecture: i386
Package type: deb
Installed size: 230 B
Download size: 51.42 KB
Official Mirror: archive.ubuntu.com
This package provides various utility programs for a Security-enhanced Linux system. Security-enhanced Linux is a patch of the Linux kernel and a number of utilities with enhanced security functionality designed to add mandatory access controls to Linux. This package provides utility programs to get and set process and file security contexts and to obtain security policy decisions.

Alternatives

    Download

    Source package: libselinux

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install selinux-utils deb package:
      # sudo apt-get install selinux-utils

    Files

    • /usr/sbin/avcstat
    • /usr/sbin/compute_av
    • /usr/sbin/compute_create
    • /usr/sbin/compute_member
    • /usr/sbin/compute_relabel
    • /usr/sbin/compute_user
    • /usr/sbin/getconlist
    • /usr/sbin/getdefaultcon
    • /usr/sbin/getenforce
    • /usr/sbin/getfilecon
    • /usr/sbin/getpidcon
    • /usr/sbin/getsebool
    • /usr/sbin/getseuser
    • /usr/sbin/matchpathcon
    • /usr/sbin/policyvers
    • /usr/sbin/sefcontext_compile
    • /usr/sbin/selinux_check_securetty_context
    • /usr/sbin/selinuxenabled
    • /usr/sbin/selinuxexeccon
    • /usr/sbin/setenforce
    • /usr/sbin/setfilecon
    • /usr/sbin/togglesebool
    • /usr/share/doc/selinux-utils/changelog.Debian.gz
    • /usr/share/doc/selinux-utils/copyright
    • /usr/share/man/man5/booleans.5.gz
    • /usr/share/man/man5/customizable_types.5.gz
    • /usr/share/man/man5/default_contexts.5.gz
    • /usr/share/man/man5/default_type.5.gz
    • /usr/share/man/man5/failsafe_context.5.gz
    • /usr/share/man/man5/file_contexts.5.gz
    • /usr/share/man/man5/file_contexts.homedirs.5.gz
    • /usr/share/man/man5/file_contexts.local.5.gz
    • /usr/share/man/man5/file_contexts.subs.5.gz
    • /usr/share/man/man5/file_contexts.subs_dist.5.gz
    • /usr/share/man/man5/local.users.5.gz
    • /usr/share/man/man5/media.5.gz
    • /usr/share/man/man5/removable_context.5.gz
    • /usr/share/man/man5/secolor.conf.5.gz
    • /usr/share/man/man5/securetty_types.5.gz
    • /usr/share/man/man5/selabel_db.5.gz
    • /usr/share/man/man5/selabel_file.5.gz
    • /usr/share/man/man5/selabel_media.5.gz
    • /usr/share/man/man5/selabel_x.5.gz
    • /usr/share/man/man5/sepgsql_contexts.5.gz
    • /usr/share/man/man5/service_seusers.5.gz
    • /usr/share/man/man5/seusers.5.gz
    • /usr/share/man/man5/user_contexts.5.gz
    • /usr/share/man/man5/virtual_domain_context.5.gz
    • /usr/share/man/man5/virtual_image_context.5.gz
    • /usr/share/man/man5/x_contexts.5.gz
    • /usr/share/man/man8/avcstat.8.gz
    • /usr/share/man/man8/booleans.8.gz
    • /usr/share/man/man8/getenforce.8.gz
    • /usr/share/man/man8/getsebool.8.gz
    • /usr/share/man/man8/matchpathcon.8.gz
    • /usr/share/man/man8/sefcontext_compile.8.gz
    • /usr/share/man/man8/selinux.8.gz
    • /usr/share/man/man8/selinuxenabled.8.gz
    • /usr/share/man/man8/selinuxexeccon.8.gz
    • /usr/share/man/man8/setenforce.8.gz
    • /usr/share/man/man8/togglesebool.8.gz

    Changelog

    2016-03-16 - Matthias Klose <doko@ubuntu.com> libselinux (2.4-3build2) xenial; urgency=medium * No-change rebuild for ruby2.3 support.

    2016-01-19 - Matthias Klose <doko@ubuntu.com> libselinux (2.4-3build1) xenial; urgency=medium * No-change rebuild to drop python3.4 support.

    2015-11-18 - Laurent Bigonville <bigon@debian.org> libselinux (2.4-3) unstable; urgency=medium * Team upload. * Upload to unstable * debian/python.mk: Add $(PYTHON3_VERSIONS) to the PHONY target

    2015-07-10 - Laurent Bigonville <bigon@debian.org> libselinux (2.4-2) experimental; urgency=medium * Team upload. * debian/control: Also bump the dependency against libsepol1-dev to 2.4 * Start building python 3 packages

    2015-06-03 - Laurent Bigonville <bigon@debian.org> libselinux (2.4-1) experimental; urgency=medium * Team upload. * New upstream release - Bump libsepol1-dev build-dependency to >= 2.4 to match the release - Drop d/p/Add-pcre-version-string.patch, d/p/Log-an-error-on-unknown-classes.patch and d/p/libselinux-man-Add-missing-manpage-links-to-security.patch: Applied upstream. - debian/patches/fix-makefile-bugs.patch: Refreshed * debian/watch: Update watch file URL * debian/control: Bump Standards-Version to 3.9.6 (no further changes)

    2014-08-31 - Laurent Bigonville <bigon@debian.org> libselinux (2.3-2) unstable; urgency=medium * Team upload. * Add debian/patches/Add-pcre-version-string.patch: Add pcre version string to the compiled file_contexts format. This is necesarry to detect the cases where the internal libpcre representation has changed, if it's the case libselinux will rely on the non-compiled file (Closes: #756826) * Add debian/patches/Log-an-error-on-unknown-classes.patch: Log an error on unknown classes and permissions. * d/p/libselinux-man-Add-missing-manpage-links-to-security.patch: Add the missing manpage links for selinux_mkload_policy(3) and selinux_init_load_policy(3) (Closes: #753803) * Drop debian/libselinux1.postinst: Reloading systemd during an upgrade in an uncontroled way might endup with unwanted side effects (Closes: #753726)

    2014-05-14 - Laurent Bigonville <bigon@debian.org> libselinux (2.3-1) unstable; urgency=medium * Team upload. * New upstream release - debian/control: Bump {build-}dependencies to match new release - debian/libselinux1.symbols: Add new setexecfilecon() function * debian/ruby.mk: Rework the makefile, it should handle changes in the supported ruby versions by binNMU now (Closes: #747683) * Add Built-Using field for python-selinux as audit2why.so is statically linking against libsepol

    2014-05-02 - Laurent Bigonville <bigon@debian.org> libselinux (2.2.2-2) unstable; urgency=medium * Team upload. [ Laurent Bigonville ] * debian/rules: Do not require ruby or python dh helpers when bootstrapping thanks to Daniel Schepler <dschepler@gmail.com> (Closes: #738148) [ Hideki Yamane ] * debian/{ruby.mk,ruby-selinux.install} - drop related to ruby1.9.1 and add ruby2.1.0 instead (Closes: #746024)

    2014-01-11 - Laurent Bigonville <bigon@debian.org> libselinux (2.2.2-1) unstable; urgency=medium * Team upload. * New upstream release * debian/control: Mark -dev package as Multi-arch: same. (Closes: #732098) * debian/control: Bump Standards-Version to 3.9.5 (no further changes) * debian/rules: Fix cross build, no need for a different prefix.

    2013-11-10 - Laurent Bigonville <bigon@debian.org> libselinux (2.2.1-1) unstable; urgency=low * Team upload. * New upstream release * Drop debian/patches/link_pthread.patch: Upstream disagreed with this solution, this will unfortunately require to rebuild some of the rdependencies

    Advertisement
    Advertisement