scim_1.4.15-6_i386.deb


Advertisement

Description

scim - smart common input method platform

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: scim
Package version: 1.4.15
Package release: 6
Package architecture: i386
Package type: deb
Installed size: 1.65 KB
Download size: 385.15 KB
Official Mirror: archive.ubuntu.com
Smart Common Input Method (SCIM) is an input method (IM) platform. Input methods are needed to enter complex characters in many non-latin languages. SCIM provides a common platform for various plugin modules and independent IM programs, as well as a set of modules and programs on its own. It is highly modularized and exposes abstract interfaces, so that plugin modules with different functions can easily communicate with each other. The currently supported module types are configuration, IM engine, front end, filter, and setup GUI. SCIM achieves the communication between IM engines and front ends through both shared library linking and server/client mode. It supports XIM protocol, as well as GTK+ IM module and Qt IM module. This package is the main binary package of SCIM. It includes: the main program scim (GTK+ based) and other support programs; simple configuration module, X11 front end module, rawcode IM engine module, simplified/traditional Chinese conversion filter module, and their corresponding setup GUI modules; GTK+ panel and its setup GUI module; and a GTK+ based setup tool. SCIM is a well accepted platform and features various input method engines for many languages. In Debian you can find the following separately packaged IMs useful: scim-tables-{additional,ja,ko,zh}, scim-pinyin, scim-uim, scim-m17n, scim-chewing, scim-anthy, scim-canna, scim-prime, and scim-skk. GTK+ users would also find package scim-gtk-immodule useful for GTK+ IM module support. For development on SCIM platform, please see the description of scim-dev package.

Alternatives

    Download

    Binary package: scim_1.4.15-6_i386.deb
    Source package: scim

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install scim deb package:
      # sudo apt-get install scim

    Files

    • /etc/X11/xinit/xinput.d/scim
    • /etc/X11/xinit/xinput.d/scim-immodule
    • /etc/scim/config
    • /etc/scim/global
    • /usr/bin/scim
    • /usr/bin/scim-config-agent
    • /usr/bin/scim-setup
    • /usr/lib/i386-linux-gnu/scim-1.0/scim-helper-launcher
    • /usr/lib/i386-linux-gnu/scim-1.0/scim-helper-manager
    • /usr/lib/i386-linux-gnu/scim-1.0/scim-launcher
    • /usr/lib/i386-linux-gnu/scim-1.0/scim-panel-gtk
    • /usr/lib/i386-linux-gnu/scim-1.0/1.4.0/Config/simple.so
    • /usr/lib/i386-linux-gnu/scim-1.0/1.4.0/Filter/sctc.so
    • /usr/lib/i386-linux-gnu/scim-1.0/1.4.0/FrontEnd/x11.so
    • /usr/lib/i386-linux-gnu/scim-1.0/1.4.0/Helper/setup.so
    • /usr/lib/i386-linux-gnu/scim-1.0/1.4.0/IMEngine/rawcode.so
    • /usr/lib/i386-linux-gnu/scim-1.0/1.4.0/SetupUI/aaa-frontend-setup.so
    • /usr/lib/i386-linux-gnu/scim-1.0/1.4.0/SetupUI/aaa-imengine-setup.so
    • /usr/lib/i386-linux-gnu/scim-1.0/1.4.0/SetupUI/panel-gtk-setup.so
    • /usr/share/applications/scim-setup.desktop
    • /usr/share/bug/scim/script
    • /usr/share/doc/scim/AUTHORS
    • /usr/share/doc/scim/NEWS.Debian.gz
    • /usr/share/doc/scim/README.Debian.gz
    • /usr/share/doc/scim/README.GTK
    • /usr/share/doc/scim/README.Qt
    • /usr/share/doc/scim/README.gz
    • /usr/share/doc/scim/TODO
    • /usr/share/doc/scim/changelog.Debian.gz
    • /usr/share/doc/scim/copyright
    • /usr/share/locale/as/LC_MESSAGES/scim.mo
    • /usr/share/locale/bn_IN/LC_MESSAGES/scim.mo
    • /usr/share/locale/ca/LC_MESSAGES/scim.mo
    • /usr/share/locale/cs/LC_MESSAGES/scim.mo
    • /usr/share/locale/de/LC_MESSAGES/scim.mo
    • /usr/share/locale/es/LC_MESSAGES/scim.mo
    • /usr/share/locale/fi/LC_MESSAGES/scim.mo
    • /usr/share/locale/fr/LC_MESSAGES/scim.mo
    • /usr/share/locale/gu/LC_MESSAGES/scim.mo
    • /usr/share/locale/hi/LC_MESSAGES/scim.mo
    • /usr/share/locale/it/LC_MESSAGES/scim.mo
    • /usr/share/locale/ja/LC_MESSAGES/scim.mo
    • /usr/share/locale/kn/LC_MESSAGES/scim.mo
    • /usr/share/locale/ko/LC_MESSAGES/scim.mo
    • /usr/share/locale/ml/LC_MESSAGES/scim.mo
    • /usr/share/locale/mr/LC_MESSAGES/scim.mo
    • /usr/share/locale/nl/LC_MESSAGES/scim.mo
    • /usr/share/locale/pa/LC_MESSAGES/scim.mo
    • /usr/share/locale/pt_BR/LC_MESSAGES/scim.mo
    • /usr/share/locale/ru/LC_MESSAGES/scim.mo
    • /usr/share/locale/sk/LC_MESSAGES/scim.mo
    • /usr/share/locale/sv/LC_MESSAGES/scim.mo
    • /usr/share/locale/ta/LC_MESSAGES/scim.mo
    • /usr/share/locale/te/LC_MESSAGES/scim.mo
    • /usr/share/locale/vi/LC_MESSAGES/scim.mo
    • /usr/share/locale/zh_CN/LC_MESSAGES/scim.mo
    • /usr/share/locale/zh_TW/LC_MESSAGES/scim.mo
    • /usr/share/man/man1/scim-config-agent.1.gz
    • /usr/share/man/man1/scim-setup.1.gz
    • /usr/share/man/man1/scim.1.gz
    • /usr/share/pixmaps/scim-setup.png
    • /usr/share/scim/icons/down.png
    • /usr/share/scim/icons/full-letter.png
    • /usr/share/scim/icons/full-punct.png
    • /usr/share/scim/icons/half-letter.png
    • /usr/share/scim/icons/half-punct.png
    • /usr/share/scim/icons/help.png
    • /usr/share/scim/icons/keyboard.png
    • /usr/share/scim/icons/left.png
    • /usr/share/scim/icons/menu.png
    • /usr/share/scim/icons/pin-down.png
    • /usr/share/scim/icons/pin-up.png
    • /usr/share/scim/icons/rawcode.png
    • /usr/share/scim/icons/right.png
    • /usr/share/scim/icons/sctc-sc-to-tc.png
    • /usr/share/scim/icons/sctc-tc-to-sc.png
    • /usr/share/scim/icons/sctc.png
    • /usr/share/scim/icons/setup.png
    • /usr/share/scim/icons/trademark.png
    • /usr/share/scim/icons/up.png

    Changelog

    2016-02-21 - Rolf Leggewie <foss@rolf.leggewie.biz> scim (1.4.15-6) unstable; urgency=medium [ Chris Boot ] * scim.prerm: stop failing on two valid arguments. Closes: #813260

    2015-08-06 - Rolf Leggewie <foss@rolf.leggewie.biz> scim (1.4.15-5) unstable; urgency=medium [ Rolf Leggewie ] * control: drop unused Pre-Depends line from a number of binary pkgs [ Matthias Klose ] * Rename libscim8c2a to libscim8v5 for the libstdc++6 triggered ABI change. Closes: #791275. - Add Conflict/Replaces to the old package as necessary - Adjust lintian override files as necessary

    2014-11-10 - Rolf Leggewie <foss@rolf.leggewie.biz> scim (1.4.15-4) experimental; urgency=medium [ Tz-Huan Huang ] * control: multi-archify the scim-im-agent package [ Rolf Leggewie ] * postinst: stop special-casing a long-gone package version

    2014-11-08 - Rolf Leggewie <foss@rolf.leggewie.biz> scim (1.4.15-3) unstable; urgency=medium * prerm: stop calling "ua --remove" on upgrade and deconfigure. See #71621

    2014-10-25 - Rolf Leggewie <foss@rolf.leggewie.biz> scim (1.4.15-2) unstable; urgency=medium * no-change rebuild

    2014-10-23 - Rolf Leggewie <foss@rolf.leggewie.biz> scim (1.4.15-1) unstable; urgency=medium [ Tz-Huan Huang ] * new upstream release 1.4.15 - build successfully with clang instead of gcc. Closes: #750115 - drop 03_backport_964b2221.patch which has landed upstream * debian/control: - bump to policy 3.9.6 - update Homepage - add intltool and autopoint to Build-Depends * debian/rules: - use scim's bootstrap script for dh_autoreconf - make sure that clutter-immodule continues to be built [ Rolf Leggewie ] * patches: backport 88fbabed7dc2 to disable subdir-objects.

    2014-02-08 - Rolf Leggewie <foss@rolf.leggewie.biz> scim (1.4.14-6) unstable; urgency=low [ William Grant ] * control: build with dh-autoreconf instead of autotools-dev for new libtool [ Rolf Leggewie ] * fix spelling mistake in scim-im-agent manpage * control: bump standards version to 3.9.5. no further changes.

    2013-06-16 - Rolf Leggewie <foss@rolf.leggewie.biz> scim (1.4.14-5) unstable; urgency=low * add scim-im-agent man page

    2013-06-15 - Rolf Leggewie <foss@rolf.leggewie.biz> scim (1.4.14-4) unstable; urgency=low [ Rolf Leggewie ] * control: drop obsolete DMUA field [ Tz-Huan Huang ] * patches: backport upstream fix to one compiler warning

    2013-05-11 - Rolf Leggewie <foss@rolf.leggewie.biz> scim (1.4.14-3) unstable; urgency=low * control: - update info about binary package incompatibilities. Closes: #680988 - set scim-clutter-immodule to MA:same - drop inactive co-maintainer - bump to policy 3.9.4 * scim-dev-doc: - let libjs-jquery provide jquery.js instead of shipping our own - stop shipping private copy of FreeSans.ttf * copyright: update my copyright to 2013

    Advertisement
    Advertisement