scanmem_0.13-1_i386.deb


Advertisement

Description

scanmem - Program to locate and modify a variable in a running process

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: scanmem
Package version: 0.13
Package release: 1
Package architecture: i386
Package type: deb
Installed size: 134 B
Download size: 45.68 KB
Official Mirror: archive.ubuntu.com
Scanmem is a simple interactive debugging utility for Linux, used to locate the address of a variable in a running process. This can be used for the analysis or modification of a hostile process on a compromised machine, for reverse engineering, or as a "pokefinder" to cheat at video games.

Alternatives

    Download

    Binary package: scanmem_0.13-1_i386.deb
    Source package: scanmem

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install scanmem deb package:
      # sudo apt-get install scanmem

    Files

    • /usr/bin/scanmem
    • /usr/share/doc/scanmem/README
    • /usr/share/doc/scanmem/TODO
    • /usr/share/doc/scanmem/changelog.Debian.gz
    • /usr/share/doc/scanmem/copyright
    • /usr/share/man/man1/scanmem.1.gz

    Changelog

    2012-11-02 - Kartik Mistry <kartik@debian.org> scanmem (0.13-1) unstable; urgency=low * New upstream release: + Dropped gameconqueror-man-page-fix.diff patch, merged upstream. * debian/control: + Updated Standards-Version to 3.9.3 + Bumped debhelper dependency to >=9 for hardening support. * debian/compat: + Set to 9 for hardening support. * debian/copyright: + Updated to copyright-format 1.0 * debian/rules: + Fixed permission for configure script. * debian/docs: + Do not install old NEWS file.

    2011-07-03 - Kartik Mistry <kartik@debian.org> scanmem (0.12-2) unstable; urgency=low [Kartik Mistry] * debian/rules: + Use dh7 * debian/patches/gameconqueror-man-page-fix.diff: + Added patch to fix gameconqueror.1 manpage mistakes * debian/control: + Removed dependency on cdbs + Updated python dependency for Build-Depends/Depends for dh_python2 use + Updated Standards-Version to 3.9.2

    2011-04-19 - WANG Lu <coolwanglu@gmail.com> scanmem (0.12-1) unstable; urgency=low [WANG Lu] * New upstream release: + Ignore empty values in cheat list + Resizable process lit dialog + Skip when /proc/pid/exe is not available + Run as root now, in order to read remote memory in Ubuntu + Fix a problem with bytearray displaying + Wildcard support in bytearray writing + A memory leak fix + Use monospace font + Fix a string parsing problem [Kartik Mistry] * debian/control: + Updated Standards-Version to 3.9.1 + Fixed package description for gnomeconqueror * debian/copyright: + Added missing author, updated copyright years + Updated to latest DEP-5 specifications

    2010-05-16 - WANG Lu <coolwanglu@gmail.com> scanmem (0.11-1) unstable; urgency=low [WANG Lu] * Fix build on Debian-kfreebsd* (Closes: #578457) * Fix an issue of freezing when scanning for multiple variables * Added a new debian/watch file [Kartik Mistry] * debian/copyright: + Fixed for DEP-5 specifications * debian/gnomeconqueror.manpages: + Fixed manpage path

    2010-04-16 - WANG Lu <coolwanglu@gmail.com> scanmem (0.10-1) unstable; urgency=low [WANG Lu] * New upstream release: + Added GUI for program as GameConqueror, separated binary package * debian/control: + Updated Standards-Version to 3.8.4 + Added Kartik Mistry <kartik@debian.org> as Uploader now + Updated Homepage entry * debian/rules: + Used CDBS to simplyfy rules, dh will follow with next upload [Kartik Mistry] * Added manpage for GameConqueror, debian/gameconqueror.1 * Converted package to use source format 3.0 (quilt)

    2009-09-13 - Kartik Mistry <kartik@debian.org> scanmem (0.07-8) unstable; urgency=low * debian/control: + Build-Depends on libreadline-dev instead of libreadline5-dev + Updated Standards-Version to 3.8.3 + Wrapped up Build-Depends + Updated debhelper dependency to 7.0.50~ + Removed dependency on cdbs, no longer needed as we use dh now * debian/rules: + dh usage instead of cdbs * debian/copyright: + Don't point to versionless symlink in /usr/share/common-licenses

    2009-06-15 - Kartik Mistry <kartik@debian.org> scanmem (0.07-7) unstable; urgency=low * debian/control: + Updated my maintainer email address + Removed Torsten from Uploader as package is not part of bollin + Removed VCS-* fields + Updated Standards-Version to 3.8.1 (no changes needed) * debian/copyright: + [Lintian] Updated to use correct copyright symbol © + Updated Debian copyright information

    2009-02-15 - Torsten Werner <twerner@debian.org> scanmem (0.07-6) unstable; urgency=low * upload to unstable

    2008-12-28 - Torsten Werner <twerner@debian.org> scanmem (0.07-5) experimental; urgency=low [ Kartik Mistry ] * debian/control: + Much better short description, Thanks to adn [ Torsten Werner ] * Bump up Standards-Version: 3.8.0 (no changes).

    Advertisement
    Advertisement