salt-api_2015.8.8+ds-1_all.deb


Advertisement

Description

salt-api - Generic, modular network access system

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name salt-api
Package version 2015.8.8+ds
Package release 1
Package architecture all
Package type deb
Installed size 70 B
Download size 14.26 KB
Official Mirror archive.ubuntu.com
a modular interface on top of Salt that can provide a variety of entry points
into a running Salt system. It can start and manage multiple interfaces
allowing a REST API to coexist with XMLRPC or even a Websocket API.
The Salt API system is used to expose the fundamental aspects of Salt control
to external sources. salt-api acts as the bridge between Salt itself and
REST, Websockets, etc.

Alternatives

Package Version Architecture Repository
salt-api_2015.8.8+ds-1_all.deb 2015.8.8+ds all Ubuntu Universe
salt-api - - -

Requires

Name Value
init-system-helpers >= 1.18~
lsb-base >= 4.1+Debian11ubuntu7
python:any >= 2.6~
salt-master -

Download

Type URL
Binary Package salt-api_2015.8.8+ds-1_all.deb
Source Package salt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install salt-api deb package:
    # sudo apt-get install salt-api

Files

Path
/etc/init/salt-api.conf
/etc/init.d/salt-api
/lib/systemd/system/salt-api.service
/usr/bin/salt-api
/usr/share/doc/salt-api/NEWS.Debian.gz
/usr/share/doc/salt-api/changelog.Debian.gz
/usr/share/doc/salt-api/copyright
/usr/share/man/man1/salt-api.1.gz

Changelog

2016-04-04 - Benjamin Drung <benjamin.drung@profitbricks.com>
salt (2015.8.8+ds-1) unstable; urgency=high
* New upstream release
- CVE-2016-3176: Fix insecure configuration of PAM external
authentication service (Closes: #819184)
* Drop reproducible_builds.patch (accepted upstream)
* Cherry-pick the four patches from 2015.8.8.2
* Re-add shebang to ssh-id-wrapper shell script
2016-02-22 - Benjamin Drung <benjamin.drung@profitbricks.com>
salt (2015.8.7+ds-1) unstable; urgency=medium
* New upstream release.
* Override lintian warning about long link in JavaScript comment.
2016-02-04 - Benjamin Drung <benjamin.drung@profitbricks.com>
salt (2015.8.5+ds-1) unstable; urgency=high
[ Benjamin Drung ]
* Drop patches that were accepted upstream
* Rewrite reproducible patch and sent it to upstream
* Bump Standards-Version to 3.9.7 (no changes needed)
* Ignore false positive source-is-missing lintian error (see #813013)
[ Wolodja Wentland ]
* New upstream release.
- CVE-2016-1866: Improper handling of clear messages on the minion, which
could result in executing commands not sent by the master.
* Add Wolodja Wentland to Uploaders
* Use secure URI for Vcs-Git
2016-01-14 - Benjamin Drung <benjamin.drung@profitbricks.com>
salt (2015.8.3+ds-3) unstable; urgency=medium
* Cherry-pick fix to silence warnings from (not installed) nova client
2015-12-14 - Benjamin Drung <benjamin.drung@profitbricks.com>
salt (2015.8.3+ds-2) unstable; urgency=medium
* salt-master: Depend on python-systemd for the startup notification
unless sysvinit is used as default init system (Closes: #807741,
LP: #1525184)
2015-12-09 - Benjamin Drung <benjamin.drung@profitbricks.com>
salt (2015.8.3+ds-1) unstable; urgency=high
* New upstream release.
- CVE-2015-8034: Fix information leak from state.sls cache data stored as
world-readable (Closes: #807356)
* Drop Fix-OS-related-grains-on-Debian.patch (accepted upstream)
* Use upstream systemd service files (Closes: #806786)
* Extend description of salt-cloud
2015-11-06 - Benjamin Drung <benjamin.drung@profitbricks.com>
salt (2015.8.1+ds-2) unstable; urgency=medium
* Demote python-croniter to recommends (only needed for the schedule state)
* Add missing dependency on python-tornado >= 4.2
* Fix OS related grains on Debian (wrongly named "Debian GNU")
2015-11-05 - Benjamin Drung <benjamin.drung@profitbricks.com>
salt (2015.8.1+ds-1) unstable; urgency=medium
* New upstream release (Closes: #801289)
* debian/repack: Create xz compressed source tarball
* Refresh reproducible_builds patch and refresh remaining patches
* Drop make-log-file-group-readable.patch (applied upstream)
* Require python-crypto (>= 2.6)
* Add a separate salt-proxy package
* Drop patch to support sphinx < 1.3 (sphinx is recent enough in unstable)
* Add myself to uploaders
* Raise compat level to 9
* Update debian/copyright
2015-07-28 - Joe Healy <joehealy@gmail.com>
salt (2015.5.3+ds-1) unstable; urgency=medium
* [e481db1] Imported Upstream version 2015.5.3+ds
* [16f6801] Added salt-minion dependency on bsdmainutils. Closes: 790758
* [761f735] Added dependency on python-croniter. Closes: 771015
* [5b957bb] Weakened dependency on python-mako to suggests.
2015-07-01 - Joe Healy <joehealy@gmail.com>
salt (2015.5.2+ds-1) unstable; urgency=medium
* [e6d32ad] Updated repack script to remove new sphinx theme
* [48bdace] Imported Upstream version 2015.5.2+ds
* [9e98c1c] Updated patches for 2015.5.2 and set doc theme to saltstack

See Also

Package Description
salt-cloud_2015.8.8+ds-1_all.deb public cloud VM management system
salt-common_2015.8.8+ds-1_all.deb shared libraries that salt requires for all packages
salt-doc_2015.8.8+ds-1_all.deb additional documentation for salt, the distributed remote execution system
salt-master_2015.8.8+ds-1_all.deb remote manager to administer servers via salt
salt-minion_2015.8.8+ds-1_all.deb client package for salt, the distributed remote execution system
salt-proxy_2015.8.8+ds-1_all.deb Proxy client package for salt stack
salt-ssh_2015.8.8+ds-1_all.deb remote manager to administer servers via Salt SSH
salt-syndic_2015.8.8+ds-1_all.deb master-of-masters for salt, the distributed remote execution system
sam2p_0.49.2-3_i386.deb convert raster images to EPS, PDF, and other formats
samba-testsuite_4.3.8+dfsg-0ubuntu1_i386.deb test suite from Samba
samdump2_3.0.0-3_i386.deb Dump Windows 2k/NT/XP password hashes
samhain_3.1.0-7build1_i386.deb Data integrity and host intrusion alert system
samizdat_0.7.0-2_all.deb Web collaboration and open publishing engine
samplerate-programs_0.1.8-8_i386.deb Sample programs that use libsamplerate
samplv1_0.7.1-1_i386.deb polyphonic sampler synthesizer
Advertisement
Advertisement