ryu-bin_3.30+dfsg1-1ubuntu2_all.deb


Advertisement

Description

ryu-bin - software defined networking framework - ryu binary

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ryu-bin
Package version: 3.30+dfsg1
Package release: 1ubuntu2
Package architecture: all
Package type: deb
Installed size: 44 B
Download size: 9.57 KB
Official Mirror: archive.ubuntu.com
Ryu is a component-based software defined networking framework. Ryu provides software components with well defined API that make it easy for developers to create new network management and control applications. Ryu supports various protocols for managing network devices, such as OpenFlow, Netconf, OF-config, etc. About OpenFlow, Ryu supports fully 1.0, 1.2, 1.3, 1.4 and Nicira Extensions. This package provides the Ryu manager.

Alternatives

    Download

    Source package: ryu

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ryu-bin deb package:
      # sudo apt-get install ryu-bin

    Files

    • /etc/init/ryu.conf
    • /etc/init.d/ryu
    • /etc/logrotate.d/ryu
    • /etc/ryu/log.conf
    • /etc/ryu/ryu.conf
    • /lib/systemd/system/ryu.service
    • /usr/bin/ryu
    • /usr/bin/ryu-manager
    • /usr/share/doc/ryu-bin/changelog.Debian.gz
    • /usr/share/doc/ryu-bin/copyright
    • /usr/share/man/man8/ryu-manager.8.gz
    • /usr/share/man/man8/ryu.8.gz

    Changelog

    2016-04-04 - Corey Bryant <corey.bryant@canonical.com> ryu (3.30+dfsg1-1ubuntu2) xenial; urgency=medium * debian/patches/fix-i386-test-failures.patch: Add i386 long support to ryu/lib/ip.py and ryu/lib/ofctl_utils.py.

    2016-03-23 - Corey Bryant <corey.bryant@canonical.com> ryu (3.30+dfsg1-1ubuntu1) xenial; urgency=medium * Merge from Debian unstable. Remaining changes: - debian/patches/fix-i386-test-failures.patch: + Fixup misc i386 issues due to differences in use of long and int depending on architecture in use.

    2016-03-08 - Thomas Goirand <zigo@debian.org> ryu (3.30+dfsg1-1) experimental; urgency=medium * New upstream release. * Uploading to experimental until Mitaka is out. * Moved the package to PKG OpenStack: - Updated VCS fields. - Switched to git tag based workflow instead of pristine-tar (updated gbp.conf, etc.). - Added build-depends on openstack-pkg-tools. - Added export OSLO_PACKAGE_VERSION - Added upstream VCS URL in debian/rules. - Includes pkgos.make in debian/rules. - Now using +dfsg1 suffix from upstream, showing we're removing their debian folder. Updated watch file accordingly. * Added myself as Uploaders:. * Removed useless X-Python-Version: in python-ryu. * Added myself in debian/copyright. * Added explicit --buildsystem=python_distutils for dh. * Switched the ryu.init to ryu.init.in format from openstack-pkg-tools, so that ryu supports sysv-rc, upstart and systemd now: - rm -f debian/*.init debian/*.upstart debian/*.service in d/rules - added --with systemd - build-depends on dh-systemd. - scraped most of the sysv-rc init script, enriched the declarative part. - trashed the debian/*.service unit file, now generated automatically. * Added copytruncate in the ryu logrotate file. * Standards-Version: 3.9.7 (no change). * Removed ryu-bin.dirs, created on daemon startup. * Added ryu-bin.postrm to purge /var/log/ryu and /var/lib/ryu on purge.

    2016-02-16 - Corey Bryant <corey.bryant@canonical.com> ryu (3.26-1ubuntu2) xenial; urgency=medium * d/p/fix-i386-test-failures.patch: Patch i386 hexify() bug in ryu/ofproto/ofproto_parser.py.

    2016-01-01 - Artur Rona <ari-tczew@ubuntu.com> ryu (3.26-1ubuntu1) xenial; urgency=low * Merge from Debian unstable. Remaining changes: - debian/patches/fix-i386-test-failures.patch: + Fixup misc i386 issues due to differences in use of long and int depending on architecture in use. * Drop following changes: - debian/control: + No need to force versioning Build-Depends. - debian/patches/uncap-pbr-version.patch: + Fixed upstream. - debian/rules: + Test are already enabled in Debian.

    2015-10-02 - Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl> ryu (3.26-1) unstable; urgency=medium * Imported Upstream version 3.26 * d/patches: removed patch fixing pbr version in setup.py

    2015-09-25 - Thomas Goirand <zigo@debian.org> ryu (3.24-1.1) unstable; urgency=medium * Non-maintainer upload. * Ran wrap-and-sort -t -a. * Fixed wrong location for python-setuptools and python-pbr: they should be in Build-Depends and not Build-Depends-Indep as they are needed for clean. * Fixed wrong version of pbr in setup.py: the restriction is simply wrong. * Removed versions in (build-)depends when already satisfied in Jessie & Trusty. * Added running of test suite: now build-depends-indep on nose, formencode, mock. * Make sure dh_clean doesn't download by setting http{s,}_proxy. * Drops now useless X-Python-Version: >= 2.6 (Jessie has 2.7 only). * Using sphinx-build directly instead of the provided Makefile. * Added (= ${binary:Version}) in ryu-bin python-ryu depends:. * Added extend-diff-ignore = "^[^/]*[.]egg-info/" in d/s/options, do not clean egg-info on clean. * Added overrides of dh commands we don't need to run.

    Advertisement
    Advertisement