ruby-yaml-db_0.3.0-1_all.deb


Advertisement

Description

ruby-yaml-db - library to export/import of database into/from yaml files

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-yaml-db
Package version: 0.3.0
Package release: 1
Package architecture: all
Package type: deb
Installed size: 36 B
Download size: 7.28 KB
Official Mirror: archive.ubuntu.com
YamlDb is a database-independent format for dumping and restoring data from any database that has an ActiveRecord adapter. This can be used as a replacement for mysqldump or pg_dump, but only for the databases typically used by Rails apps. Users, permissions, schemas, triggers, and other advanced database features are not supported - by design.

Alternatives

    Download

    Source package: ruby-yaml-db

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-yaml-db deb package:
      # sudo apt-get install ruby-yaml-db

    Files

    • /usr/lib/ruby/vendor_ruby/csv_db.rb
    • /usr/lib/ruby/vendor_ruby/serialization_helper.rb
    • /usr/lib/ruby/vendor_ruby/yaml_db.rb
    • /usr/lib/ruby/vendor_ruby/yaml_db/version.rb
    • /usr/lib/ruby/vendor_ruby/yaml_db/tasks/yaml_db_tasks.rake
    • /usr/share/doc/ruby-yaml-db/README.md
    • /usr/share/doc/ruby-yaml-db/changelog.Debian.gz
    • /usr/share/doc/ruby-yaml-db/copyright
    • /usr/share/rubygems-integration/all/specifications/yaml_db-0.3.0.gemspec

    Changelog

    2015-07-06 - Cédric Boutillier <boutil@debian.org> ruby-yaml-db (0.3.0-1) unstable; urgency=medium * Imported Upstream version 0.3.0 * Use GitHub as upstream for debian/watch * install README.md as documentation * Drop previous patches, integrated upstream or not needed anymore * Specify mimimum version for ruby-rspec to >= 3~ in build-dependencies * Build-depend on ruby-sqlite3 * Move Rake tasks file under /usr/lib/ruby/vendor_ruby/yamldb/

    2014-10-20 - Cédric Boutillier <boutil@debian.org> ruby-yaml-db (0.2.3-2) unstable; urgency=medium [ Cédric Boutillier ] * Rebuild to update rubygems-integration metadata * debian/control: + remove obsolete DM-Upload-Allowed flag + use canonical URI in Vcs-* fields + add myself to uploaders + bump Standards-Version to 3.9.6 + set Testsuite to autopkgtest-pkg-ruby + build-depend on ruby-rails instead of ruby-rails-3.2 (Closes: #765115) [ Ondřej Surý ] * Remove myself from Uploaders

    2013-04-15 - Ondřej Surý <ondrej@debian.org> ruby-yaml-db (0.2.3-1) unstable; urgency=low * Initial release (Closes: #705477) * debian/patches: + Add gitlab patch to fix tests + Add patch to kill rubygems dependency * debian/control: Require whole ruby-rails-3.2 stack for tests * debian/rules: Ignore tests on ruby1.8

    Advertisement
    Advertisement