ruby-xmlparser_0.7.3-1build4_i386.deb


Advertisement

Description

ruby-xmlparser - Ruby interface for the expat XML parser toolkit

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-xmlparser
Package version 0.7.3
Package release 1build4
Package architecture i386
Package type deb
Installed size 433 B
Download size 75.20 KB
Official Mirror archive.ubuntu.com
This is the module to access to James Clark's XML Parser Toolkit "expat"
<URL:http://www.jclark.com/xml/expat.html> from Ruby.

Alternatives

Package Version Architecture Repository
ruby-xmlparser_0.7.3-1build4_amd64.deb 0.7.3 amd64 Ubuntu Universe
ruby-xmlparser - - -

Requires

Name Value
libc6 >= 2.4
libexpat1 >= 2.0.1
libruby2.3 >= 2.3.0~preview2
ruby >= 1:2.3~0

Download

Type URL
Binary Package ruby-xmlparser_0.7.3-1build4_i386.deb
Source Package ruby-xmlparser

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-xmlparser deb package:
    # sudo apt-get install ruby-xmlparser

Files

Path
/usr/lib/i386-linux-gnu/ruby/vendor_ruby/2.3.0/xmlparser.so
/usr/lib/ruby/vendor_ruby/sax.rb
/usr/lib/ruby/vendor_ruby/saxdriver.rb
/usr/lib/ruby/vendor_ruby/wget.rb
/usr/lib/ruby/vendor_ruby/xmldigest.rb
/usr/lib/ruby/vendor_ruby/xmltree.rb
/usr/lib/ruby/vendor_ruby/xmltreebuilder.rb
/usr/lib/ruby/vendor_ruby/xmltreevisitor.rb
/usr/lib/ruby/vendor_ruby/xml/parser.rb
/usr/lib/ruby/vendor_ruby/xml/parserns.rb
/usr/lib/ruby/vendor_ruby/xml/sax.rb
/usr/lib/ruby/vendor_ruby/xml/saxdriver.rb
/usr/lib/ruby/vendor_ruby/xml/xpath.rb
/usr/lib/ruby/vendor_ruby/xml/xpath.ry
/usr/lib/ruby/vendor_ruby/xml/dom/builder.rb
/usr/lib/ruby/vendor_ruby/xml/dom/core.rb
/usr/lib/ruby/vendor_ruby/xml/dom/digest.rb
/usr/lib/ruby/vendor_ruby/xml/dom/visitor.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/attr.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/cdatasection.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/characterdata.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/comment.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/core.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/document.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/documentfragment.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/documenttype.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/dombuilder.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/dombuilderfilter.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/domentityresolver.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/domentityresolverimpl.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/domexception.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/domimplementation.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/dominputsource.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/element.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/entity.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/entityreference.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/namednodemap.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/node.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/nodelist.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/notation.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/processinginstruction.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/text.rb
/usr/lib/ruby/vendor_ruby/xml/dom2/xpath.rb
/usr/share/doc/ruby-xmlparser/README.gz
/usr/share/doc/ruby-xmlparser/README.ja.gz
/usr/share/doc/ruby-xmlparser/changelog.Debian.gz
/usr/share/doc/ruby-xmlparser/copyright

Changelog

2016-03-13 - Matthias Klose <doko@ubuntu.com>
ruby-xmlparser (0.7.3-1build4) xenial; urgency=medium
* No-change rebuild for ruby2.3-only support.
2016-03-13 - Matthias Klose <doko@ubuntu.com>
ruby-xmlparser (0.7.3-1build3) xenial; urgency=medium
* No-change rebuild to add ruby2.3 support.
2016-01-21 - Matthias Klose <doko@ubuntu.com>
ruby-xmlparser (0.7.3-1build2) xenial; urgency=medium
* No-change rebuild to drop ruby2.1 support.
2015-09-08 - Matthias Klose <doko@ubuntu.com>
ruby-xmlparser (0.7.3-1build1) wily; urgency=medium
* No-change to add ruby2.2 support.
2015-05-06 - Lucas Nussbaum <lucas@debian.org>
ruby-xmlparser (0.7.3-1) unstable; urgency=medium
* New upstream release.
* Refresh packaging:
+ Bump Standards-Version
+ Update Vcs-Browser
+ Add Testsuite
2014-01-06 - Christian Hofstaedtler <zeha@debian.org>
ruby-xmlparser (0.7.2-3) unstable; urgency=medium
* Team upload.
[ Cédric Boutillier ]
* debian/control: remove obsolete DM-Upload-Allowed flag
* use canonical URI in Vcs-* fields
[ Christian Hofstaedtler ]
* Bump Standards-Version to 3.9.5 (no changes)
* Remove transitional packages
* Update Build-Depends for ruby2.0, drop ruby1.8
2012-06-24 - Vincent Fourmond <fourmond@debian.org>
ruby-xmlparser (0.7.2-2) unstable; urgency=low
* Team upload.
* Rebuild with newer gem2deb
* Seems to conform to standards 3.9.3
* Move transitional packages to Priority: extra
2012-06-22 - gregor herrmann <gregoa@debian.org>
ruby-xmlparser (0.7.2-1.1) unstable; urgency=low
* Non-maintainer upload.
* Fix "FTBFS: xmlparser.c:1783:2: error: format not a string literal
and no format arguments [-Werror=format-security]": add patch
xmlparser-ftbfs-fix.patch from Andreas Stührk (adds format strings).
(Closes: #676194)
2011-06-16 - Lucas Nussbaum <lucas@debian.org>
ruby-xmlparser (0.7.2-1) unstable; urgency=low
* Switch to gem2deb-based packaging.
2010-12-24 - Hideki Yamane <henrich@debian.org>
libxml-parser-ruby (0.7.1-1.1) unstable; urgency=high
* Non-maintainer upload.
* debian/patches
- add "add-digest.rb" to work it with ruby1.9.1 (Closes: #593082)

See Also

Package Description
ruby-xmmsclient_0.8+dfsg-14build3_i386.deb XMMS2 - Ruby bindings
ruby-xpath_2.0.0-2_all.deb Ruby library to generate XPath expressions
ruby-yajl_1.2.0-3build4_i386.deb Ruby interface to Yajl, a JSON stream-based parser library
ruby-yaml-db_0.3.0-1_all.deb library to export/import of database into/from yaml files
ruby-yell_2.0.5-1_all.deb Your Extensible Logging Library for Ruby
ruby-zentest_4.11.0-2_all.deb ZenTest provides 4 different tools: zentest, unit_diff, autotest, and multiruby
ruby-zeroc-ice_3.5.1-6.4ubuntu1_i386.deb Ice for Ruby modules
ruby-zip-zip_0.3+gh-1_all.deb ease the migration to RubyZip v1.0.0
ruby-zip_1.1.7-1_i386.deb Ruby module for reading and writing zip files
ruby-zoom_0.4.1-7build2_i386.deb Ruby/ZOOM provides a Ruby binding to the Z40.50 Object-Orientation Model
ruby2.3-tcltk_2.3.0-5ubuntu1_i386.deb Ruby/Tk for Ruby 2.3
rumor_1.0.5-2_i386.deb Realtime MIDI keyboard to Lilypond converter
runawk_1.6.0-1_i386.deb wrapper for AWK interpreter implementing modules
runc_0.0.8+dfsg-2_i386.deb Open Container Project - runtime
rungetty_1.2-16_i386.deb minimal console getty that can run any process
Advertisement
Advertisement