ruby-warden_1.2.3-2_all.deb


Advertisement

Description

ruby-warden - Rack middleware that provides authentication for rack applications

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-warden
Package version: 1.2.3
Package release: 2
Package architecture: all
Package type: deb
Installed size: 74 B
Download size: 14.09 KB
Official Mirror: archive.ubuntu.com
Warden is a Rack-based middleware, designed to provide a mechanism for authentication in Ruby web applications. It is a common mechanism that fits into the Rack Machinery to offer powerful options for authentication. Warden is designed to be lazy. That is, if you don't use it, it doesn't do anything, but when you do use it, it will spring into action and provide an underlying mechanism to allow authentication in any Rack-based application.

Alternatives

    Download

    Source package: ruby-warden

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-warden deb package:
      # sudo apt-get install ruby-warden

    Files

    • /usr/lib/ruby/vendor_ruby/warden.rb
    • /usr/lib/ruby/vendor_ruby/warden/config.rb
    • /usr/lib/ruby/vendor_ruby/warden/errors.rb
    • /usr/lib/ruby/vendor_ruby/warden/hooks.rb
    • /usr/lib/ruby/vendor_ruby/warden/manager.rb
    • /usr/lib/ruby/vendor_ruby/warden/proxy.rb
    • /usr/lib/ruby/vendor_ruby/warden/session_serializer.rb
    • /usr/lib/ruby/vendor_ruby/warden/strategies.rb
    • /usr/lib/ruby/vendor_ruby/warden/version.rb
    • /usr/lib/ruby/vendor_ruby/warden/mixins/common.rb
    • /usr/lib/ruby/vendor_ruby/warden/strategies/base.rb
    • /usr/lib/ruby/vendor_ruby/warden/test/helpers.rb
    • /usr/lib/ruby/vendor_ruby/warden/test/warden_helpers.rb
    • /usr/share/doc/ruby-warden/README.textile
    • /usr/share/doc/ruby-warden/changelog.Debian.gz
    • /usr/share/doc/ruby-warden/copyright
    • /usr/share/rubygems-integration/all/specifications/warden-1.2.3.gemspec

    Changelog

    2015-09-02 - Balasankar C <balasankarc@autistici.org> ruby-warden (1.2.3-2) unstable; urgency=medium * Team upload. * Add rspec3-port.patch (Closes: #795123) - Ports the tests to support RSpec3 syntax * Bump Standards Version to 3.9.6 (no changes)

    2014-04-13 - Pirate Praveen <praveen@debian.org> ruby-warden (1.2.3-1) unstable; urgency=low * New upstream release. * Bump standards version to 3.9.5 (no changes) * Bump gem2deb build dep to >= 0.7.5~ (ruby 2.x) * Remove explicit_require_rspec.patch

    2012-11-14 - Praveen Arimbrathodiyil <praveen@debian.org> ruby-warden (1.2.1-2) unstable; urgency=low * Upload to unstable * Install README.textfile as doc * Install History.rdoc as changelog * Use debian/ruby-tests.rake for tests * Add rake to build-depends

    2012-10-18 - Praveen Arimbrathodiyil <praveen@debian.org> ruby-warden (1.2.1-1) experimental; urgency=low * Initial release (Closes: #624635)

    Advertisement
    Advertisement