ruby-versionomy_0.5.0-2_all.deb


Advertisement

Description

ruby-versionomy - Generalized version number class for Ruby

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-versionomy
Package version 0.5.0
Package release 2
Package architecture all
Package type deb
Installed size 215 B
Download size 39.02 KB
Official Mirror archive.ubuntu.com
Versionomy is a generalized version number library. It provides tools to
represent, manipulate, parse, and compare version numbers in the wide variety
of versioning schemes in use.

Alternatives

Package Version Architecture Repository
ruby-versionomy_0.5.0-2_all.deb 0.5.0 all Ubuntu Universe
ruby-versionomy - - -

Requires

Name Value
ruby -
ruby-blockenspiel >= 0.5
ruby-interpreter -

Download

Type URL
Binary Package ruby-versionomy_0.5.0-2_all.deb
Source Package ruby-versionomy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-versionomy deb package:
    # sudo apt-get install ruby-versionomy

Files

Path
/usr/lib/ruby/vendor_ruby/versionomy.rb
/usr/lib/ruby/vendor_ruby/versionomy/Version
/usr/lib/ruby/vendor_ruby/versionomy/conversion.rb
/usr/lib/ruby/vendor_ruby/versionomy/errors.rb
/usr/lib/ruby/vendor_ruby/versionomy/format.rb
/usr/lib/ruby/vendor_ruby/versionomy/interface.rb
/usr/lib/ruby/vendor_ruby/versionomy/schema.rb
/usr/lib/ruby/vendor_ruby/versionomy/value.rb
/usr/lib/ruby/vendor_ruby/versionomy/version.rb
/usr/lib/ruby/vendor_ruby/versionomy/conversion/base.rb
/usr/lib/ruby/vendor_ruby/versionomy/conversion/parsing.rb
/usr/lib/ruby/vendor_ruby/versionomy/format/base.rb
/usr/lib/ruby/vendor_ruby/versionomy/format/delimiter.rb
/usr/lib/ruby/vendor_ruby/versionomy/format_definitions/rubygems.rb
/usr/lib/ruby/vendor_ruby/versionomy/format_definitions/semver.rb
/usr/lib/ruby/vendor_ruby/versionomy/format_definitions/standard.rb
/usr/lib/ruby/vendor_ruby/versionomy/schema/field.rb
/usr/lib/ruby/vendor_ruby/versionomy/schema/wrapper.rb
/usr/share/doc/ruby-versionomy/README.rdoc.gz
/usr/share/doc/ruby-versionomy/Versionomy.rdoc.gz
/usr/share/doc/ruby-versionomy/changelog.Debian.gz
/usr/share/doc/ruby-versionomy/copyright
/usr/share/rubygems-integration/all/specifications/versionomy-0.5.0.gemspec

Changelog

2016-03-01 - Christian Hofstaedtler <zeha@debian.org>
ruby-versionomy (0.5.0-2) unstable; urgency=medium
* Team upload.
[ Thiago Ribeiro ]
* Imported Upstream version 0.5.0
* Bump compat to 9
[ Christian Hofstaedtler ]
* Update packaging using dh-make-ruby -w
2013-08-11 - Ben Armstrong <synrg@sanctuary.nslug.ns.ca>
ruby-versionomy (0.4.4-1) unstable; urgency=low
* Initial release (Closes: #719314)

See Also

Package Description
ruby-virtus_1.0.5-2_all.deb attributes on steroids for plain old Ruby objects
ruby-warden_1.2.3-2_all.deb Rack middleware that provides authentication for rack applications
ruby-wavefile_0.6.0-2_all.deb Pure Ruby library for reading and writing Wave sound files (*.wav)
ruby-web-console_2.2.1-2_all.deb Ruby on Rails debugger
ruby-webkit-gtk_2.2.5-4build1_all.deb WebKitGTK+ bindings for the Ruby language
ruby-webmock_1.22.6-1_all.deb library for stubbing HTTP requests in Ruby
ruby-webrobots_0.1.1-1build1_all.deb Library for creating robots.txt-aware web robots
ruby-websocket-driver_0.6.3-2build1_i386.deb WebSocket protocol handler with pluggable I/O
ruby-websocket-extensions_0.1.2-1_all.deb Generic extension manager for WebSocket connections
ruby-websocket-parser_1.0.0-1_all.deb RFC6455 compliant parser for websocket messages
ruby-whenever_0.9.4-1build1_all.deb Ruby library to abstract writing and deploying cron jobs
ruby-whitewash_2.0-2_all.deb Whitelist-based HTML filter for Ruby
ruby-wikicloth_0.8.1+dfsg-3_all.deb MediaWiki markup language parser for Ruby
ruby-will-paginate_3.1.0-1_all.deb Pagination for Rails
ruby-wirble_0.1.3-5_all.deb Extensions for the Ruby irb command line shell
Advertisement
Advertisement