ruby-twitter_5.16.0-1_all.deb


Advertisement

Description

ruby-twitter - Ruby interface to the Twitter API

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-twitter
Package version 5.16.0
Package release 1
Package architecture all
Package type deb
Installed size 336 B
Download size 43.70 KB
Official Mirror archive.ubuntu.com
This ruby library provides a convenient access to the Twitter API.
This provides comprehensive methods to access the API. This library
needs only a registration of your application with Twitter. It uses
OAuth protocol for interacting with Twitter API.

Alternatives

Package Version Architecture Repository
ruby-twitter_5.16.0-1_all.deb 5.16.0 all Ubuntu Universe
ruby-twitter - - -

Requires

Name Value
ruby -
ruby-buftok -
ruby-equalizer >= 0.0.10
ruby-faraday >= 0.9.0
ruby-http -
ruby-http-parser.rb -
ruby-interpreter -
ruby-memoizable -
ruby-multi-json >= 1.0
ruby-naught -
ruby-simple-oauth << 0.4
ruby-simple-oauth >= 0.3

Conflicts

Name Value
ruby-twitter4r -

Replaces

Name Value
ruby-twitter4r -

Download

Type URL
Binary Package ruby-twitter_5.16.0-1_all.deb
Source Package ruby-twitter

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-twitter deb package:
    # sudo apt-get install ruby-twitter

Files

Path
/usr/lib/ruby/vendor_ruby/twitter.rb
/usr/lib/ruby/vendor_ruby/twitter/arguments.rb
/usr/lib/ruby/vendor_ruby/twitter/base.rb
/usr/lib/ruby/vendor_ruby/twitter/basic_user.rb
/usr/lib/ruby/vendor_ruby/twitter/client.rb
/usr/lib/ruby/vendor_ruby/twitter/configuration.rb
/usr/lib/ruby/vendor_ruby/twitter/creatable.rb
/usr/lib/ruby/vendor_ruby/twitter/cursor.rb
/usr/lib/ruby/vendor_ruby/twitter/direct_message.rb
/usr/lib/ruby/vendor_ruby/twitter/entities.rb
/usr/lib/ruby/vendor_ruby/twitter/entity.rb
/usr/lib/ruby/vendor_ruby/twitter/enumerable.rb
/usr/lib/ruby/vendor_ruby/twitter/error.rb
/usr/lib/ruby/vendor_ruby/twitter/factory.rb
/usr/lib/ruby/vendor_ruby/twitter/geo.rb
/usr/lib/ruby/vendor_ruby/twitter/geo_factory.rb
/usr/lib/ruby/vendor_ruby/twitter/geo_results.rb
/usr/lib/ruby/vendor_ruby/twitter/headers.rb
/usr/lib/ruby/vendor_ruby/twitter/identity.rb
/usr/lib/ruby/vendor_ruby/twitter/language.rb
/usr/lib/ruby/vendor_ruby/twitter/list.rb
/usr/lib/ruby/vendor_ruby/twitter/media_factory.rb
/usr/lib/ruby/vendor_ruby/twitter/metadata.rb
/usr/lib/ruby/vendor_ruby/twitter/null_object.rb
/usr/lib/ruby/vendor_ruby/twitter/oembed.rb
/usr/lib/ruby/vendor_ruby/twitter/place.rb
/usr/lib/ruby/vendor_ruby/twitter/profile.rb
/usr/lib/ruby/vendor_ruby/twitter/profile_banner.rb
/usr/lib/ruby/vendor_ruby/twitter/rate_limit.rb
/usr/lib/ruby/vendor_ruby/twitter/relationship.rb
/usr/lib/ruby/vendor_ruby/twitter/saved_search.rb
/usr/lib/ruby/vendor_ruby/twitter/search_results.rb
/usr/lib/ruby/vendor_ruby/twitter/settings.rb
/usr/lib/ruby/vendor_ruby/twitter/size.rb
/usr/lib/ruby/vendor_ruby/twitter/source_user.rb
/usr/lib/ruby/vendor_ruby/twitter/suggestion.rb
/usr/lib/ruby/vendor_ruby/twitter/target_user.rb
/usr/lib/ruby/vendor_ruby/twitter/token.rb
/usr/lib/ruby/vendor_ruby/twitter/trend.rb
/usr/lib/ruby/vendor_ruby/twitter/trend_results.rb
/usr/lib/ruby/vendor_ruby/twitter/tweet.rb
/usr/lib/ruby/vendor_ruby/twitter/user.rb
/usr/lib/ruby/vendor_ruby/twitter/utils.rb
/usr/lib/ruby/vendor_ruby/twitter/variant.rb
/usr/lib/ruby/vendor_ruby/twitter/version.rb
/usr/lib/ruby/vendor_ruby/twitter/entity/hashtag.rb
/usr/lib/ruby/vendor_ruby/twitter/entity/symbol.rb
/usr/lib/ruby/vendor_ruby/twitter/entity/uri.rb
/usr/lib/ruby/vendor_ruby/twitter/entity/user_mention.rb
/usr/lib/ruby/vendor_ruby/twitter/geo/point.rb
/usr/lib/ruby/vendor_ruby/twitter/geo/polygon.rb
/usr/lib/ruby/vendor_ruby/twitter/media/animated_gif.rb
/usr/lib/ruby/vendor_ruby/twitter/media/photo.rb
/usr/lib/ruby/vendor_ruby/twitter/media/video.rb
/usr/lib/ruby/vendor_ruby/twitter/media/video_info.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/api.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/client.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/direct_messages.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/favorites.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/friends_and_followers.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/help.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/lists.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/media.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/oauth.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/places_and_geo.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/request.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/saved_searches.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/search.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/spam_reporting.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/suggested_users.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/timelines.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/trends.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/tweets.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/undocumented.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/users.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/utils.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/request/multipart_with_file.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/response/parse_error_json.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/response/parse_json.rb
/usr/lib/ruby/vendor_ruby/twitter/rest/response/raise_error.rb
/usr/lib/ruby/vendor_ruby/twitter/streaming/client.rb
/usr/lib/ruby/vendor_ruby/twitter/streaming/connection.rb
/usr/lib/ruby/vendor_ruby/twitter/streaming/deleted_tweet.rb
/usr/lib/ruby/vendor_ruby/twitter/streaming/event.rb
/usr/lib/ruby/vendor_ruby/twitter/streaming/friend_list.rb
/usr/lib/ruby/vendor_ruby/twitter/streaming/message_parser.rb
/usr/lib/ruby/vendor_ruby/twitter/streaming/response.rb
/usr/lib/ruby/vendor_ruby/twitter/streaming/stall_warning.rb
/usr/share/doc/ruby-twitter/README.md.gz
/usr/share/doc/ruby-twitter/changelog.Debian.gz
/usr/share/doc/ruby-twitter/copyright
/usr/share/rubygems-integration/all/specifications/twitter-5.16.0.gemspec

Changelog

2016-03-11 - Thiago Ribeiro <thiago@pencillabs.com>
ruby-twitter (5.16.0-1) unstable; urgency=medium
* Team Upload.
[ C├ędric Boutillier ]
* Bump debhelper compatibility level to 9
* Remove version in the gem2deb build-dependency
* Use https:// in Vcs-* fields
* Use https:// in Vcs-* fields
* Bump Standards-Version to 3.9.7 (no changes needed)
* Run wrap-and-sort on packaging files
[ Thiago Ribeiro ]
* Imported Upstream version 5.16.0 (closes: #817887)
2015-10-30 - Pirate Praveen <praveen@debian.org>
ruby-twitter (5.15.0-1) unstable; urgency=medium
* New upstream release
* Check gemspec dependencies during build
* Bump equalizer dependency to 0.0.10
2015-08-06 - Pirate Praveen <praveen@debian.org>
ruby-twitter (5.14.0-2) unstable; urgency=medium
* Loosen depency on simple_oauth in gemspec
* Add myself to Uploaders
2015-07-13 - Pirate Praveen <praveen@debian.org>
ruby-twitter (5.14.0-1) unstable; urgency=medium
* New upstream release.
2014-11-26 - Pirate Praveen <praveen@debian.org>
ruby-twitter (5.11.0-2) unstable; urgency=medium
* Team upload.
* Add ruby-buftok to depends.
* Conflict and Replace ruby-twitter4r (closes: #768160).
* Bump standards version to 3.9.6 (no changes).
2014-08-10 - Caitlin Matos <caitlin.matos@zoho.com>
ruby-twitter (5.11.0-1) unstable; urgency=medium
* Team upload
[ Praveen Arimbrathodiyil ]
* drop lintian overrides for source-is-missing, lintian 2.5.22.1 is happy
* drop patches, add ruby-simplecov and ruby-coveralls to build deps instead
[ Caitlin Matos ]
* New upstream release 5.11.0
2014-05-02 - Pirate Praveen <praveen@debian.org>
ruby-twitter (5.8.0-1) unstable; urgency=low
* Team upload.
* Bump standards version to 3.9.5 (no changes)
* Bump gem2deb build dep to >= 0.7.5~ (ruby all)
* Refresh patches
* Update dependencies and build dependencies as per gemspec
* Override source-is-missing errors for json files
2013-06-12 - Anish A <aneesh.nl@gmail.com>
ruby-twitter (4.7.0-1) unstable; urgency=low
* Initial release (Closes: #623897)

See Also

Package Description
ruby-typed-array_0.1.2-4_all.deb Ruby library providing enforced-type functionality to Arrays
ruby-typhoeus_0.8.0-2_all.deb parallel HTTP library on top of ethon
ruby-tzinfo_1.2.2-1_all.deb Daylight-savings aware timezone library
ruby-uconv_0.6.1-3_i386.deb Unicode/EUC-JP translation module for Ruby
ruby-uglifier_2.7.2-1_all.deb Ruby wrapper for UglifyJS JavaScript compressor
ruby-underscore-rails_1.8.2+dfsg-1_all.deb library to use underscore.js with Rails
ruby-unf-ext_0.0.7.2-1build2_i386.deb Unicode Normalization Form support library for CRuby
ruby-unf_0.1.4-1_all.deb Wrapper library to bring Unicode Normalization Form support to Ruby
ruby-unicode_0.4.4-2build6_i386.deb Unicode string manipulation library for Ruby
ruby-unicorn-worker-killer_0.4.2-1_all.deb library to kill unicorn workers by memory and request counts
ruby-upr_0.3.0-2_all.deb Upload Progress for Rack
ruby-uuid_2.3.8+debian-1_all.deb UUID generator for Ruby
ruby-uuidtools-doc_2.1.5-1_all.deb UUIDs generation library for Ruby - documentation
ruby-uuidtools_2.1.5-1_all.deb UUIDs generation library for Ruby
ruby-valid_1.0.0-2_all.deb standalone, generic object validator for ruby
Advertisement
Advertisement