ruby-twitter-text_1.13.4+conformance-1_all.deb


Advertisement

Description

ruby-twitter-text - library that does auto linking and extraction items in tweets

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-twitter-text
Package version 1.13.4+conformance
Package release 1
Package architecture all
Package type deb
Installed size 123 B
Download size 21.68 KB
Official Mirror archive.ubuntu.com
This library provides text processing routines for Twitter Tweets. The major
reason for this is to unify the various auto-linking and extraction of
usernames, lists, hashtags and URLs.
Learn more about its usage at /usr/share/doc/ruby-twitter-text/README.rdoc

Alternatives

Package Version Architecture Repository
ruby-twitter-text_1.13.4+conformance-1_all.deb 1.13.4+conformance all Ubuntu Universe
ruby-twitter-text - - -

Requires

Name Value
ruby-unf -

Download

Type URL
Binary Package ruby-twitter-text_1.13.4+conformance-1_all.deb
Source Package ruby-twitter-text

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-twitter-text deb package:
    # sudo apt-get install ruby-twitter-text

Files

Path
/usr/lib/ruby/vendor_ruby/twitter-text.rb
/usr/lib/ruby/vendor_ruby/assets/tld_lib.yml
/usr/lib/ruby/vendor_ruby/twitter-text/autolink.rb
/usr/lib/ruby/vendor_ruby/twitter-text/deprecation.rb
/usr/lib/ruby/vendor_ruby/twitter-text/extractor.rb
/usr/lib/ruby/vendor_ruby/twitter-text/hash_helper.rb
/usr/lib/ruby/vendor_ruby/twitter-text/hit_highlighter.rb
/usr/lib/ruby/vendor_ruby/twitter-text/regex.rb
/usr/lib/ruby/vendor_ruby/twitter-text/rewriter.rb
/usr/lib/ruby/vendor_ruby/twitter-text/unicode.rb
/usr/lib/ruby/vendor_ruby/twitter-text/validation.rb
/usr/share/doc/ruby-twitter-text/README.rdoc
/usr/share/doc/ruby-twitter-text/changelog.Debian.gz
/usr/share/doc/ruby-twitter-text/copyright
/usr/share/ruby-twitter-text/lib/assets/tld_lib.yml
/usr/share/ruby-twitter-text/test/twitter-text-conformance/tld_lib.yml
/usr/share/rubygems-integration/all/specifications/twitter-text-1.13.4.gemspec

Changelog

2016-03-13 - Pirate Praveen <praveen@debian.org>
ruby-twitter-text (1.13.4+conformance-1) unstable; urgency=medium
[ Sudheesh Shetty ]
* Team upload
* New upstream release
[ Balasankar C ]
* Use standard docs file name.
* Make tests run.
* Add debian/ruby-tests.rake.
* Edit 3001-fix-path.patch to check for relative and fixed links.
* Add necessary build deps. 
* Generate gemspec file
* Rename 2001-avoid-git-in-gemspec.patch to 2001-fix-gemspec.patch to
make it a general patch.
* Remove usage of spec from gemspec.
* Clean coverage folder before building.
[ Pirate Praveen]
* Add ruby-rspec as build dependency
2015-10-30 - Pirate Praveen <praveen@debian.org>
ruby-twitter-text (1.13.0+conformance-1) unstable; urgency=medium
* New upstream release
2015-07-28 - Pirate Praveen <praveen@debian.org>
ruby-twitter-text (1.12.0+conformance-1) unstable; urgency=medium
* New upstream release.
* Add team address as Maintainer.
* Add myself to Uploaders.
2015-04-29 - Pirate Praveen <praveen@debian.org>
ruby-twitter-text (1.11.0+conformance-3) unstable; urgency=medium
* Team upload.
* Re-upload to unstable.
2015-04-11 - Pirate Praveen <praveen@debian.org>
ruby-twitter-text (1.11.0+conformance-2) experimental; urgency=medium
* Team upload.
* Install lib/assets/tld_lib.yml.
2015-03-31 - Pirate Praveen <praveen@debian.org>
ruby-twitter-text (1.11.0+conformance-1) experimental; urgency=low
* Team upload.
* New upstream release
* Add conformance to source (see README.source)
2015-03-25 - Hideki Yamane <henrich@debian.org>
ruby-twitter-text (1.10.0+gem-2) unstable; urgency=medium
* debian/control
- fix Vcs-* 
2014-11-22 - Pirate Praveen <praveen@debian.org>
ruby-twitter-text (1.10.0+gem-1) unstable; urgency=medium
* Team upload.
* Use gem file as upstream source (closes: #770621)
- github tarball has missing files 
* Rebuild to include gemspec file (remove git usage).
* Bump standards version to 3.9.6 (no changes).
2014-11-01 - Hideki Yamane <henrich@debian.org>
ruby-twitter-text (1.10.0-1) unstable; urgency=medium
* New upstream release 
2014-07-29 - Hideki Yamane <henrich@debian.org>
ruby-twitter-text (1.9.2-1) unstable; urgency=medium
* New upstream release

See Also

Package Description
ruby-twitter_5.16.0-1_all.deb Ruby interface to the Twitter API
ruby-typed-array_0.1.2-4_all.deb Ruby library providing enforced-type functionality to Arrays
ruby-typhoeus_0.8.0-2_all.deb parallel HTTP library on top of ethon
ruby-tzinfo_1.2.2-1_all.deb Daylight-savings aware timezone library
ruby-uconv_0.6.1-3_i386.deb Unicode/EUC-JP translation module for Ruby
ruby-uglifier_2.7.2-1_all.deb Ruby wrapper for UglifyJS JavaScript compressor
ruby-underscore-rails_1.8.2+dfsg-1_all.deb library to use underscore.js with Rails
ruby-unf-ext_0.0.7.2-1build2_i386.deb Unicode Normalization Form support library for CRuby
ruby-unf_0.1.4-1_all.deb Wrapper library to bring Unicode Normalization Form support to Ruby
ruby-unicode_0.4.4-2build6_i386.deb Unicode string manipulation library for Ruby
ruby-unicorn-worker-killer_0.4.2-1_all.deb library to kill unicorn workers by memory and request counts
ruby-upr_0.3.0-2_all.deb Upload Progress for Rack
ruby-uuid_2.3.8+debian-1_all.deb UUID generator for Ruby
ruby-uuidtools-doc_2.1.5-1_all.deb UUIDs generation library for Ruby - documentation
ruby-uuidtools_2.1.5-1_all.deb UUIDs generation library for Ruby
Advertisement
Advertisement