ruby-treetop_1.6.3-1_all.deb


Advertisement

Description

ruby-treetop - Ruby-based text parsing and interpretation DSL

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-treetop
Package version 1.6.3
Package release 1
Package architecture all
Package type deb
Installed size 276 B
Download size 35.03 KB
Official Mirror archive.ubuntu.com
Treetop is a language for describing languages. It provides a Ruby
implementation of a custom language based on parsing expression
grammars (PEGs).
This package provides the Ruby library implementation of treetop.

Alternatives

Package Version Architecture Repository
ruby-treetop_1.6.3-1_all.deb 1.6.3 all Ubuntu Universe
ruby-treetop - - -

Requires

Name Value
ruby -
ruby-i18n -
ruby-interpreter -
ruby-polyglot >= 0.3

Download

Type URL
Binary Package ruby-treetop_1.6.3-1_all.deb
Source Package ruby-treetop

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-treetop deb package:
    # sudo apt-get install ruby-treetop

Files

Path
/usr/lib/ruby/vendor_ruby/treetop.rb
/usr/lib/ruby/vendor_ruby/treetop/bootstrap_gen_1_metagrammar.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler.rb
/usr/lib/ruby/vendor_ruby/treetop/polyglot.rb
/usr/lib/ruby/vendor_ruby/treetop/ruby_extensions.rb
/usr/lib/ruby/vendor_ruby/treetop/runtime.rb
/usr/lib/ruby/vendor_ruby/treetop/version.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/grammar_compiler.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/lexical_address_space.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/metagrammar.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/metagrammar.treetop
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/ruby_builder.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/anything_symbol.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/atomic_expression.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/character_class.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/choice.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/declaration_sequence.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/grammar.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/inline_module.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/nonterminal.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/optional.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/parenthesized_expression.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/parsing_expression.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/parsing_rule.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/predicate.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/predicate_block.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/repetition.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/sequence.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/terminal.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/transient_prefix.rb
/usr/lib/ruby/vendor_ruby/treetop/compiler/node_classes/treetop_file.rb
/usr/lib/ruby/vendor_ruby/treetop/ruby_extensions/string.rb
/usr/lib/ruby/vendor_ruby/treetop/runtime/compiled_parser.rb
/usr/lib/ruby/vendor_ruby/treetop/runtime/interval_skip_list.rb
/usr/lib/ruby/vendor_ruby/treetop/runtime/syntax_node.rb
/usr/lib/ruby/vendor_ruby/treetop/runtime/terminal_parse_failure.rb
/usr/lib/ruby/vendor_ruby/treetop/runtime/terminal_syntax_node.rb
/usr/lib/ruby/vendor_ruby/treetop/runtime/interval_skip_list/head_node.rb
/usr/lib/ruby/vendor_ruby/treetop/runtime/interval_skip_list/interval_skip_list.rb
/usr/lib/ruby/vendor_ruby/treetop/runtime/interval_skip_list/node.rb
/usr/share/doc/ruby-treetop/README.md.gz
/usr/share/doc/ruby-treetop/changelog.Debian.gz
/usr/share/doc/ruby-treetop/copyright
/usr/share/doc/ruby-treetop/examples/inner_outer.rb
/usr/share/doc/ruby-treetop/examples/inner_outer.tt
/usr/share/doc/ruby-treetop/examples/numerals.rb
/usr/share/doc/ruby-treetop/examples/numerals.tt
/usr/share/doc/ruby-treetop/examples/indented_blocks/indented_blocks.tt
/usr/share/doc/ruby-treetop/examples/indented_blocks/indented_blocks_test.rb
/usr/share/doc/ruby-treetop/examples/lambda_calculus/arithmetic.rb
/usr/share/doc/ruby-treetop/examples/lambda_calculus/arithmetic.treetop
/usr/share/doc/ruby-treetop/examples/lambda_calculus/arithmetic_node_classes.rb
/usr/share/doc/ruby-treetop/examples/lambda_calculus/arithmetic_test.rb
/usr/share/doc/ruby-treetop/examples/lambda_calculus/lambda_calculus.rb
/usr/share/doc/ruby-treetop/examples/lambda_calculus/lambda_calculus.treetop
/usr/share/doc/ruby-treetop/examples/lambda_calculus/lambda_calculus_node_classes.rb
/usr/share/doc/ruby-treetop/examples/lambda_calculus/lambda_calculus_test.rb
/usr/share/doc/ruby-treetop/examples/lambda_calculus/test_helper.rb
/usr/share/rubygems-integration/all/specifications/treetop-1.6.3.gemspec

Changelog

2015-08-13 - Cédric Boutillier <boutil@debian.org>
ruby-treetop (1.6.3-1) unstable; urgency=medium
* Imported Upstream version 1.6.3
+ add support for RSpec3 (Closes: #795134)
* Drop drop-failing-test.patch, applied upstream
2015-05-12 - Lucas Nussbaum <lucas@debian.org>
ruby-treetop (1.6.2-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Refreshed packaging using dh-make-ruby.
* Add patch: do-not-depend-on-lib-for-tests.patch. This is required
to allow running tests on ci.d.n.
* Drop patch: 0001-Do-not-require-rubygems.patch. No longer needed.
* Add patch: drop-failing-test.patch. This test was already removed
upstream.
2014-09-22 - Cédric Boutillier <boutil@debian.org>
ruby-treetop (1.4.15-1) unstable; urgency=medium
* Imported Upstream version 1.4.15
The indent method of the String class extension is now inlined to avoid
collision with the one from ActiveSupport (Closes: #759925)
* Do not install the HTML manual, as the tools to build it from source are
not available in the Debian archive.
* Refresh 0001-Do-not-require-rubygems.patch
* Remove 0002-Add-a-tt-manual-page.patch, applied upstream
* Remove 0003-Use-ruby18-compatible-regexp.patch, applied upstream
* Drop 0004-privacy-breach.patch, not needed without HTML manual
2014-05-19 - Antonio Terceiro <terceiro@debian.org>
ruby-treetop (1.4.14-3) unstable; urgency=medium
* Team upload.
* Rebuild against newer gem2deb (adds gemspecs for all interpreters, current
and future)
2014-01-19 - Cédric Boutillier <boutil@debian.org>
ruby-treetop (1.4.14-2) unstable; urgency=low
* debian/copyright: update to the correct source URL, according to
Rubygems.org 
* Use the rake method to run the tests.
This method finds the spec_helper.rb file (Closes: #735866)
* Bump Standards-Version to 3.9.5 (no changes needed)
* Fix privacy breach in the HTML documentation
2013-06-19 - Cédric Boutillier <boutil@debian.org>
ruby-treetop (1.4.14-1) unstable; urgency=low
* New upstream version
* debian/patches:
+ 0001-Do-not-require-rubygems.patch refreshed
+ 0002-Add-a-tt-manual-page.patch: update and forward tt manpage 
+ 0003-Require-rspec-core-shared_context.patch dropped (included upstream)
+ 0003-Use-ruby18-compatible-regexp.patch addedto make specs
pass with Ruby 1.8.
* debian/control:
+ update my email address
+ update Homepage field
+ bump Standards-Version to 3.9.4 (no changes needed)
* debian/copyright: update source URL  
2012-06-25 - Antonio Terceiro <terceiro@debian.org>
ruby-treetop (1.4.10-5) unstable; urgency=low
* Bump build dependency on gem2deb to >= 0.3.0~
* debian/ruby-treetop.install: install rubygems-integration data
2012-05-08 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-treetop (1.4.10-4) unstable; urgency=low
*  Fix typo in the short description of treetop package (Closes: #671972)
2012-05-06 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-treetop (1.4.10-3) unstable; urgency=low
* Add myself to Uploaders:
* Bump Standard-Versions: to 3.9.3 (no changes needed)
* Modify ruby-tests.rb to use rspec/autorun and to load only *_spec.rb files
* Import upstream commit to require rspec/core/shared_context
(Closes: #665251)
* Fix hyphens in the manpage tt.1
* Register html documentation with doc-base 
2012-03-05 - Carl Worth <cworth@debian.org>
ruby-treetop (1.4.10-2) unstable; urgency=low
* control: Add ruby-polyglot to the Build-Depends list

See Also

Package Description
ruby-trollop_2.0-2_all.deb command-line argument processing library
ruby-ttfunk_1.4.0-1_all.deb Ruby library to parse TrueType font metrics
ruby-turbolinks_2.5.3-2_all.deb following links in your Rails web application faster
ruby-twitter-oauth_0.4.94-1_all.deb Twitter OAuth REST API client library for Ruby
ruby-twitter-stream_0.1.16-2_all.deb Twitter realtime API client for Ruby
ruby-twitter-text_1.13.4+conformance-1_all.deb library that does auto linking and extraction items in tweets
ruby-twitter_5.16.0-1_all.deb Ruby interface to the Twitter API
ruby-typed-array_0.1.2-4_all.deb Ruby library providing enforced-type functionality to Arrays
ruby-typhoeus_0.8.0-2_all.deb parallel HTTP library on top of ethon
ruby-tzinfo_1.2.2-1_all.deb Daylight-savings aware timezone library
ruby-uconv_0.6.1-3_i386.deb Unicode/EUC-JP translation module for Ruby
ruby-uglifier_2.7.2-1_all.deb Ruby wrapper for UglifyJS JavaScript compressor
ruby-underscore-rails_1.8.2+dfsg-1_all.deb library to use underscore.js with Rails
ruby-unf-ext_0.0.7.2-1build2_i386.deb Unicode Normalization Form support library for CRuby
ruby-unf_0.1.4-1_all.deb Wrapper library to bring Unicode Normalization Form support to Ruby
Advertisement
Advertisement