ruby-tilt_2.0.1-2_all.deb


Advertisement

Description

ruby-tilt - Generic interface to multiple Ruby template engines

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-tilt
Package version: 2.0.1
Package release: 2
Package architecture: all
Package type: deb
Installed size: 93 B
Download size: 21.62 KB
Official Mirror: archive.ubuntu.com
Tilt is a thin interface over a bunch of different Ruby template engines in an attempt to make their usage as generic possible. This is useful for web frameworks, static site generators, and other systems that support multiple template engines but don't want to code for each of them individually.

Alternatives

    Download

    Binary package: ruby-tilt_2.0.1-2_all.deb
    Source package: ruby-tilt

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-tilt deb package:
      # sudo apt-get install ruby-tilt

    Files

    • /usr/bin/tilt
    • /usr/lib/ruby/vendor_ruby/tilt.rb
    • /usr/lib/ruby/vendor_ruby/tilt/asciidoc.rb
    • /usr/lib/ruby/vendor_ruby/tilt/bluecloth.rb
    • /usr/lib/ruby/vendor_ruby/tilt/builder.rb
    • /usr/lib/ruby/vendor_ruby/tilt/coffee.rb
    • /usr/lib/ruby/vendor_ruby/tilt/creole.rb
    • /usr/lib/ruby/vendor_ruby/tilt/csv.rb
    • /usr/lib/ruby/vendor_ruby/tilt/erb.rb
    • /usr/lib/ruby/vendor_ruby/tilt/erubis.rb
    • /usr/lib/ruby/vendor_ruby/tilt/etanni.rb
    • /usr/lib/ruby/vendor_ruby/tilt/haml.rb
    • /usr/lib/ruby/vendor_ruby/tilt/kramdown.rb
    • /usr/lib/ruby/vendor_ruby/tilt/less.rb
    • /usr/lib/ruby/vendor_ruby/tilt/liquid.rb
    • /usr/lib/ruby/vendor_ruby/tilt/mapping.rb
    • /usr/lib/ruby/vendor_ruby/tilt/markaby.rb
    • /usr/lib/ruby/vendor_ruby/tilt/maruku.rb
    • /usr/lib/ruby/vendor_ruby/tilt/nokogiri.rb
    • /usr/lib/ruby/vendor_ruby/tilt/plain.rb
    • /usr/lib/ruby/vendor_ruby/tilt/radius.rb
    • /usr/lib/ruby/vendor_ruby/tilt/rdiscount.rb
    • /usr/lib/ruby/vendor_ruby/tilt/rdoc.rb
    • /usr/lib/ruby/vendor_ruby/tilt/redcarpet.rb
    • /usr/lib/ruby/vendor_ruby/tilt/redcloth.rb
    • /usr/lib/ruby/vendor_ruby/tilt/sass.rb
    • /usr/lib/ruby/vendor_ruby/tilt/string.rb
    • /usr/lib/ruby/vendor_ruby/tilt/template.rb
    • /usr/lib/ruby/vendor_ruby/tilt/wikicloth.rb
    • /usr/lib/ruby/vendor_ruby/tilt/yajl.rb
    • /usr/share/doc/ruby-tilt/README.md.gz
    • /usr/share/doc/ruby-tilt/changelog.Debian.gz
    • /usr/share/doc/ruby-tilt/copyright
    • /usr/share/man/man1/tilt.1.gz
    • /usr/share/rubygems-integration/all/specifications/tilt-2.0.1.gemspec

    Changelog

    2016-01-13 - Pirate Praveen <praveen@debian.org> ruby-tilt (2.0.1-2) unstable; urgency=medium * Team upload * Reupload to unstable (verified reverse dependencies are working)

    2016-01-12 - Pirate Praveen <praveen@debian.org> ruby-tilt (2.0.1-1) experimental; urgency=medium * Team upload [ Lucas Nussbaum ] * Drop myself from Uploaders [ Pirate Praveen ] * New upstream release (stage in experimental to sort reverse dependencies) * Drop patch: new-test-unit-compatibility.patch (not needed for this version) * Disable unpackaged dependencies * Bump standards version to 3.9.6 (no changes) [ Balasankar C ] * Make tests run. - disable-failing-test.patch: Disable the failing test. - remove-bundler.patch: Remove usage of bundler during tests. - set-available-locales.patch: Set available locales during tests. * Bump debhelper compatibility. * Add dep3 headers to all patches.

    2014-02-23 - Antonio Terceiro <terceiro@debian.org> ruby-tilt (2.0.0+really1.4.1-1) unstable; urgency=medium * Team upload * Revert to previous upstream release due to breakage of reverse dependencies (Closes: #738488). * switch build-dependency from ruby-minitest to ruby-test-unit - had to add debian/patches/new-test-unit-compatibility.patch temporarily

    2014-01-31 - Youhei SASAKI <uwabami@gfd-dennou.org> ruby-tilt (2.0.0-1) unstable; urgency=medium * Imported Upstream version 2.0.0 * Refresh patches * debian/control: Update Build-Depends * Bump Standard Version: 3.9.5

    2013-07-22 - Jérémy Bobbio <lunar@debian.org> ruby-tilt (1.4.1-1) unstable; urgency=low [ Jérémy Bobbio ] * Team upload. * New upstream release. * Refresh Debian patches. * Add git-buildpackage configuration * Unapply patches after build. * Remove cruft in debian/control. * Bump Standards-Version to 3.9.4, no changes required. [ Cédric Boutillier ] * debian/control: remove obsolete DM-Upload-Allowed flag. * Use canonical URI in Vcs-* fields. * debian/copyright: use DEP5 copyright-format/1.0 official URL for Format field.

    2012-06-25 - Antonio Terceiro <terceiro@debian.org> ruby-tilt (1.3.3-2) unstable; urgency=low * Bump build dependency on gem2deb to >= 0.3.0~

    2011-09-23 - Youhei SASAKI <uwabami@gfd-dennou.org> ruby-tilt (1.3.3-1) unstable; urgency=low [ Cédric Boutillier ] * copyright: change to a working url in Format: field [ Youhei SASAKI ] * New Upstream Version: 1.3.3 * control: update Build-Depends: libnokogiri-ruby{1.8,1.9.1} to ruby-nokogiri * copyright: change MIT to Expat

    2011-07-26 - Youhei SASAKI <uwabami@gfd-dennou.org> ruby-tilt (1.3.2-1) unstable; urgency=low * Fix FTBFS: Closes: #628271 - add Encoding.default_external for Ruby >= 1.9.1 * New Upstream version: 1.3.2 * Bump Standard Version: 3.9.2 * Add manpage for /usr/bin/tilt * Add me to Uploaders

    2011-04-26 - Lucas Nussbaum <lucas@lucas-nussbaum.net> ruby-tilt (1.2.2-1) unstable; urgency=low * Initial release.

    Advertisement
    Advertisement