ruby-test-declarative_0.0.5-3_all.deb


Advertisement

Description

ruby-test-declarative - adds a declarative test method syntax to test/unit

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-test-declarative
Package version 0.0.5
Package release 3
Package architecture all
Package type deb
Installed size 20 B
Download size 3.59 KB
Official Mirror archive.ubuntu.com
Simply adds a declarative test method syntax to test/unit.

Alternatives

Package Version Architecture Repository
ruby-test-declarative_0.0.5-3_all.deb 0.0.5 all Ubuntu Universe
ruby-test-declarative - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-test-declarative_0.0.5-3_all.deb
Source Package ruby-test-declarative

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-test-declarative deb package:
    # sudo apt-get install ruby-test-declarative

Files

Path
/usr/lib/ruby/vendor_ruby/test_declarative.rb
/usr/lib/ruby/vendor_ruby/test_declarative/version.rb
/usr/share/doc/ruby-test-declarative/README.textile
/usr/share/doc/ruby-test-declarative/changelog.Debian.gz
/usr/share/doc/ruby-test-declarative/copyright
/usr/share/rubygems-integration/all/specifications/test_declarative-0.0.5.gemspec

Changelog

2015-08-18 - Lucas Nussbaum <lucas@debian.org>
ruby-test-declarative (0.0.5-3) unstable; urgency=medium
* Add patch 0001-Add-support-for-Minitest-5.patch to support minitest >5.
Closes: #795042
* Refresh packaging using dh-make-ruby.
+ Bump Standards-Version.
2013-12-15 - Jonas Genannt <jonas.genannt@capi2name.de>
ruby-test-declarative (0.0.5-2) unstable; urgency=low
* Team upload.
[ C├ędric Boutillier ]
* transform hyphen to underline to fix debian/watch
* debian/control
- remove obsolete DM-Upload-Allowed flag
- use canonical URI in Vcs-* fields
* debian/copyright
- use DEP5 copyright-format/1.0 official URL for Format field
- change to a working url in Format: field
[ Jonas Genannt ]
* d/control
- bumped standards version to 3.9.5 (no changed needed)
- changed dependency from ruby1.8 to ruby
* d/copyright: updated to license format 1.0
2011-04-26 - Lucas Nussbaum <lucas@lucas-nussbaum.net>
ruby-test-declarative (0.0.5-1) unstable; urgency=low
* Initial release.

See Also

Package Description
ruby-test-spec_0.10.0-3build1_all.deb Ruby library providing behaviour driven development interface for Test::Unit
ruby-test-unit-context_0.5.0-2_all.deb context for the Test::Unit Ruby testing framework
ruby-test-unit-rr_1.0.5-1_all.deb RR adapter for Ruby Test::Unit
ruby-text-format_1.0.0-4build1_all.deb Ruby library for text formatting
ruby-text-table_1.2.4-1_all.deb feature-rich, easy-to-use plain text table formatter in Ruby
ruby-text_1.3.0-1_all.deb Collection of text algorithms for Ruby
ruby-thinking-sphinx_3.1.4-3_all.deb smart wrapper over sphinx for activerecord
ruby-thor_0.19.1-2_all.deb Ruby scripting framework
ruby-threach_0.2.0-1_all.deb Threaded each
ruby-thread-order_1.1.0-1_all.deb test helper for ordering threaded code
ruby-thread-safe_0.3.5-3_all.deb thread-safe collections and utilities for Ruby
ruby-tilt_2.0.1-2_all.deb Generic interface to multiple Ruby template engines
ruby-timecop_0.8.0-1_all.deb Ruby library to easily test time-dependent code
ruby-timers_4.1.1-2_all.deb pure Ruby timer collections
ruby-timfel-krb5-auth_0.8.3-2build3_i386.deb Kerberos binding for Ruby
Advertisement
Advertisement