ruby-termios_1.0.0-1build6_i386.deb


Advertisement

Description

ruby-termios - termios simple wrapper for Ruby

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-termios
Package version: 1.0.0
Package release: 1build6
Package architecture: i386
Package type: deb
Installed size: 128 B
Download size: 24.04 KB
Official Mirror: archive.ubuntu.com
Ruby-termios is a wrapper for the termios(3) interface. It can be included into IO-family classes and extends IO-family objects. In addition, the methods can used as module function.

Alternatives

    Download

    Source package: ruby-termios

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-termios deb package:
      # sudo apt-get install ruby-termios

    Files

    • /usr/lib/i386-linux-gnu/ruby/vendor_ruby/2.3.0/termios.so
    • /usr/lib/ruby/vendor_ruby/termios.rb
    • /usr/share/doc/ruby-termios/README.gz
    • /usr/share/doc/ruby-termios/changelog.Debian.gz
    • /usr/share/doc/ruby-termios/copyright
    • /usr/share/doc/ruby-termios/examples/modem_check0.rb
    • /usr/share/doc/ruby-termios/examples/modem_check1.rb
    • /usr/share/doc/ruby-termios/examples/modem_check2.rb
    • /usr/share/doc/ruby-termios/examples/secret_input1.rb
    • /usr/share/doc/ruby-termios/examples/secret_input2.rb
    • /usr/share/rubygems-integration/2.3.0/specifications/ruby-termios-1.0.0.gemspec

    Changelog

    2016-03-13 - Matthias Klose <doko@ubuntu.com> ruby-termios (1.0.0-1build6) xenial; urgency=medium * No-change rebuild for ruby2.3-only support.

    2016-03-13 - Matthias Klose <doko@ubuntu.com> ruby-termios (1.0.0-1build5) xenial; urgency=medium * No-change rebuild to add ruby2.3 support.

    2016-01-21 - Matthias Klose <doko@ubuntu.com> ruby-termios (1.0.0-1build4) xenial; urgency=medium * No-change rebuild to drop ruby2.1 support.

    2015-09-08 - Matthias Klose <doko@ubuntu.com> ruby-termios (1.0.0-1build3) wily; urgency=medium * No-change to add ruby2.2 support.

    2014-11-19 - Colin Watson <cjwatson@ubuntu.com> ruby-termios (1.0.0-1build2) vivid; urgency=medium * Rebuild against current ruby-defaults, dropping support for Ruby 2.0.

    2014-04-28 - Matthias Klose <doko@ubuntu.com> ruby-termios (1.0.0-1build1) utopic; urgency=medium * No-change rebuild for ruby2.0 and ruby2.1.

    2013-09-26 - Cédric Boutillier <cedric.boutillier@gmail.com> ruby-termios (1.0.0-1) unstable; urgency=low * Team upload * Imported Upstream version 1.0.0 * debian/copyright: + use DEP5 copyright-format/1.0 official URL for Format field + ruby-termios is now BSD-2-clause or Ruby * debian/control: + remove obsolete DM-Upload-Allowed flag + use canonical URI in Vcs-* fields + bump Standards-Version to 3.9.4 (no changes needed) + replace ruby1.8 by ruby in Depends: + drop transitional packages + capitalize Ruby and fix spaces in description * debian/watch: use temporarily github as source

    2011-04-09 - Lucas Nussbaum <lucas@lucas-nussbaum.net> ruby-termios (0.9.6-2) unstable; urgency=low * Fix Vcs-Browser field.

    2011-04-03 - Lucas Nussbaum <lucas@lucas-nussbaum.net> ruby-termios (0.9.6-1) unstable; urgency=low * New upstream release. * Switch to gem2deb-based packaging. * Drop patch, integrated upstream.

    2008-06-03 - Lucas Nussbaum <lucas@lucas-nussbaum.net> libtermios-ruby (0.9.5-4) unstable; urgency=low * Added rb_io_t+ruby1.8.7.patch to build with ruby 1.8.7. Thanks to Akira Yamada for the patch. Closes: #484186. * Now uses quilt to manage patches. * Added build-dependencies on quilt and patchutils. * Updated copyright notice.

    Advertisement
    Advertisement