ruby-sshkit_1.9.0~rc1-1_all.deb


Advertisement

Description

ruby-sshkit - toolkit for running commands in a structured way on one or more servers

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-sshkit
Package version: 1.9.0~rc1
Package release: 1
Package architecture: all
Package type: deb
Installed size: 111 B
Download size: 29.06 KB
Official Mirror: archive.ubuntu.com
SSHKit is a comprehensive toolkit for remotely running commands in a structured manner on groups of servers. SSHKit makes it easy to write structured, testable SSH commands in Ruby.

Alternatives

    Download

    Source package: ruby-sshkit

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-sshkit deb package:
      # sudo apt-get install ruby-sshkit

    Files

    • /usr/lib/ruby/vendor_ruby/sshkit.rb
    • /usr/lib/ruby/vendor_ruby/core_ext/array.rb
    • /usr/lib/ruby/vendor_ruby/core_ext/hash.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/all.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/color.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/command.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/command_map.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/configuration.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/coordinator.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/deprecation_logger.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/dsl.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/exception.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/host.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/log_message.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/logger.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/mapping_interaction_handler.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/version.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/backends/abstract.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/backends/connection_pool.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/backends/local.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/backends/netssh.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/backends/printer.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/backends/skipper.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/backends/connection_pool/cache.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/backends/connection_pool/nil_cache.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/formatters/abstract.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/formatters/black_hole.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/formatters/dot.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/formatters/pretty.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/formatters/simple_text.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/runners/abstract.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/runners/group.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/runners/null.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/runners/parallel.rb
    • /usr/lib/ruby/vendor_ruby/sshkit/runners/sequential.rb
    • /usr/share/doc/ruby-sshkit/FAQ.md
    • /usr/share/doc/ruby-sshkit/README.md.gz
    • /usr/share/doc/ruby-sshkit/changelog.Debian.gz
    • /usr/share/doc/ruby-sshkit/copyright
    • /usr/share/doc/ruby-sshkit/examples/EXAMPLES.md.gz

    Changelog

    2016-03-01 - Sebastien Badia <seb@sebian.fr> ruby-sshkit (1.9.0~rc1-1) unstable; urgency=medium * d/control: Bump Standards-Version to 3.9.7 (no changes) Update Vcs-* fields (use https erverywhere) * d/watch: Update watch file, use version 4 * Imported Upstream version (Closes: #795118) * Update Debian packaging using dh-make-ruby * d/patches: Refresh patchs * d/copyright: Upstream change from GPL to MIT license

    2015-05-04 - Sebastien Badia <seb@sebian.fr> ruby-sshkit (1.7.1-1) unstable; urgency=medium * New upstream release. * Fix Build-Depends (add minitest instead of rspec). * Update Vcs-Browser to cgit URL and HTTPS. * Bump Standards-Version to 3.9.6 (no further changes).

    2014-04-21 - Sebastien Badia <seb@sebian.fr> ruby-sshkit (1.4.0-1) unstable; urgency=low * Initial release (Closes: #745421)

    Advertisement
    Advertisement