ruby-sqlite3_1.3.11-2build1_i386.deb


Advertisement

Description

ruby-sqlite3 - SQLite3 interface for Ruby

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-sqlite3
Package version: 1.3.11
Package release: 2build1
Package architecture: i386
Package type: deb
Installed size: 149 B
Download size: 34.79 KB
Official Mirror: archive.ubuntu.com
This module allows Ruby programs to interface with the SQLite3 database engine. Note that this module is only compatible with SQLite 3.6.16 or newer.

Alternatives

    Download

    Source package: ruby-sqlite3

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-sqlite3 deb package:
      # sudo apt-get install ruby-sqlite3

    Files

    • /usr/lib/i386-linux-gnu/ruby/vendor_ruby/2.3.0/sqlite3/sqlite3_native.so
    • /usr/lib/ruby/vendor_ruby/sqlite3.rb
    • /usr/lib/ruby/vendor_ruby/sqlite3/constants.rb
    • /usr/lib/ruby/vendor_ruby/sqlite3/database.rb
    • /usr/lib/ruby/vendor_ruby/sqlite3/errors.rb
    • /usr/lib/ruby/vendor_ruby/sqlite3/pragmas.rb
    • /usr/lib/ruby/vendor_ruby/sqlite3/resultset.rb
    • /usr/lib/ruby/vendor_ruby/sqlite3/statement.rb
    • /usr/lib/ruby/vendor_ruby/sqlite3/translator.rb
    • /usr/lib/ruby/vendor_ruby/sqlite3/value.rb
    • /usr/lib/ruby/vendor_ruby/sqlite3/version.rb
    • /usr/share/doc-base/ruby-sqlite3-faq
    • /usr/share/doc/ruby-sqlite3/API_CHANGES.rdoc
    • /usr/share/doc/ruby-sqlite3/README.rdoc
    • /usr/share/doc/ruby-sqlite3/changelog.Debian.gz
    • /usr/share/doc/ruby-sqlite3/copyright
    • /usr/share/doc/ruby-sqlite3/faq.html
    • /usr/share/rubygems-integration/2.3.0/specifications/sqlite3-1.3.11.gemspec

    Changelog

    2016-03-14 - Matthias Klose <doko@ubuntu.com> ruby-sqlite3 (1.3.11-2build1) xenial; urgency=medium * No-change rebuild for ruby2.3-only support.

    2016-03-05 - Cédric Boutillier <boutil@debian.org> ruby-sqlite3 (1.3.11-2) unstable; urgency=medium * Team upload. * Use slugs instead of object ids to generate the FAQ in order to make package build reproducible. Thanks Lunar (Closes: #782884) * Use https:// in Vcs-* fields * Bump Standards-Version to 3.9.7 (no changes needed) * Run wrap-and-sort on packaging files

    2015-11-23 - Antonio Terceiro <terceiro@debian.org> ruby-sqlite3 (1.3.11-1) unstable; urgency=medium * New upstream release. - dropped handle-big-endian.diff, already applied upstream * Add Recommends: on sqlite3 * Add myself to Uploaders: * Update packaging with a new dh-make-ruby run

    2015-08-14 - Antonio Terceiro <terceiro@debian.org> ruby-sqlite3 (1.3.10-1) unstable; urgency=medium * New upstream release.

    2014-05-06 - Antonio Terceiro <terceiro@debian.org> ruby-sqlite3 (1.3.9-2) unstable; urgency=medium * Team upload. * debian/patches/handle-big-endian.diff: don't assume the native byte order is little endian. Based on initial patch suggested by David Suárez (Closes: #745929)

    2014-04-07 - Pirate Praveen <praveen@debian.org> ruby-sqlite3 (1.3.9-1) unstable; urgency=low * Team upload. * New upstream release. * Bump gem2deb build dep to 0.7.5~. - Drop ruby 1.9 * Remove already applied patch.

    2014-01-16 - Cédric Boutillier <boutil@debian.org> ruby-sqlite3 (1.3.8-2) unstable; urgency=medium * Team upload * add fix_test_insert_duplicate_records.patch to match messages modified in libsqlite3 3.8.2 (Closes: #735512) * Bump Standards-Version to 3.9.5 (no changes needed)

    2013-10-18 - Cédric Boutillier <boutil@debian.org> ruby-sqlite3 (1.3.8-1) unstable; urgency=low * Team upload * Imported Upstream version 1.3.8 * debian/control: + remove obsolete DM-Upload-Allowed flag + use canonical URI in Vcs-* fields + drop transitional packages + bump Standards-Version to 3.9.4 (no changes needed) + build against against gem2deb >= 0.5 to add support for Ruby 2.0 and drop Ruby 1.8 * debian/copyright: use copyright-format/1.0 official URL for Format * debian/watch: use gemwatch service * Update homepage to point to github.com/sparklemotion/sqlite3-ruby * Register SQLite3/Ruby FAQ in doc-base

    2012-06-24 - Antonio Terceiro <terceiro@debian.org> ruby-sqlite3 (1.3.6-2) unstable; urgency=low * Team upload. * Bump build-depends on gem2deb to >= 0.3.0~ * debian/rules: use debian/sqlite3-1.3.6.gemspec as a gemspec

    2012-04-21 - Dmitry Borodaenko <angdraug@debian.org> ruby-sqlite3 (1.3.6-1) unstable; urgency=low * New upstream release. * Standards-Version upgraded to 3.9.3. * Avoid requiring test/helper.rb twice to prevent the included monkey patch of Test::Unit::TestCase from breaking unit tests.

    Advertisement
    Advertisement