ruby-solve_2.0.2-1_all.deb


Advertisement

Description

ruby-solve - Ruby version constraint solver implementing semantic versioning

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-solve
Package version: 2.0.2
Package release: 1
Package architecture: all
Package type: deb
Installed size: 67 B
Download size: 12.57 KB
Official Mirror: archive.ubuntu.com
Ruby versioning constraint solver implementing Semantic Versioning 2.0.0 (see http://semver.org/). Solve supports two different resolvers. A pure Ruby solver implemented using Molinillo and the same dependency resolver the Chef Server uses, dep-selector, which is a Ruby C extension for Gecode. The Ruby solver is installed and enabled by default. If you'd like to use the Gecode solver you can do so by installing the ruby-dep-selector package.

Alternatives

    Download

    Source package: ruby-solve

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-solve deb package:
      # sudo apt-get install ruby-solve

    Files

    • /usr/lib/ruby/vendor_ruby/solve.rb
    • /usr/lib/ruby/vendor_ruby/solve/artifact.rb
    • /usr/lib/ruby/vendor_ruby/solve/constraint.rb
    • /usr/lib/ruby/vendor_ruby/solve/demand.rb
    • /usr/lib/ruby/vendor_ruby/solve/dependency.rb
    • /usr/lib/ruby/vendor_ruby/solve/errors.rb
    • /usr/lib/ruby/vendor_ruby/solve/gecode_solver.rb
    • /usr/lib/ruby/vendor_ruby/solve/graph.rb
    • /usr/lib/ruby/vendor_ruby/solve/ruby_solver.rb
    • /usr/lib/ruby/vendor_ruby/solve/version.rb
    • /usr/lib/ruby/vendor_ruby/solve/solver/serializer.rb
    • /usr/share/doc/ruby-solve/README.md
    • /usr/share/doc/ruby-solve/changelog.Debian.gz
    • /usr/share/doc/ruby-solve/copyright
    • /usr/share/rubygems-integration/all/specifications/solve-2.0.2.gemspec

    Changelog

    2016-03-03 - Sebastien Badia <seb@sebian.fr> ruby-solve (2.0.2-1) unstable; urgency=medium * Team upload [ Christian Hofstaedtler ] * Add patch for Molinillo 0.4 [ Sebastien Badia ] * Imported Upstream version (Closes: #816359) * Bump compat. version to 9 * d/control: Update Vcs-* fields (use https everywhere) Bump Standards-Version to 3.9.7 (no changes) * Update Debian packaging using dh-make-ruby * d/patches: Remove spork usage (ROM) Remove Change-Version-to-Semverse-Version patch (applied upstream)

    2015-07-24 - Hleb Valoshka <375gnu@gmail.com> ruby-solve (2.0.1-2) unstable; urgency=medium * Run tests for Gecode solver during package build. * Bump ruby-dep-selector version to require proper one.

    2015-06-26 - Hleb Valoshka <375gnu@gmail.com> ruby-solve (2.0.1-1) unstable; urgency=medium * Initial release.

    Advertisement
    Advertisement