ruby-soap4r_2.0.5-3build1_all.deb


Advertisement

Description

ruby-soap4r - SOAP library for the Ruby programming language

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-soap4r
Package version 2.0.5
Package release 3build1
Package architecture all
Package type deb
Installed size 678 B
Download size 94.51 KB
Official Mirror archive.ubuntu.com
This library was originally part of the standard library up until Ruby 1.8. It
was removed from the standard library in Ruby 1.9 for compatibility reasons.
This version of the library was forward-ported to Ruby 1.9.

Alternatives

Package Version Architecture Repository
ruby-soap4r_2.0.5-3build1_all.deb 2.0.5 all Ubuntu Universe
ruby-soap4r - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-soap4r_2.0.5-3build1_all.deb
Source Package ruby-soap4r

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-soap4r deb package:
    # sudo apt-get install ruby-soap4r

Files

Path
/usr/lib/ruby/vendor_ruby/soap/attachment.rb
/usr/lib/ruby/vendor_ruby/soap/attrproxy.rb
/usr/lib/ruby/vendor_ruby/soap/baseData.rb
/usr/lib/ruby/vendor_ruby/soap/element.rb
/usr/lib/ruby/vendor_ruby/soap/filter.rb
/usr/lib/ruby/vendor_ruby/soap/generator.rb
/usr/lib/ruby/vendor_ruby/soap/httpconfigloader.rb
/usr/lib/ruby/vendor_ruby/soap/mapping.rb
/usr/lib/ruby/vendor_ruby/soap/marshal.rb
/usr/lib/ruby/vendor_ruby/soap/mimemessage.rb
/usr/lib/ruby/vendor_ruby/soap/nestedexception.rb
/usr/lib/ruby/vendor_ruby/soap/netHttpClient.rb
/usr/lib/ruby/vendor_ruby/soap/ns.rb
/usr/lib/ruby/vendor_ruby/soap/parser.rb
/usr/lib/ruby/vendor_ruby/soap/processor.rb
/usr/lib/ruby/vendor_ruby/soap/property.rb
/usr/lib/ruby/vendor_ruby/soap/proxy.rb
/usr/lib/ruby/vendor_ruby/soap/ruby18ext.rb
/usr/lib/ruby/vendor_ruby/soap/soap.rb
/usr/lib/ruby/vendor_ruby/soap/streamHandler.rb
/usr/lib/ruby/vendor_ruby/soap/wsdlDriver.rb
/usr/lib/ruby/vendor_ruby/soap/encodingstyle/aspDotNetHandler.rb
/usr/lib/ruby/vendor_ruby/soap/encodingstyle/handler.rb
/usr/lib/ruby/vendor_ruby/soap/encodingstyle/literalHandler.rb
/usr/lib/ruby/vendor_ruby/soap/encodingstyle/soapHandler.rb
/usr/lib/ruby/vendor_ruby/soap/filter/filterchain.rb
/usr/lib/ruby/vendor_ruby/soap/filter/handler.rb
/usr/lib/ruby/vendor_ruby/soap/filter/streamhandler.rb
/usr/lib/ruby/vendor_ruby/soap/header/handler.rb
/usr/lib/ruby/vendor_ruby/soap/header/handlerset.rb
/usr/lib/ruby/vendor_ruby/soap/header/mappinghandler.rb
/usr/lib/ruby/vendor_ruby/soap/header/simplehandler.rb
/usr/lib/ruby/vendor_ruby/soap/mapping/encodedregistry.rb
/usr/lib/ruby/vendor_ruby/soap/mapping/factory.rb
/usr/lib/ruby/vendor_ruby/soap/mapping/literalregistry.rb
/usr/lib/ruby/vendor_ruby/soap/mapping/mapping.rb
/usr/lib/ruby/vendor_ruby/soap/mapping/registry.rb
/usr/lib/ruby/vendor_ruby/soap/mapping/rubytypeFactory.rb
/usr/lib/ruby/vendor_ruby/soap/mapping/schemadefinition.rb
/usr/lib/ruby/vendor_ruby/soap/mapping/typeMap.rb
/usr/lib/ruby/vendor_ruby/soap/mapping/wsdlencodedregistry.rb
/usr/lib/ruby/vendor_ruby/soap/mapping/wsdlliteralregistry.rb
/usr/lib/ruby/vendor_ruby/soap/rpc/cgistub.rb
/usr/lib/ruby/vendor_ruby/soap/rpc/driver.rb
/usr/lib/ruby/vendor_ruby/soap/rpc/element.rb
/usr/lib/ruby/vendor_ruby/soap/rpc/httpserver.rb
/usr/lib/ruby/vendor_ruby/soap/rpc/methodDef.rb
/usr/lib/ruby/vendor_ruby/soap/rpc/proxy.rb
/usr/lib/ruby/vendor_ruby/soap/rpc/router.rb
/usr/lib/ruby/vendor_ruby/soap/rpc/rpc.rb
/usr/lib/ruby/vendor_ruby/soap/rpc/soaplet.rb
/usr/lib/ruby/vendor_ruby/soap/rpc/standaloneServer.rb
/usr/lib/ruby/vendor_ruby/wsdl/binding.rb
/usr/lib/ruby/vendor_ruby/wsdl/data.rb
/usr/lib/ruby/vendor_ruby/wsdl/definitions.rb
/usr/lib/ruby/vendor_ruby/wsdl/documentation.rb
/usr/lib/ruby/vendor_ruby/wsdl/import.rb
/usr/lib/ruby/vendor_ruby/wsdl/importer.rb
/usr/lib/ruby/vendor_ruby/wsdl/info.rb
/usr/lib/ruby/vendor_ruby/wsdl/message.rb
/usr/lib/ruby/vendor_ruby/wsdl/operation.rb
/usr/lib/ruby/vendor_ruby/wsdl/operationBinding.rb
/usr/lib/ruby/vendor_ruby/wsdl/param.rb
/usr/lib/ruby/vendor_ruby/wsdl/parser.rb
/usr/lib/ruby/vendor_ruby/wsdl/part.rb
/usr/lib/ruby/vendor_ruby/wsdl/port.rb
/usr/lib/ruby/vendor_ruby/wsdl/portType.rb
/usr/lib/ruby/vendor_ruby/wsdl/service.rb
/usr/lib/ruby/vendor_ruby/wsdl/types.rb
/usr/lib/ruby/vendor_ruby/wsdl/wsdl.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/address.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/binding.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/body.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/cgiStubCreator.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/classDefCreator.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/classDefCreatorSupport.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/classNameCreator.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/clientSkeltonCreator.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/complexType.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/data.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/definitions.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/driverCreator.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/element.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/encodedMappingRegistryCreator.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/fault.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/header.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/headerfault.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/literalMappingRegistryCreator.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/mappingRegistryCreator.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/mappingRegistryCreatorSupport.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/methodDefCreator.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/operation.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/servantSkeltonCreator.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/servletStubCreator.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/standaloneServerStubCreator.rb
/usr/lib/ruby/vendor_ruby/wsdl/soap/wsdl2ruby.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/all.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/annotation.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/any.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/anyAttribute.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/attribute.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/attributeGroup.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/choice.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/complexContent.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/complexExtension.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/complexRestriction.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/complexType.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/content.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/data.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/element.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/enumeration.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/fractiondigits.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/group.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/import.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/importHandler.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/importer.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/include.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/length.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/list.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/maxexclusive.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/maxinclusive.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/maxlength.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/minexclusive.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/mininclusive.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/minlength.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/parser.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/pattern.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/ref.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/schema.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/sequence.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/simpleContent.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/simpleExtension.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/simpleRestriction.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/simpleType.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/totaldigits.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/union.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/unique.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/whitespace.rb
/usr/lib/ruby/vendor_ruby/wsdl/xmlSchema/xsd2ruby.rb
/usr/lib/ruby/vendor_ruby/xsd/charset.rb
/usr/lib/ruby/vendor_ruby/xsd/codegen.rb
/usr/lib/ruby/vendor_ruby/xsd/datatypes.rb
/usr/lib/ruby/vendor_ruby/xsd/datatypes1999.rb
/usr/lib/ruby/vendor_ruby/xsd/iconvcharset.rb
/usr/lib/ruby/vendor_ruby/xsd/mapping.rb
/usr/lib/ruby/vendor_ruby/xsd/namedelements.rb
/usr/lib/ruby/vendor_ruby/xsd/ns.rb
/usr/lib/ruby/vendor_ruby/xsd/qname.rb
/usr/lib/ruby/vendor_ruby/xsd/xmlparser.rb
/usr/lib/ruby/vendor_ruby/xsd/codegen/classdef.rb
/usr/lib/ruby/vendor_ruby/xsd/codegen/commentdef.rb
/usr/lib/ruby/vendor_ruby/xsd/codegen/gensupport.rb
/usr/lib/ruby/vendor_ruby/xsd/codegen/methoddef.rb
/usr/lib/ruby/vendor_ruby/xsd/codegen/moduledef.rb
/usr/lib/ruby/vendor_ruby/xsd/xmlparser/libxmlparser.rb
/usr/lib/ruby/vendor_ruby/xsd/xmlparser/parser.rb
/usr/lib/ruby/vendor_ruby/xsd/xmlparser/rexmlparser.rb
/usr/lib/ruby/vendor_ruby/xsd/xmlparser/xmlparser.rb
/usr/lib/ruby/vendor_ruby/xsd/xmlparser/xmlscanner.rb
/usr/share/doc/ruby-soap4r/changelog.Debian.gz
/usr/share/doc/ruby-soap4r/copyright
/usr/share/doc/ruby-soap4r/examples/wsdl2ruby.rb
/usr/share/doc/ruby-soap4r/examples/xsd2ruby.rb
/usr/share/rubygems-integration/all/specifications/soap4r-ruby1.9-2.0.5.gemspec

Changelog

2014-04-30 - Matthias Klose <doko@ubuntu.com>
ruby-soap4r (2.0.5-3build1) utopic; urgency=medium
* No-change rebuild to update the Ruby-Version attribute.
2014-01-06 - Antonio Terceiro <terceiro@debian.org>
ruby-soap4r (2.0.5-3) unstable; urgency=medium
[ David Suárez ]
* Fix failing tests on ruby2.0 (Closes: #730912)
* debian/source/options: remove 'single-debian-patch' options and add 
'unapply-patches' one
[ Antonio Terceiro ]
* Don't use ruby-libxml based parser
added debian/patches/dont-use-libxml-based-parser.patch.
The parser seems to be written for a old version of ruby-libxml and my
quick attempt at fixing it didn't work. My level of patience with
anything that involves XML is quite low, so it's possible that the
problem is still properly fixable. (Closes: #725672)
2013-09-07 - Antonio Terceiro <terceiro@debian.org>
ruby-soap4r (2.0.5-2) unstable; urgency=low
* Remove usage os iconv which is deprecated under Ruby 1.9
* Ignore test failures on Ruby 1.8 which will go away soon.
2013-08-11 - Antonio Terceiro <terceiro@debian.org>
ruby-soap4r (2.0.5-1) unstable; urgency=low
* Initial release (Closes: #629979)

See Also

Package Description
ruby-solve_2.0.2-1_all.deb Ruby version constraint solver implementing semantic versioning
ruby-source-map_3.0.1+git.20120229.bda06a3f-1_all.deb ruby support for source maps in javascripts
ruby-specinfra_2.35.1-1_all.deb Common layer for serverspec and configspec
ruby-spider_0.4.4-2_all.deb web spidering library for Ruby
ruby-spoon_0.0.4-2_all.deb FFI binding of the posix_spawn function for Ruby
ruby-spreadsheet_1.0.0-1_all.deb Ruby library for manipulating MS Excel (.xls) spreadsheets
ruby-spring_1.3.6-2_all.deb Rails application preloader
ruby-sprite-factory_1.7.1-2_all.deb automatic css sprite generator
ruby-sprockets-rails_2.3.2-1_all.deb Sprockets Rails integration (part of Rails)
ruby-sprockets_3.3.0-1_all.deb Rack-based asset packaging system
ruby-spy_0.4.2-1_all.deb simple modern mocking library using the spy pattern
ruby-sqlite3_1.3.11-2build1_i386.deb SQLite3 interface for Ruby
ruby-sshkit_1.9.0~rc1-1_all.deb toolkit for running commands in a structured way on one or more servers
ruby-stamp_0.6.0-1_all.deb date and time formatting for humans
ruby-standalone_0.5.1_i386.deb Ruby interpreter that won't integrate with Debian packages
Advertisement
Advertisement