ruby-slop_4.2.0-1_all.deb


Advertisement

Description

ruby-slop - Simple DSL for gathering options and parsing the command lineOption

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-slop
Package version 4.2.0
Package release 1
Package architecture all
Package type deb
Installed size 44 B
Download size 11.90 KB
Official Mirror archive.ubuntu.com
Slop is a simple option parser with an easy to remember syntax and
friendly API.

Alternatives

Package Version Architecture Repository
ruby-slop_4.2.0-1_all.deb 4.2.0 all Ubuntu Universe
ruby-slop - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-slop_4.2.0-1_all.deb
Source Package ruby-slop

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-slop deb package:
    # sudo apt-get install ruby-slop

Files

Path
/usr/lib/ruby/vendor_ruby/slop.rb
/usr/lib/ruby/vendor_ruby/slop/error.rb
/usr/lib/ruby/vendor_ruby/slop/option.rb
/usr/lib/ruby/vendor_ruby/slop/options.rb
/usr/lib/ruby/vendor_ruby/slop/parser.rb
/usr/lib/ruby/vendor_ruby/slop/result.rb
/usr/lib/ruby/vendor_ruby/slop/types.rb
/usr/share/doc/ruby-slop/CHANGELOG.md.gz
/usr/share/doc/ruby-slop/README.md.gz
/usr/share/doc/ruby-slop/changelog.Debian.gz
/usr/share/doc/ruby-slop/copyright
/usr/share/rubygems-integration/all/specifications/slop-4.2.0.gemspec

Changelog

2015-07-29 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-slop (4.2.0-1) unstable; urgency=medium
* Imported Upstream version 4.2.0
* Update debian/rules: follow upstream file renaming
* Bump Standard Version: 3.9.6
2014-08-12 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-slop (3.6.0-1) unstable; urgency=medium
* Imported Upstream version 3.6.0
2014-05-12 - Antonio Terceiro <terceiro@debian.org>
ruby-slop (3.5.0-1) unstable; urgency=medium
* New upstream release
2013-12-15 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-slop (3.4.7-1) unstable; urgency=medium
[ Jonas Genannt ]
* Team upload.
* Imported Upstream version 3.4.7
* d/control: bumped up standards version to 3.9.5 (no changes needed)
* d/control: changed dependency from ruby1.8 to ruby
[ Youhei SASAKI ]
* Update debian/changelog
2013-08-05 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-slop (3.4.6-1) unstable; urgency=low
* Imported Upstream version 3.4.6
* Bump Standard Version: 3.9.4
2013-05-27 - Ondřej Surý <ondrej@debian.org>
ruby-slop (3.4.5-1) unstable; urgency=low
[ Cédric Boutillier ]
* debian/control: remove obsolete DM-Upload-Allowed flag
* Use canonical URI in Vcs-* fields
* debian/copyright: use DEP5 copyright-format/1.0 official URL for Format field
[ Ondřej Surý ]
* Imported Upstream version 3.4.5
2013-01-20 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-slop (3.4.3-1) experimental; urgency=low
* Imported Upstream version 3.4.3
* Update upstream url: use gemwatch
* Install upstream changelog as CHANGES.md
* Bump Standard version: 3.9.3
2012-01-29 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-slop (2.4.4-1) unstable; urgency=low
* Initial release (Closes: #657765)

See Also

Package Description
ruby-snmp_1.2.0-1_all.deb simple network management protocol bindings for ruby
ruby-soap4r_2.0.5-3build1_all.deb SOAP library for the Ruby programming language
ruby-solve_2.0.2-1_all.deb Ruby version constraint solver implementing semantic versioning
ruby-source-map_3.0.1+git.20120229.bda06a3f-1_all.deb ruby support for source maps in javascripts
ruby-specinfra_2.35.1-1_all.deb Common layer for serverspec and configspec
ruby-spider_0.4.4-2_all.deb web spidering library for Ruby
ruby-spoon_0.0.4-2_all.deb FFI binding of the posix_spawn function for Ruby
ruby-spreadsheet_1.0.0-1_all.deb Ruby library for manipulating MS Excel (.xls) spreadsheets
ruby-spring_1.3.6-2_all.deb Rails application preloader
ruby-sprite-factory_1.7.1-2_all.deb automatic css sprite generator
ruby-sprockets-rails_2.3.2-1_all.deb Sprockets Rails integration (part of Rails)
ruby-sprockets_3.3.0-1_all.deb Rack-based asset packaging system
ruby-spy_0.4.2-1_all.deb simple modern mocking library using the spy pattern
ruby-sqlite3_1.3.11-2build1_i386.deb SQLite3 interface for Ruby
ruby-sshkit_1.9.0~rc1-1_all.deb toolkit for running commands in a structured way on one or more servers
Advertisement
Advertisement