ruby-slim_3.0.6-1_all.deb


Advertisement

Description

ruby-slim - powerful (X)HTML templating engine with an elegant syntax

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-slim
Package version: 3.0.6
Package release: 1
Package architecture: all
Package type: deb
Installed size: 123 B
Download size: 33.32 KB
Official Mirror: archive.ubuntu.com
Slim is a template language whose goal is to reduce the view syntax to the essential parts without becoming cryptic. A short list of the features: - elegant syntax: short syntax without closing tags, HTML style mode with closing tags and configurable shortcut tags - automatic HTML escaping and support for Rails' `html_safe?` - highly configurable and extendable via plugins: logic less mode similar to Mustache and translator/I18n support among others. - high performance: comparable speed to ERB and streaming support in Rails - supported by all major frameworks (Rails, Sinatra, ...) - full Unicode support for tags and attributes on Ruby 1.9 - embedded engines like Markdown and Textile

Alternatives

    Download

    Binary package: ruby-slim_3.0.6-1_all.deb
    Source package: ruby-slim

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-slim deb package:
      # sudo apt-get install ruby-slim

    Files

    • /usr/lib/ruby/vendor_ruby/slim.rb
    • /usr/lib/ruby/vendor_ruby/slim/code_attributes.rb
    • /usr/lib/ruby/vendor_ruby/slim/command.rb
    • /usr/lib/ruby/vendor_ruby/slim/controls.rb
    • /usr/lib/ruby/vendor_ruby/slim/do_inserter.rb
    • /usr/lib/ruby/vendor_ruby/slim/embedded.rb
    • /usr/lib/ruby/vendor_ruby/slim/end_inserter.rb
    • /usr/lib/ruby/vendor_ruby/slim/engine.rb
    • /usr/lib/ruby/vendor_ruby/slim/erb_converter.rb
    • /usr/lib/ruby/vendor_ruby/slim/filter.rb
    • /usr/lib/ruby/vendor_ruby/slim/grammar.rb
    • /usr/lib/ruby/vendor_ruby/slim/include.rb
    • /usr/lib/ruby/vendor_ruby/slim/interpolation.rb
    • /usr/lib/ruby/vendor_ruby/slim/logic_less.rb
    • /usr/lib/ruby/vendor_ruby/slim/parser.rb
    • /usr/lib/ruby/vendor_ruby/slim/smart.rb
    • /usr/lib/ruby/vendor_ruby/slim/template.rb
    • /usr/lib/ruby/vendor_ruby/slim/translator.rb
    • /usr/lib/ruby/vendor_ruby/slim/version.rb
    • /usr/lib/ruby/vendor_ruby/slim/logic_less/context.rb
    • /usr/lib/ruby/vendor_ruby/slim/logic_less/filter.rb
    • /usr/lib/ruby/vendor_ruby/slim/smart/escaper.rb
    • /usr/lib/ruby/vendor_ruby/slim/smart/filter.rb
    • /usr/lib/ruby/vendor_ruby/slim/smart/parser.rb
    • /usr/lib/ruby/vendor_ruby/slim/splat/builder.rb
    • /usr/lib/ruby/vendor_ruby/slim/splat/filter.rb
    • /usr/share/doc/ruby-slim/README.md.gz
    • /usr/share/doc/ruby-slim/changelog.Debian.gz
    • /usr/share/doc/ruby-slim/copyright
    • /usr/share/doc/ruby-slim/examples/slimrb
    • /usr/share/rubygems-integration/all/specifications/slim-3.0.6.gemspec

    Changelog

    2015-09-09 - Jérémy Bobbio <lunar@debian.org> ruby-slim (3.0.6-1) unstable; urgency=low * New upstream version. * Update Build-Depends. * Switch to debhelper compat level 9. * Update Vcs-* URL. * Remove obsolete patches. * Update debian/copyright. * Bump Standards-Version, no changes required..

    2014-05-13 - Jérémy Bobbio <lunar@debian.org> ruby-slim (2.0.2-3) unstable; urgency=low * Remove obsolete patch now that dependencies have been updated. (Closes: #747745)

    2014-04-14 - Christian Hofstaedtler <zeha@debian.org> ruby-slim (2.0.2-2) unstable; urgency=medium * Team upload. * Fix ruby-interpreter dependency. In 2.0.2-1 compatibility with all Ruby versions was restored, so this package should depend on ruby | ruby-interpreter over (the outdated) ruby1.9.1.

    2014-04-11 - Jérémy Bobbio <lunar@debian.org> ruby-slim (2.0.2-1) unstable; urgency=low * New upstream version. * Tighten the Build-Dependency on ruby-tilt * Latest versions should support all Ruby versions currently in Debian. (Closes: #744041) * Bump Standards-Version, no changes required. * Revert an upstream patch to fix 'pretty' test case. * Stop running tests using Sinatra as they need Sinatra's sources.

    2013-09-03 - Jérémy Bobbio <lunar@debian.org> ruby-slim (2.0.1-1) unstable; urgency=low [ Jérémy Bobbio ] * New upstream version. (Closes: #718066) * Update Depends and Build-Depends. * Drop obsolete patch. * Drop support for Ruby 1.8. [ Cédric Boutillier ] * Use canonical URI in Vcs-* fields.

    2013-04-13 - Jérémy Bobbio <lunar@debian.org> ruby-slim (2.0.0~pre6-1) unstable; urgency=low * Initial release (Closes: #703182)

    Advertisement
    Advertisement