ruby-sinatra-contrib_1.4.6-2_all.deb


Advertisement

Description

ruby-sinatra-contrib - collection of useful extensions to the Sinatra web framework

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-sinatra-contrib
Package version 1.4.6
Package release 2
Package architecture all
Package type deb
Installed size 118 B
Download size 26.27 KB
Official Mirror archive.ubuntu.com
sinatra-contrib is a collection of common extensions to the Sinatra web
framework, semi-officially supported:
- capture: Let's you capture the content of blocks in templates.
- config_file: Allows loading configuration from yaml files.
- content_for: Adds Rails-style content_for helpers to Haml, Erb,
Erubis and Slim.
- cookies: A cookies helper for reading and writing cookies.
- engine_tracking: Adds methods like haml? that allow helper methods
to check whether they are called from within a template.
- json: Adds a #json helper method to return JSON documents.
- link_header: Helpers for generating link HTML tags and
corresponding Link HTTP headers. Adds link, stylesheet and prefetch helper
methods.
- multi_route: Adds ability to define one route block for multiple
routes and multiple or custom HTTP verbs.
- namespace: Adds namespace support to Sinatra.
- respond_with: Choose action and/or template automatically depending
on the incoming request. Adds helpers respond_to and respond_with.
- custom_logger: Allows one to define their own logger instance.
- decompile: Recreates path patterns from Sinatra's internal data
structures (used by other extensions).
- reloader: Automatically reloads Ruby files on code changes.
- extension: Mixin for writing your own Sinatra extensions.
- test_helpers: Helper methods to ease testing your Sinatra
application. Partly extracted from Sinatra. Testing framework agnostic.

Alternatives

Package Version Architecture Repository
ruby-sinatra-contrib_1.4.6-2_all.deb 1.4.6 all Ubuntu Universe
ruby-sinatra-contrib - - -

Requires

Name Value
ruby -
ruby-backports >= 2.0~
ruby-interpreter -
ruby-multi-json -
ruby-rack-protection -
ruby-rack-test -
ruby-sinatra >= 1.4.2~
ruby-tilt >= 1.3~

Download

Type URL
Binary Package ruby-sinatra-contrib_1.4.6-2_all.deb
Source Package ruby-sinatra-contrib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-sinatra-contrib deb package:
    # sudo apt-get install ruby-sinatra-contrib

Files

Path
/usr/lib/ruby/vendor_ruby/sinatra/capture.rb
/usr/lib/ruby/vendor_ruby/sinatra/config_file.rb
/usr/lib/ruby/vendor_ruby/sinatra/content_for.rb
/usr/lib/ruby/vendor_ruby/sinatra/contrib.rb
/usr/lib/ruby/vendor_ruby/sinatra/cookies.rb
/usr/lib/ruby/vendor_ruby/sinatra/custom_logger.rb
/usr/lib/ruby/vendor_ruby/sinatra/decompile.rb
/usr/lib/ruby/vendor_ruby/sinatra/engine_tracking.rb
/usr/lib/ruby/vendor_ruby/sinatra/extension.rb
/usr/lib/ruby/vendor_ruby/sinatra/json.rb
/usr/lib/ruby/vendor_ruby/sinatra/link_header.rb
/usr/lib/ruby/vendor_ruby/sinatra/multi_route.rb
/usr/lib/ruby/vendor_ruby/sinatra/namespace.rb
/usr/lib/ruby/vendor_ruby/sinatra/reloader.rb
/usr/lib/ruby/vendor_ruby/sinatra/respond_with.rb
/usr/lib/ruby/vendor_ruby/sinatra/streaming.rb
/usr/lib/ruby/vendor_ruby/sinatra/test_helpers.rb
/usr/lib/ruby/vendor_ruby/sinatra/contrib/all.rb
/usr/lib/ruby/vendor_ruby/sinatra/contrib/setup.rb
/usr/lib/ruby/vendor_ruby/sinatra/contrib/version.rb
/usr/share/doc/ruby-sinatra-contrib/README.md
/usr/share/doc/ruby-sinatra-contrib/changelog.Debian.gz
/usr/share/doc/ruby-sinatra-contrib/copyright
/usr/share/doc/ruby-sinatra-contrib/ideas.md
/usr/share/rubygems-integration/all/specifications/sinatra-contrib-1.4.6.gemspec

Changelog

2016-02-18 - Jérémy Bobbio <lunar@debian.org>
ruby-sinatra-contrib (1.4.6-2) unstable; urgency=medium
* Remove unavailable dependencies from the list of engines. (Closes: #812189)
2015-09-09 - Jérémy Bobbio <lunar@debian.org>
ruby-sinatra-contrib (1.4.6-1) unstable; urgency=low
* New upstream version.
* Add new Build-Depends.
* Remove obsolete patches.
* Add a patch to remove the dependency on less.
* Update extended package description.
* Update Vcs-* URL.
2015-08-19 - Jonas Genannt <genannt@debian.org>
ruby-sinatra-contrib (1.4.2-2) unstable; urgency=medium
* Team upload.
* Added patch for RSpec3 (Closes: #795117)
* d/control:
- wrap-sort
- d/control: bumped standards version to 3.9.6
- changed Homepage URL to https
* Bumped compats level to 9
2014-04-11 - Jérémy Bobbio <lunar@debian.org>
ruby-sinatra-contrib (1.4.2-1) unstable; urgency=low
* New upstream version. (Closes: #738420)
* Bump Standards-Version, no changes required.
2013-08-29 - Jérémy Bobbio <lunar@debian.org>
ruby-sinatra-contrib (1.4.1-1) unstable; urgency=low
* New upstream version. (Closes: #713163)
* Update Depends and Build-Depends.
2013-04-19 - Jérémy Bobbio <lunar@debian.org>
ruby-sinatra-contrib (1.3.2-1) unstable; urgency=low
* Initial release (Closes: #703068)

See Also

Package Description
ruby-sinatra-simple-navigation_3.6.0-1build1_all.deb Extension providing simple navigations for Sinatra or Padrino
ruby-sinatra_1.4.7-3_all.deb Ruby web-development dressed in a DSL
ruby-sinon-rails_1.9.0-1_all.deb provides sinon.js via asset pipeline for rails apps
ruby-six_0.2.0-3_all.deb very simple authorization library for Ruby
ruby-slack-notifier_1.2.1-1_all.deb Ruby wrapper for posting to slack webhooks
ruby-slim_3.0.6-1_all.deb powerful (X)HTML templating engine with an elegant syntax
ruby-slop_4.2.0-1_all.deb Simple DSL for gathering options and parsing the command lineOption
ruby-snmp_1.2.0-1_all.deb simple network management protocol bindings for ruby
ruby-soap4r_2.0.5-3build1_all.deb SOAP library for the Ruby programming language
ruby-solve_2.0.2-1_all.deb Ruby version constraint solver implementing semantic versioning
ruby-source-map_3.0.1+git.20120229.bda06a3f-1_all.deb ruby support for source maps in javascripts
ruby-specinfra_2.35.1-1_all.deb Common layer for serverspec and configspec
ruby-spider_0.4.4-2_all.deb web spidering library for Ruby
ruby-spoon_0.0.4-2_all.deb FFI binding of the posix_spawn function for Ruby
ruby-spreadsheet_1.0.0-1_all.deb Ruby library for manipulating MS Excel (.xls) spreadsheets
Advertisement
Advertisement