ruby-simple-oauth_0.3.1-2_all.deb


Advertisement

Description

ruby-simple-oauth - Simply builds and verifies OAuth headers

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-simple-oauth
Package version 0.3.1
Package release 2
Package architecture all
Package type deb
Installed size 27 B
Download size 5.35 KB
Official Mirror archive.ubuntu.com
The library, "simple_oauth", provides classes in order to simply build
and verify OAuth headers.
This library aims to support and is tested against the following Ruby
implementations:
Ruby 1.8.7
Ruby 1.9.3
Ruby 2.0.0
Ruby 2.1
JRuby
Rubinius
If something doesn't work on one of these interpreters, it's a bug.

Alternatives

Package Version Architecture Repository
ruby-simple-oauth_0.3.1-2_all.deb 0.3.1 all Ubuntu Universe
ruby-simple-oauth - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-simple-oauth_0.3.1-2_all.deb
Source Package ruby-simple-oauth

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-simple-oauth deb package:
    # sudo apt-get install ruby-simple-oauth

Files

Path
/usr/lib/ruby/vendor_ruby/simple_oauth.rb
/usr/lib/ruby/vendor_ruby/simple_oauth/header.rb
/usr/share/doc/ruby-simple-oauth/README.md
/usr/share/doc/ruby-simple-oauth/changelog.Debian.gz
/usr/share/doc/ruby-simple-oauth/copyright
/usr/share/lintian/overrides/ruby-simple-oauth
/usr/share/rubygems-integration/all/specifications/simple_oauth-0.3.1.gemspec

Changelog

2015-08-06 - Pirate Praveen <praveen@debian.org>
ruby-simple-oauth (0.3.1-2) unstable; urgency=medium
* Install gemspec file (remove git ls usage in gemspec) 
2015-07-29 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-simple-oauth (0.3.1-1) unstable; urgency=medium
* Update debian/watch: use Github as upstream
* Imported Upstream version 0.3.1
* Refresh patches
* Bump Standard Version: 3.9.6
* Update long description
2014-05-05 - Pirate Praveen <praveen@debian.org>
ruby-simple-oauth (0.2.0-2) unstable; urgency=low
* Rebuild with gem2deb >= 0.7.5 (install gemspec for all ruby versions)
* Bump standards version to 3.9.5 (no changes)
2013-05-18 - Praveen Arimbrathodiyil <praveen@debian.org>
ruby-simple-oauth (0.2.0-1) unstable; urgency=low
* Initial release (Closes: #635727)
[ Youhei SASAKI ]
* Initial packaging

See Also

Package Description
ruby-simplecov-html_0.10.0-1_all.deb default HTML formatter for SimpleCov code coverage tool
ruby-simplecov_0.11.1-1_all.deb code coverage for Ruby 1.9+
ruby-sinatra-contrib_1.4.6-2_all.deb collection of useful extensions to the Sinatra web framework
ruby-sinatra-simple-navigation_3.6.0-1build1_all.deb Extension providing simple navigations for Sinatra or Padrino
ruby-sinatra_1.4.7-3_all.deb Ruby web-development dressed in a DSL
ruby-sinon-rails_1.9.0-1_all.deb provides sinon.js via asset pipeline for rails apps
ruby-six_0.2.0-3_all.deb very simple authorization library for Ruby
ruby-slack-notifier_1.2.1-1_all.deb Ruby wrapper for posting to slack webhooks
ruby-slim_3.0.6-1_all.deb powerful (X)HTML templating engine with an elegant syntax
ruby-slop_4.2.0-1_all.deb Simple DSL for gathering options and parsing the command lineOption
ruby-snmp_1.2.0-1_all.deb simple network management protocol bindings for ruby
ruby-soap4r_2.0.5-3build1_all.deb SOAP library for the Ruby programming language
ruby-solve_2.0.2-1_all.deb Ruby version constraint solver implementing semantic versioning
ruby-source-map_3.0.1+git.20120229.bda06a3f-1_all.deb ruby support for source maps in javascripts
ruby-specinfra_2.35.1-1_all.deb Common layer for serverspec and configspec
Advertisement
Advertisement