ruby-simple-form_3.2.0-1_all.deb


Advertisement

Description

ruby-simple-form - library to simplify the creation of forms in Rails applications

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-simple-form
Package version 3.2.0
Package release 1
Package architecture all
Package type deb
Installed size 185 B
Download size 38.21 KB
Official Mirror archive.ubuntu.com
Simple Form provides a stack of components that can be invoked to create
complete HTML inputs on Rails application , which by default contains label,
hints, errors and the input itself. Simple Form reduces duplication and helps
having a consistent form usage across the application.

Alternatives

Package Version Architecture Repository
ruby-simple-form_3.2.0-1_all.deb 3.2.0 all Ubuntu Universe
ruby-simple-form - - -

Requires

Name Value
ruby -
ruby-actionpack >= 2:4.0
ruby-activemodel >= 2:4.0
ruby-interpreter -

Download

Type URL
Binary Package ruby-simple-form_3.2.0-1_all.deb
Source Package ruby-simple-form

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-simple-form deb package:
    # sudo apt-get install ruby-simple-form

Files

Path
/usr/lib/ruby/vendor_ruby/simple_form.rb
/usr/lib/ruby/vendor_ruby/generators/simple_form/USAGE
/usr/lib/ruby/vendor_ruby/generators/simple_form/install_generator.rb
/usr/lib/ruby/vendor_ruby/generators/simple_form/templates/README
/usr/lib/ruby/vendor_ruby/generators/simple_form/templates/_form.html.erb
/usr/lib/ruby/vendor_ruby/generators/simple_form/templates/_form.html.haml
/usr/lib/ruby/vendor_ruby/generators/simple_form/templates/_form.html.slim
/usr/lib/ruby/vendor_ruby/generators/simple_form/templates/config/initializers/simple_form.rb
/usr/lib/ruby/vendor_ruby/generators/simple_form/templates/config/initializers/simple_form_bootstrap.rb
/usr/lib/ruby/vendor_ruby/generators/simple_form/templates/config/initializers/simple_form_foundation.rb
/usr/lib/ruby/vendor_ruby/generators/simple_form/templates/config/locales/simple_form.en.yml
/usr/lib/ruby/vendor_ruby/simple_form/components.rb
/usr/lib/ruby/vendor_ruby/simple_form/error_notification.rb
/usr/lib/ruby/vendor_ruby/simple_form/form_builder.rb
/usr/lib/ruby/vendor_ruby/simple_form/helpers.rb
/usr/lib/ruby/vendor_ruby/simple_form/i18n_cache.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs.rb
/usr/lib/ruby/vendor_ruby/simple_form/map_type.rb
/usr/lib/ruby/vendor_ruby/simple_form/railtie.rb
/usr/lib/ruby/vendor_ruby/simple_form/tags.rb
/usr/lib/ruby/vendor_ruby/simple_form/version.rb
/usr/lib/ruby/vendor_ruby/simple_form/wrappers.rb
/usr/lib/ruby/vendor_ruby/simple_form/action_view_extensions/builder.rb
/usr/lib/ruby/vendor_ruby/simple_form/action_view_extensions/form_helper.rb
/usr/lib/ruby/vendor_ruby/simple_form/components/errors.rb
/usr/lib/ruby/vendor_ruby/simple_form/components/hints.rb
/usr/lib/ruby/vendor_ruby/simple_form/components/html5.rb
/usr/lib/ruby/vendor_ruby/simple_form/components/label_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/components/labels.rb
/usr/lib/ruby/vendor_ruby/simple_form/components/maxlength.rb
/usr/lib/ruby/vendor_ruby/simple_form/components/min_max.rb
/usr/lib/ruby/vendor_ruby/simple_form/components/pattern.rb
/usr/lib/ruby/vendor_ruby/simple_form/components/placeholders.rb
/usr/lib/ruby/vendor_ruby/simple_form/components/readonly.rb
/usr/lib/ruby/vendor_ruby/simple_form/helpers/autofocus.rb
/usr/lib/ruby/vendor_ruby/simple_form/helpers/disabled.rb
/usr/lib/ruby/vendor_ruby/simple_form/helpers/readonly.rb
/usr/lib/ruby/vendor_ruby/simple_form/helpers/required.rb
/usr/lib/ruby/vendor_ruby/simple_form/helpers/validators.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/base.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/block_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/boolean_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/collection_check_boxes_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/collection_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/collection_radio_buttons_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/collection_select_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/date_time_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/file_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/grouped_collection_select_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/hidden_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/numeric_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/password_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/priority_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/range_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/string_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/inputs/text_input.rb
/usr/lib/ruby/vendor_ruby/simple_form/wrappers/builder.rb
/usr/lib/ruby/vendor_ruby/simple_form/wrappers/leaf.rb
/usr/lib/ruby/vendor_ruby/simple_form/wrappers/many.rb
/usr/lib/ruby/vendor_ruby/simple_form/wrappers/root.rb
/usr/lib/ruby/vendor_ruby/simple_form/wrappers/single.rb
/usr/share/doc/ruby-simple-form/README.md.gz
/usr/share/doc/ruby-simple-form/changelog.Debian.gz
/usr/share/doc/ruby-simple-form/copyright
/usr/share/rubygems-integration/all/specifications/simple_form-3.2.0.gemspec

Changelog

2015-11-18 - Antonio Terceiro <terceiro@debian.org>
ruby-simple-form (3.2.0-1) unstable; urgency=medium
* Initial release (Closes: #805543)
* Added patch 0001-Skip-tests-dependening-on-country_select.patch to skip
tests that dependend on an optional dependency that is not in Debian yet.

See Also

Package Description
ruby-simple-navigation_4.0.3-1_all.deb Library to create navigations for Ruby web applications
ruby-simple-oauth_0.3.1-2_all.deb Simply builds and verifies OAuth headers
ruby-simplecov-html_0.10.0-1_all.deb default HTML formatter for SimpleCov code coverage tool
ruby-simplecov_0.11.1-1_all.deb code coverage for Ruby 1.9+
ruby-sinatra-contrib_1.4.6-2_all.deb collection of useful extensions to the Sinatra web framework
ruby-sinatra-simple-navigation_3.6.0-1build1_all.deb Extension providing simple navigations for Sinatra or Padrino
ruby-sinatra_1.4.7-3_all.deb Ruby web-development dressed in a DSL
ruby-sinon-rails_1.9.0-1_all.deb provides sinon.js via asset pipeline for rails apps
ruby-six_0.2.0-3_all.deb very simple authorization library for Ruby
ruby-slack-notifier_1.2.1-1_all.deb Ruby wrapper for posting to slack webhooks
ruby-slim_3.0.6-1_all.deb powerful (X)HTML templating engine with an elegant syntax
ruby-slop_4.2.0-1_all.deb Simple DSL for gathering options and parsing the command lineOption
ruby-snmp_1.2.0-1_all.deb simple network management protocol bindings for ruby
ruby-soap4r_2.0.5-3build1_all.deb SOAP library for the Ruby programming language
ruby-solve_2.0.2-1_all.deb Ruby version constraint solver implementing semantic versioning
Advertisement
Advertisement