ruby-simple-captcha2_0.3.4-1_all.deb


Advertisement

Description

ruby-simple-captcha2 - simplest and a robust captcha plugin for rails

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-simple-captcha2
Package version: 0.3.4
Package release: 1
Package architecture: all
Package type: deb
Installed size: 92 B
Download size: 14.32 KB
Official Mirror: archive.ubuntu.com
Available with Rails 3 + 4 or above provides backward compatibility. This is a fork of the popular Rubygem ``simple_captcha`` which got abandoned. Features * Zero FileSystem usage (secret code moved to db-store and image storage removed). * Provides various image styles. * Provides three level of complexity of images. * Works absolutely fine in distributed environment(session and db based implementation works fine in distributed environment). * Implementation is as easy as just writing a single line in your view. ```<%= show_simple_captcha %>``` within the 'form' tags. * Flexible DOM and CSS handling(There is a separate view partial for rendering SimpleCaptcha DOM elements). * Automated removal of 1 hour old unmatched simple_captcha data.

Alternatives

    Download

    Source package: ruby-simple-captcha2

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-simple-captcha2 deb package:
      # sudo apt-get install ruby-simple-captcha2

    Files

    • /usr/lib/ruby/vendor_ruby/simple_captcha.rb
    • /usr/lib/ruby/vendor_ruby/simple_captcha2.rb
    • /usr/lib/ruby/vendor_ruby/generators/USAGE
    • /usr/lib/ruby/vendor_ruby/generators/simple_captcha_generator.rb
    • /usr/lib/ruby/vendor_ruby/generators/templates/migration.rb
    • /usr/lib/ruby/vendor_ruby/generators/templates/partial.erb
    • /usr/lib/ruby/vendor_ruby/simple_captcha/controller.rb
    • /usr/lib/ruby/vendor_ruby/simple_captcha/engine.rb
    • /usr/lib/ruby/vendor_ruby/simple_captcha/form_builder.rb
    • /usr/lib/ruby/vendor_ruby/simple_captcha/formtastic.rb
    • /usr/lib/ruby/vendor_ruby/simple_captcha/image.rb
    • /usr/lib/ruby/vendor_ruby/simple_captcha/middleware.rb
    • /usr/lib/ruby/vendor_ruby/simple_captcha/model_helpers.rb
    • /usr/lib/ruby/vendor_ruby/simple_captcha/simple_captcha_data.rb
    • /usr/lib/ruby/vendor_ruby/simple_captcha/simple_captcha_data_mongoid.rb
    • /usr/lib/ruby/vendor_ruby/simple_captcha/utils.rb
    • /usr/lib/ruby/vendor_ruby/simple_captcha/version.rb
    • /usr/lib/ruby/vendor_ruby/simple_captcha/view.rb
    • /usr/share/doc/ruby-simple-captcha2/README.md.gz
    • /usr/share/doc/ruby-simple-captcha2/changelog.Debian.gz
    • /usr/share/doc/ruby-simple-captcha2/copyright
    • /usr/share/rubygems-integration/all/specifications/simple_captcha2-0.3.4.gemspec

    Changelog

    2015-04-02 - Pirate Praveen <praveen@debian.org> ruby-simple-captcha2 (0.3.4-1) unstable; urgency=medium [ R.Harish Navnit ] * Initial release (Closes: #767000)

    Advertisement
    Advertisement