ruby-sexp-processor_4.4.4-1_all.deb


Advertisement

Description

ruby-sexp-processor - brings all the generic sexp processing tools to ruby

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-sexp-processor
Package version: 4.4.4
Package release: 1
Package architecture: all
Package type: deb
Installed size: 209 B
Download size: 25.23 KB
Official Mirror: archive.ubuntu.com
sexp_processor branches from ParseTree bringing all the generic sexp processing tools with it. Sexp, SexpProcessor, Environment, etc. Includes SexpProcessor and CompositeSexpProcessor. Allows you to write very clean filters.

Alternatives

    Download

    Source package: ruby-sexp-processor

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-sexp-processor deb package:
      # sudo apt-get install ruby-sexp-processor

    Files

    • /usr/lib/ruby/vendor_ruby/composite_sexp_processor.rb
    • /usr/lib/ruby/vendor_ruby/pt_testcase.rb
    • /usr/lib/ruby/vendor_ruby/sexp.rb
    • /usr/lib/ruby/vendor_ruby/sexp_processor.rb
    • /usr/lib/ruby/vendor_ruby/unique.rb
    • /usr/share/doc/ruby-sexp-processor/README.txt
    • /usr/share/doc/ruby-sexp-processor/changelog.Debian.gz
    • /usr/share/doc/ruby-sexp-processor/copyright
    • /usr/share/rubygems-integration/all/specifications/sexp_processor-4.4.4.gemspec

    Changelog

    2014-08-22 - Cédric Boutillier <boutil@debian.org> ruby-sexp-processor (4.4.4-1) unstable; urgency=medium * Imported Upstream version 4.4.4

    2014-05-06 - Razee Marikar <mboxrm-lin@yahoo.co.uk> ruby-sexp-processor (4.4.1-2) unstable; urgency=low * Team upload * Rebuilding with gem2deb >= 0.7.5~

    2013-12-25 - Cédric Boutillier <boutil@debian.org> ruby-sexp-processor (4.4.1-1) unstable; urgency=medium * Imported Upstream version 4.4.1 * debian/copyright: update Format: to copyright-format/1.0 URI * debian/control: + add myself to uploaders + remove obsolete DM-Upload-Allowed flag + use canonical URI in Vcs-* fields + bump Standards-Version: to 3.9.5 (no changes needed) + build against gem2deb >=0.5~ to add Ruby2.0 support * Drop transitional packages

    2011-09-28 - Praveen Arimbrathodiyil <pravi.a@gmail.com> ruby-sexp-processor (3.0.7-1) unstable; urgency=low * New upstream release. * fix debian/watch (change sexp-processor to sexp_processor).

    2011-09-01 - Praveen Arimbrathodiyil <pravi.a@gmail.com> ruby-sexp-processor (3.0.6-1) unstable; urgency=low * New upstream release * Migrated to gem2deb (Closes: #640036) * Update copyright file to follow dep5 * Standards-Version: 3.9.2 * Add myself to uploaders * Add ruby-minitest to build depends

    2010-08-15 - Tobias Grimm <etobi@debian.org> libsexp-processor-ruby (3.0.4-2) unstable; urgency=low * Load tests with absolute path - Ruby 1.9.2 doesn't include '.' in it's load path anymore (Closes: #593026) * Standards-Version: 3.9.1 * Fixed package description

    2010-03-29 - Tobias Grimm <etobi@debian.org> libsexp-processor-ruby (3.0.4-1) unstable; urgency=low * New upstream release

    2010-02-27 - Tobias Grimm <etobi@debian.org> libsexp-processor-ruby (3.0.3-6) unstable; urgency=low * Re-enabled Ruby 1.9.1 support (fixed the test runner) * Install upstream changelog

    2010-02-21 - Lucas Nussbaum <lucas@lucas-nussbaum.net> libsexp-processor-ruby (3.0.3-5) unstable; urgency=low * Remove Sebastien Delafond from maintainer. Many thanks for all the past work!

    2010-02-20 - Lucas Nussbaum <lucas@lucas-nussbaum.net> libsexp-processor-ruby (3.0.3-4) unstable; urgency=low * Drop package for Ruby 1.9. The test suite fails. Closes: #569883. * Standards-Version -> 3.8.4. No changes needed.

    Advertisement
    Advertisement