ruby-sequel-pg_1.6.14-1build2_i386.deb


Advertisement

Description

ruby-sequel-pg - Faster SELECTs when using Sequel with pg

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-sequel-pg
Package version: 1.6.14
Package release: 1build2
Package architecture: i386
Package type: deb
Installed size: 70 B
Download size: 20.42 KB
Official Mirror: archive.ubuntu.com
sequel_pg overwrites the inner loop of the Sequel postgres adapter row fetching code with a C version. The C version is significantly faster (2-6x) than the pure ruby version that Sequel uses by default.

Alternatives

    Download

    Source package: ruby-sequel-pg

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-sequel-pg deb package:
      # sudo apt-get install ruby-sequel-pg

    Files

    • /usr/lib/i386-linux-gnu/ruby/vendor_ruby/2.3.0/sequel_pg.so
    • /usr/lib/ruby/vendor_ruby/sequel/extensions/pg_streaming.rb
    • /usr/lib/ruby/vendor_ruby/sequel_pg/sequel_pg.rb
    • /usr/share/doc/ruby-sequel-pg/README.rdoc.gz
    • /usr/share/doc/ruby-sequel-pg/changelog.Debian.gz
    • /usr/share/doc/ruby-sequel-pg/copyright
    • /usr/share/rubygems-integration/2.3.0/specifications/sequel_pg-1.6.14.gemspec

    Changelog

    2016-03-13 - Matthias Klose <doko@ubuntu.com> ruby-sequel-pg (1.6.14-1build2) xenial; urgency=medium * No-change rebuild for ruby2.3-only support.

    2016-03-13 - Matthias Klose <doko@ubuntu.com> ruby-sequel-pg (1.6.14-1build1) xenial; urgency=medium * No-change rebuild to add ruby2.3 support.

    2016-02-08 - Dmitry Borodaenko <angdraug@debian.org> ruby-sequel-pg (1.6.14-1) unstable; urgency=low * New upstream version. * Standards-Version upgraded to 3.9.7, no changes required.

    2014-10-18 - Dmitry Borodaenko <angdraug@debian.org> ruby-sequel-pg (1.6.10-1) unstable; urgency=low * New upstream version. * Standards-Version upgraded to 3.9.6, no changes required.

    2014-06-08 - Dmitry Borodaenko <angdraug@debian.org> ruby-sequel-pg (1.6.9-1) unstable; urgency=low * New upstream version. * Standards-Version upgraded to 3.9.5 (no changes). * Fixed Vcs-* fields to point to anonscm.debian.org.

    2013-08-10 - Dmitry Borodaenko <angdraug@debian.org> ruby-sequel-pg (1.6.8-1) unstable; urgency=low [ Dmitry Borodaenko ] * New upstream version. * Standards-Version upgraded to 3.9.4 (no changes). [ Cédric Boutillier ] * debian/control: remove obsolete DM-Upload-Allowed flag. * debian/copyright: use DEP5 copyright-format/1.0 official URL for Format field. * Update debian/watch. Thanks Bart Martens.

    2012-07-15 - Dmitry Borodaenko <angdraug@debian.org> ruby-sequel-pg (1.5.0-1) unstable; urgency=low * New upstream version. * Bump Build-Depends on gem2deb to >= 0.3.0~.

    2012-06-09 - Dmitry Borodaenko <angdraug@debian.org> ruby-sequel-pg (1.4.0-1) unstable; urgency=low * New upstream version.

    2012-04-09 - Dmitry Borodaenko <angdraug@debian.org> ruby-sequel-pg (1.3.0-1) unstable; urgency=low * New upstream version.

    2012-03-03 - Dmitry Borodaenko <angdraug@debian.org> ruby-sequel-pg (1.2.1-1) unstable; urgency=low * New upstream version. * Standards-Version upgraded to 3.9.3.

    Advertisement
    Advertisement