ruby-sawyer_0.6.0-2_all.deb


Advertisement

Description

ruby-sawyer - HTTP/REST API client Ruby library

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-sawyer
Package version: 0.6.0
Package release: 2
Package architecture: all
Package type: deb
Installed size: 83 B
Download size: 9.16 KB
Official Mirror: archive.ubuntu.com
Sawyer is an experimental hypermedia HTTP client built on top of ruby-faraday. Although Sawyer provides the expected features of an HTTP client library, it's more useful when is used to interact and to implement REST APIs endpoints. Out of the box it can parse data from API responses, turns contents into high level resources or collections of resources, relations between those resources, etc.

Alternatives

    Download

    Source package: ruby-sawyer

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-sawyer deb package:
      # sudo apt-get install ruby-sawyer

    Files

    • /usr/lib/ruby/vendor_ruby/sawyer.rb
    • /usr/lib/ruby/vendor_ruby/sawyer/agent.rb
    • /usr/lib/ruby/vendor_ruby/sawyer/relation.rb
    • /usr/lib/ruby/vendor_ruby/sawyer/resource.rb
    • /usr/lib/ruby/vendor_ruby/sawyer/response.rb
    • /usr/lib/ruby/vendor_ruby/sawyer/serializer.rb
    • /usr/lib/ruby/vendor_ruby/sawyer/link_parsers/hal.rb
    • /usr/lib/ruby/vendor_ruby/sawyer/link_parsers/simple.rb
    • /usr/share/doc/ruby-sawyer/README.md
    • /usr/share/doc/ruby-sawyer/changelog.Debian.gz
    • /usr/share/doc/ruby-sawyer/copyright
    • /usr/share/rubygems-integration/all/specifications/sawyer-0.6.0.gemspec

    Changelog

    2015-07-13 - Miguel Landaeta <nomadium@debian.org> ruby-sawyer (0.6.0-2) unstable; urgency=medium * Fix FTBFS error due to failing unit tests with encoding errors. * Wrap dependencies lists.

    2015-05-22 - Miguel Landaeta <nomadium@debian.org> ruby-sawyer (0.6.0-1) unstable; urgency=medium * New upstream release. * Bump Standards-Version to 3.9.6. No changes were required. * Bump DH compat level to 9. * Update copyright dates. * Add patch to workaround encoding errors in a couple of unit tests. * Add patch to disable unit tests that need network access.

    2014-03-30 - Miguel Landaeta <nomadium@debian.org> ruby-sawyer (0.5.4-1) unstable; urgency=low * New upstream release.

    2014-03-04 - Miguel Landaeta <nomadium@debian.org> ruby-sawyer (0.5.3-1) unstable; urgency=low * Initial release (Closes: #740768).

    Advertisement
    Advertisement