ruby-sass_3.4.21-1_all.deb


Advertisement

Description

ruby-sass - powerful but elegant CSS compiler that makes CSS fun again

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-sass
Package version 3.4.21
Package release 1
Package architecture all
Package type deb
Installed size 956 B
Download size 168.94 KB
Official Mirror archive.ubuntu.com
Sass makes CSS fun again. Sass is an extension of CSS3, adding nested
rules, variables, mixins, selector inheritance, and more.
It's translated to well-formatted, standard CSS using the command line
tool or a web-framework plugin.

Alternatives

Package Version Architecture Repository
ruby-sass_3.4.21-1_all.deb 3.4.21 all Ubuntu Universe
ruby-sass - - -

Requires

Name Value
ruby -
ruby-interpreter -

Provides

Name Value
sass -

Download

Type URL
Binary Package ruby-sass_3.4.21-1_all.deb
Source Package ruby-sass

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-sass deb package:
    # sudo apt-get install ruby-sass

Files

Path
/usr/bin/sass
/usr/bin/sass-convert
/usr/bin/scss
/usr/lib/ruby/vendor_ruby/sass.rb
/usr/lib/ruby/vendor_ruby/sass/VERSION
/usr/lib/ruby/vendor_ruby/sass/VERSION_NAME
/usr/lib/ruby/vendor_ruby/sass/cache_stores.rb
/usr/lib/ruby/vendor_ruby/sass/callbacks.rb
/usr/lib/ruby/vendor_ruby/sass/css.rb
/usr/lib/ruby/vendor_ruby/sass/engine.rb
/usr/lib/ruby/vendor_ruby/sass/environment.rb
/usr/lib/ruby/vendor_ruby/sass/error.rb
/usr/lib/ruby/vendor_ruby/sass/exec.rb
/usr/lib/ruby/vendor_ruby/sass/features.rb
/usr/lib/ruby/vendor_ruby/sass/importers.rb
/usr/lib/ruby/vendor_ruby/sass/logger.rb
/usr/lib/ruby/vendor_ruby/sass/media.rb
/usr/lib/ruby/vendor_ruby/sass/plugin.rb
/usr/lib/ruby/vendor_ruby/sass/railtie.rb
/usr/lib/ruby/vendor_ruby/sass/repl.rb
/usr/lib/ruby/vendor_ruby/sass/root.rb
/usr/lib/ruby/vendor_ruby/sass/script.rb
/usr/lib/ruby/vendor_ruby/sass/scss.rb
/usr/lib/ruby/vendor_ruby/sass/selector.rb
/usr/lib/ruby/vendor_ruby/sass/shared.rb
/usr/lib/ruby/vendor_ruby/sass/stack.rb
/usr/lib/ruby/vendor_ruby/sass/supports.rb
/usr/lib/ruby/vendor_ruby/sass/util.rb
/usr/lib/ruby/vendor_ruby/sass/version.rb
/usr/lib/ruby/vendor_ruby/sass/cache_stores/base.rb
/usr/lib/ruby/vendor_ruby/sass/cache_stores/chain.rb
/usr/lib/ruby/vendor_ruby/sass/cache_stores/filesystem.rb
/usr/lib/ruby/vendor_ruby/sass/cache_stores/memory.rb
/usr/lib/ruby/vendor_ruby/sass/cache_stores/null.rb
/usr/lib/ruby/vendor_ruby/sass/exec/base.rb
/usr/lib/ruby/vendor_ruby/sass/exec/sass_convert.rb
/usr/lib/ruby/vendor_ruby/sass/exec/sass_scss.rb
/usr/lib/ruby/vendor_ruby/sass/importers/base.rb
/usr/lib/ruby/vendor_ruby/sass/importers/deprecated_path.rb
/usr/lib/ruby/vendor_ruby/sass/importers/filesystem.rb
/usr/lib/ruby/vendor_ruby/sass/logger/base.rb
/usr/lib/ruby/vendor_ruby/sass/logger/log_level.rb
/usr/lib/ruby/vendor_ruby/sass/plugin/compiler.rb
/usr/lib/ruby/vendor_ruby/sass/plugin/configuration.rb
/usr/lib/ruby/vendor_ruby/sass/plugin/generic.rb
/usr/lib/ruby/vendor_ruby/sass/plugin/merb.rb
/usr/lib/ruby/vendor_ruby/sass/plugin/rack.rb
/usr/lib/ruby/vendor_ruby/sass/plugin/rails.rb
/usr/lib/ruby/vendor_ruby/sass/plugin/staleness_checker.rb
/usr/lib/ruby/vendor_ruby/sass/script/css_lexer.rb
/usr/lib/ruby/vendor_ruby/sass/script/css_parser.rb
/usr/lib/ruby/vendor_ruby/sass/script/functions.rb
/usr/lib/ruby/vendor_ruby/sass/script/lexer.rb
/usr/lib/ruby/vendor_ruby/sass/script/parser.rb
/usr/lib/ruby/vendor_ruby/sass/script/tree.rb
/usr/lib/ruby/vendor_ruby/sass/script/value.rb
/usr/lib/ruby/vendor_ruby/sass/script/tree/funcall.rb
/usr/lib/ruby/vendor_ruby/sass/script/tree/interpolation.rb
/usr/lib/ruby/vendor_ruby/sass/script/tree/list_literal.rb
/usr/lib/ruby/vendor_ruby/sass/script/tree/literal.rb
/usr/lib/ruby/vendor_ruby/sass/script/tree/map_literal.rb
/usr/lib/ruby/vendor_ruby/sass/script/tree/node.rb
/usr/lib/ruby/vendor_ruby/sass/script/tree/operation.rb
/usr/lib/ruby/vendor_ruby/sass/script/tree/selector.rb
/usr/lib/ruby/vendor_ruby/sass/script/tree/string_interpolation.rb
/usr/lib/ruby/vendor_ruby/sass/script/tree/unary_operation.rb
/usr/lib/ruby/vendor_ruby/sass/script/tree/variable.rb
/usr/lib/ruby/vendor_ruby/sass/script/value/arg_list.rb
/usr/lib/ruby/vendor_ruby/sass/script/value/base.rb
/usr/lib/ruby/vendor_ruby/sass/script/value/bool.rb
/usr/lib/ruby/vendor_ruby/sass/script/value/color.rb
/usr/lib/ruby/vendor_ruby/sass/script/value/helpers.rb
/usr/lib/ruby/vendor_ruby/sass/script/value/list.rb
/usr/lib/ruby/vendor_ruby/sass/script/value/map.rb
/usr/lib/ruby/vendor_ruby/sass/script/value/null.rb
/usr/lib/ruby/vendor_ruby/sass/script/value/number.rb
/usr/lib/ruby/vendor_ruby/sass/script/value/string.rb
/usr/lib/ruby/vendor_ruby/sass/scss/css_parser.rb
/usr/lib/ruby/vendor_ruby/sass/scss/parser.rb
/usr/lib/ruby/vendor_ruby/sass/scss/rx.rb
/usr/lib/ruby/vendor_ruby/sass/scss/script_lexer.rb
/usr/lib/ruby/vendor_ruby/sass/scss/script_parser.rb
/usr/lib/ruby/vendor_ruby/sass/scss/static_parser.rb
/usr/lib/ruby/vendor_ruby/sass/selector/abstract_sequence.rb
/usr/lib/ruby/vendor_ruby/sass/selector/comma_sequence.rb
/usr/lib/ruby/vendor_ruby/sass/selector/pseudo.rb
/usr/lib/ruby/vendor_ruby/sass/selector/sequence.rb
/usr/lib/ruby/vendor_ruby/sass/selector/simple.rb
/usr/lib/ruby/vendor_ruby/sass/selector/simple_sequence.rb
/usr/lib/ruby/vendor_ruby/sass/source/map.rb
/usr/lib/ruby/vendor_ruby/sass/source/position.rb
/usr/lib/ruby/vendor_ruby/sass/source/range.rb
/usr/lib/ruby/vendor_ruby/sass/tree/at_root_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/charset_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/comment_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/content_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/css_import_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/debug_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/directive_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/each_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/error_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/extend_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/for_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/function_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/if_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/import_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/keyframe_rule_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/media_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/mixin_def_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/mixin_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/prop_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/return_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/root_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/rule_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/supports_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/trace_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/variable_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/warn_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/while_node.rb
/usr/lib/ruby/vendor_ruby/sass/tree/visitors/base.rb
/usr/lib/ruby/vendor_ruby/sass/tree/visitors/check_nesting.rb
/usr/lib/ruby/vendor_ruby/sass/tree/visitors/convert.rb
/usr/lib/ruby/vendor_ruby/sass/tree/visitors/cssize.rb
/usr/lib/ruby/vendor_ruby/sass/tree/visitors/deep_copy.rb
/usr/lib/ruby/vendor_ruby/sass/tree/visitors/extend.rb
/usr/lib/ruby/vendor_ruby/sass/tree/visitors/perform.rb
/usr/lib/ruby/vendor_ruby/sass/tree/visitors/set_options.rb
/usr/lib/ruby/vendor_ruby/sass/tree/visitors/to_css.rb
/usr/lib/ruby/vendor_ruby/sass/util/cross_platform_random.rb
/usr/lib/ruby/vendor_ruby/sass/util/multibyte_string_scanner.rb
/usr/lib/ruby/vendor_ruby/sass/util/normalized_map.rb
/usr/lib/ruby/vendor_ruby/sass/util/ordered_hash.rb
/usr/lib/ruby/vendor_ruby/sass/util/subset_map.rb
/usr/lib/ruby/vendor_ruby/sass/util/test.rb
/usr/share/doc/ruby-sass/NEWS.Debian.gz
/usr/share/doc/ruby-sass/README.md.gz
/usr/share/doc/ruby-sass/changelog.Debian.gz
/usr/share/doc/ruby-sass/copyright
/usr/share/man/man1/sass-convert.1.gz
/usr/share/man/man1/sass.1.gz
/usr/share/man/man1/scss.1.gz
/usr/share/rubygems-integration/all/specifications/sass-3.4.21.gemspec

Changelog

2016-01-25 - Jonas Smedegaard <dr@jones.dk>
ruby-sass (3.4.21-1) unstable; urgency=medium
[ upstream ]
* New release.
+ Consistent output formatting for numbers close to an integer.
+ Correctly round negative numbers that were almost but not quite a
whole number (slightly greater than the negative number).
+ Don't strip escaped semicolons from compressed output.
+ Only compress around dashes within nth selectors.
+ Selector compression of whitespace around commas was affecting
attribute values.
+ Make subtraction work when a unit is followed directly by a hyphen
and then a period.  For example, `1em-.75em` now returns `0.25em`
rather than `1em -0.75em`.  This is consistent with the behavior
when the subtrahend begins with a `0`.
2015-12-14 - Jonas Smedegaard <dr@jones.dk>
ruby-sass (3.4.20-1) unstable; urgency=medium
[ upstream ]
* New release.
+ Fix bug with rounding changes from 3.4.14 and 3.4.15 where some
negative numbers would incorrectly be rounded up instead of down.
+ Better compression for `:nth` pseudoselectors with subtraction.
+ Add support for new supports() clause for CSS @import directives.
+ Rounding numbers now respects Sass's precision setting for numbers
very close to half an integer.
+ Add support for q unit, representing one quarter of a millimeter.
+ Mitigate race condition when multiple threads are using same
Sass::Plugin object at once.
+ In compressed mode, numbers between -1 and 1 now omit leading 0.
+ Source maps now include source ranges for comments.
Deprecation
+ Certain ways of using #{} without quotes in property and variable
values have been deprecated in order to simplify the feature.
Read upstream changelog for more details.
[ Jonas Smedegaard ]
* Unfuzz patch 1001.
2015-10-11 - Jonas Smedegaard <dr@jones.dk>
ruby-sass (3.4.19-1) unstable; urgency=medium
[ upstream ]
* New release(s).
+ Fix too aggressive semi-colon stripping in 3.4.17.
+ Improved numeric equality.
+ Allow importing relative paths on implicitly set standard input.
+ Fix edge cases with `sass-convert` and string interpolation.
[ Jonas Smedegaard ]
* Bump debhelper compatibility level to 9.
* Fix lintian overrides.
* Add lintian override regarding debhelper 9.
2015-08-24 - Jonas Smedegaard <dr@jones.dk>
ruby-sass (3.4.17-1) unstable; urgency=medium
[ upstream ]
* New release.
2015-07-11 - Jonas Smedegaard <dr@jones.dk>
ruby-sass (3.4.16-1) unstable; urgency=medium
[ upstream ]
* New release(s).
[ Jonas Smedegaard ]
* Add NEWS entry about deprecation of relative path on stdin.
2015-05-25 - Jonas Smedegaard <dr@jones.dk>
ruby-sass (3.4.14-2) unstable; urgency=medium
* Update upstream source and contact URLs.
* Fix fail build if manpage creation fails, and cleanup if failing.
* Update package relations:
+ Relax to build-depend unversioned on gem2deb: Needed version
satisfied even in oldstable.
+ Stop suggest ruby-compass.
+ Provide virtual package sass.
2015-05-24 - Jonas Smedegaard <dr@jones.dk>
ruby-sass (3.4.14-1) unstable; urgency=medium
[ upstream ]
* New release.
+ Further avoid race conditions when caching.
+ Only emit one warning for each line that uses the deprecated form
of unquote().
+ Stop parsing and emitting invalid @supports directives.
+ Add a deprecation warning for using != to compare a number with
units to a number without (such warning already existed for ==).
+ Improve rounding of the results of color operations.
[ Jonas Smedegaard ]
* Update copyright info:
+ Extend coverage for mian upstream authors.
+ Use License-Grant and License-Reference fields.
Thanks to Ben Finney.
* Add lintian override regarding license in License-Reference field.
See bug#786450.

See Also

Package Description
ruby-sawyer_0.6.0-2_all.deb HTTP/REST API client Ruby library
ruby-sdl_2.1.3-1build5_i386.deb Ruby/SDL interface for Ruby
ruby-sdoc_0.4.1-1_all.deb RDoc generator to build searchable HTML documentation for Ruby code
ruby-seed-fu_2.3.5-1_all.deb easily manage seed data in an Active Record application
ruby-select2-rails_3.5.9.3-2_all.deb integrate Select2 javascript library with Rails asset pipeline
ruby-selinux_2.4-3build2_i386.deb Ruby bindings to SELinux shared libraries
ruby-semanage_2.3-1build3_i386.deb Ruby bindings to for SELinux policy management
ruby-semantic-puppet_0.1.1-1_all.deb Useful tools for working with semantic versions with Puppet
ruby-semverse_1.2.1-2_all.deb Ruby library for representing SemVer versions and constraints
ruby-sentry-raven_0.15.3-1_all.deb client interface for the Sentry error logger
ruby-sequel-pg_1.6.14-1build2_i386.deb Faster SELECTs when using Sequel with pg
ruby-sequel_4.32.0-1_all.deb Simple, flexible, and powerful SQL database access toolkit for Ruby
ruby-serialport_1.3.1-1build3_i386.deb Library for using RS-232 serial ports from Ruby programs
ruby-serverspec_2.18.0-1_all.deb RSpec tests for your servers configured by Puppet, Chef or anything else
ruby-session_3.2.0-1_all.deb persistent connections with external programs like bash (via pipes)
Advertisement
Advertisement