ruby-rugged_0.24.0+ds1-2_i386.deb


Advertisement

Description

ruby-rugged - Ruby binding to the libgit2 library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-rugged
Package version 0.24.0+ds1
Package release 2
Package architecture i386
Package type deb
Installed size 327 B
Download size 93.59 KB
Official Mirror archive.ubuntu.com
libgit2 is a portable, pure C implementation of the Git distributed version
control system core methods provided as a re-entrant linkable library with a
solid API.
Rugged is a library for accessing libgit2 in Ruby. It allows one to
explore and modify Git repositories with the speed and portability of libgit2,
and the convenience of the Ruby programmation language.

Alternatives

Package Version Architecture Repository
ruby-rugged_0.24.0+ds1-2_amd64.deb 0.24.0+ds1 amd64 Ubuntu Universe
ruby-rugged - - -

Requires

Name Value
libc6 >= 2.4
libgit2-24 >= 0.24.0
libruby2.3 >= 2.3.0~preview2
ruby >= 1:2.3~0

Download

Type URL
Binary Package ruby-rugged_0.24.0+ds1-2_i386.deb
Source Package ruby-rugged

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-rugged deb package:
    # sudo apt-get install ruby-rugged

Files

Path
/usr/lib/i386-linux-gnu/ruby/vendor_ruby/2.3.0/rugged/rugged.so
/usr/lib/ruby/vendor_ruby/rugged.rb
/usr/lib/ruby/vendor_ruby/rugged/attributes.rb
/usr/lib/ruby/vendor_ruby/rugged/blob.rb
/usr/lib/ruby/vendor_ruby/rugged/branch.rb
/usr/lib/ruby/vendor_ruby/rugged/commit.rb
/usr/lib/ruby/vendor_ruby/rugged/console.rb
/usr/lib/ruby/vendor_ruby/rugged/credentials.rb
/usr/lib/ruby/vendor_ruby/rugged/diff.rb
/usr/lib/ruby/vendor_ruby/rugged/index.rb
/usr/lib/ruby/vendor_ruby/rugged/object.rb
/usr/lib/ruby/vendor_ruby/rugged/patch.rb
/usr/lib/ruby/vendor_ruby/rugged/reference.rb
/usr/lib/ruby/vendor_ruby/rugged/remote.rb
/usr/lib/ruby/vendor_ruby/rugged/repository.rb
/usr/lib/ruby/vendor_ruby/rugged/submodule_collection.rb
/usr/lib/ruby/vendor_ruby/rugged/tag.rb
/usr/lib/ruby/vendor_ruby/rugged/tree.rb
/usr/lib/ruby/vendor_ruby/rugged/version.rb
/usr/lib/ruby/vendor_ruby/rugged/walker.rb
/usr/lib/ruby/vendor_ruby/rugged/diff/delta.rb
/usr/lib/ruby/vendor_ruby/rugged/diff/hunk.rb
/usr/lib/ruby/vendor_ruby/rugged/diff/line.rb
/usr/share/doc/ruby-rugged/README.md.gz
/usr/share/doc/ruby-rugged/TODO.Debian
/usr/share/doc/ruby-rugged/changelog.Debian.gz
/usr/share/doc/ruby-rugged/copyright
/usr/share/rubygems-integration/2.3.0/specifications/rugged-0.24.0.gemspec

Changelog

2016-04-13 - Pirate Praveen <praveen@debian.org>
ruby-rugged (0.24.0+ds1-2) unstable; urgency=medium
* Team upload
* Reupload to unstable
2016-04-12 - Pirate Praveen <praveen@debian.org>
ruby-rugged (0.24.0+ds1-1) experimental; urgency=medium
* Team upload
* New upstream release
2015-09-14 - Cédric Boutillier <boutil@debian.org>
ruby-rugged (0.23.2+ds1-1) unstable; urgency=medium
* Imported Upstream version 0.23.2+ds1
+ compatible with libgit2-dev v23 in unstable (Closes: #798859)
* Tighten version of libgit2-dev in debian/control
* Update fix_header_path.patch accordingly
* Bump Debhelper compatibility level to 9
2015-06-01 - Cédric Boutillier <boutil@debian.org>
ruby-rugged (0.22.2+ds1-1) unstable; urgency=medium
* Imported Upstream version 0.22.2+ds1
* Upload to unstable
* Add patch to not read the needed version of libgit2 from (removed)
convenience copy.
2015-04-22 - Cédric Boutillier <boutil@debian.org>
ruby-rugged (0.21.4+ds1-1~exp1) experimental; urgency=medium
* Initial release (Closes: #740011)

See Also

Package Description
ruby-rugments_1.0.0~beta8-1_all.deb pure-ruby syntax highlighter replacement for pygments
ruby-safe-yaml_1.0.4-1_all.deb safer YAML loader for Ruby
ruby-saml_1.1.2-1ubuntu1_all.deb SAML toolkit for Ruby on Rails
ruby-samuel_0.3.3-1build1_all.deb automatic logger for HTTP requests in Ruby
ruby-sanitize_2.1.0-2_all.deb whitelist-based HTML sanitizer
ruby-sasl_0.0.3.3-2_all.deb SASL client library for Ruby
ruby-sass-rails_5.0.4-1_all.deb Sass adapter for the Rails asset pipeline
ruby-sass_3.4.21-1_all.deb powerful but elegant CSS compiler that makes CSS fun again
ruby-sawyer_0.6.0-2_all.deb HTTP/REST API client Ruby library
ruby-sdl_2.1.3-1build5_i386.deb Ruby/SDL interface for Ruby
ruby-sdoc_0.4.1-1_all.deb RDoc generator to build searchable HTML documentation for Ruby code
ruby-seed-fu_2.3.5-1_all.deb easily manage seed data in an Active Record application
ruby-select2-rails_3.5.9.3-2_all.deb integrate Select2 javascript library with Rails asset pipeline
ruby-selinux_2.4-3build2_i386.deb Ruby bindings to SELinux shared libraries
ruby-semanage_2.3-1build3_i386.deb Ruby bindings to for SELinux policy management
Advertisement
Advertisement