ruby-rubymail_1.1.0-2_all.deb


Advertisement

Description

ruby-rubymail - MIME mail parsing and generation library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-rubymail
Package version 1.1.0
Package release 2
Package architecture all
Package type deb
Installed size 193 B
Download size 30.33 KB
Official Mirror archive.ubuntu.com
RMail is a lightweight mail library containing various utility classes and
modules that allow ruby scripts to parse, modify, and generate MIME mail
messages.

Alternatives

Package Version Architecture Repository
ruby-rubymail_1.1.0-2_all.deb 1.1.0 all Ubuntu Universe
ruby-rubymail - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-rubymail_1.1.0-2_all.deb
Source Package ruby-rubymail

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-rubymail deb package:
    # sudo apt-get install ruby-rubymail

Files

Path
/usr/lib/ruby/vendor_ruby/rmail.rb
/usr/lib/ruby/vendor_ruby/rmail/address.rb
/usr/lib/ruby/vendor_ruby/rmail/header.rb
/usr/lib/ruby/vendor_ruby/rmail/mailbox.rb
/usr/lib/ruby/vendor_ruby/rmail/message.rb
/usr/lib/ruby/vendor_ruby/rmail/parser.rb
/usr/lib/ruby/vendor_ruby/rmail/serialize.rb
/usr/lib/ruby/vendor_ruby/rmail/utils.rb
/usr/lib/ruby/vendor_ruby/rmail/version.rb
/usr/lib/ruby/vendor_ruby/rmail/mailbox/mboxreader.rb
/usr/lib/ruby/vendor_ruby/rmail/parser/multipart.rb
/usr/lib/ruby/vendor_ruby/rmail/parser/pushbackreader.rb
/usr/share/doc/ruby-rubymail/NOTES
/usr/share/doc/ruby-rubymail/README
/usr/share/doc/ruby-rubymail/THANKS
/usr/share/doc/ruby-rubymail/TODO
/usr/share/doc/ruby-rubymail/changelog.Debian.gz
/usr/share/doc/ruby-rubymail/copyright
/usr/share/doc/ruby-rubymail/guide/Intro.txt
/usr/share/doc/ruby-rubymail/guide/MIME.txt
/usr/share/doc/ruby-rubymail/guide/TableOfContents.txt
/usr/share/rubygems-integration/all/specifications/rmail-1.1.0.gemspec

Changelog

2015-07-01 - Antonio Terceiro <terceiro@debian.org>
ruby-rubymail (1.1.0-2) unstable; urgency=medium
* Update packaging with a new dh-make-ruby run + manual adjustments
- should fix test suite run on CI
2015-02-15 - Antonio Terceiro <terceiro@debian.org>
ruby-rubymail (1.1.0-1) experimental; urgency=medium
* New upstream release
* Dropped *all* patches which are not needed anymore.
* debian/rules: build documentation from source
* debian/rules: NEWS file renamed upstream
* debian/control: add myself to Uploaders:
2013-10-06 - Antonio Terceiro <terceiro@debian.org>
ruby-rubymail (1.0.0-2) unstable; urgency=low
* Team upload
* Added patches for Ruby 2.0 compatibility (Closes: #720253):
- debian/patches/0007-Create-Explicit-Binary-Regexp.patch
- debian/patches/0008-fix-testbase-for-ruby2.0.patch
- debian/patches/0009-fix-testaddress-for-ruby2.0.patch
- debian/patches/0010-fix-testmessage-for-ruby2.0.patch
* Standards-Version bumped to 3.9.4; no changes needed.
* Drop old transition packages as they are not needed anymore
2012-06-28 - Per Andersson <avtobiff@gmail.com>
ruby-rubymail (1.0.0-1) unstable; urgency=low
* New maintainer. Closes: #676346
* New upstream release.
* Use source format 3.0 (quilt).
* Set unapply-patches in debian/source/local-options.
* Bump standards version to 3.9.3 (no changes necessary).
* Migrate to new Ruby policy
- Build depend on debhelper >= 7.0.50~ and gem2deb >= 0.2.16~.
- Rename source and binary packages.
- Create transitional packages.
- Add Vcs-* fields.
- Add Homepage field.
- Build for all Ruby versions.
- Migrate debian/rules to a minimal straight forward debhelper makefile.
- Run all tests when building a package.
* Add patch to reintroduce removed docs.
* Add patch for running tests under both Ruby 1.8 and 1.9.
* Add patch for to parse messages with "\r\n" as linefeed.
* Add patch to remove rubygems require. Closes: #431557
* Add watch file.
* Change doc-base section to Programming/Ruby.
* Add patch for testing header params without order guarantee.
* debian/copyright:
- Change format to DEP5.
- Source is BSD licensed, updated accordingly.
* debian/rules:
- Install upstream changelog (don't install with ruby-rubymail.docs).
- Add -O--buildsystem=ruby to dh in overrides.
2009-07-12 - Adeodato Simó <adeodato@debian.org>
librmail-ruby (0.17-1.1) unstable; urgency=low
* Non-maintainer upload.
* Apply patch from upstream BTS to avoid quoting existing parameters
twice in Header::set_boundary(). Addresses part of #431557, which
requested for all patches in upstream BTS to be applied to the package.
* Add a build-dependency on quilt and the 3-line magic in debian/rules to
apply the above patch.
2005-06-22 - Shugo Maeda <shugo@debian.org>
librmail-ruby (0.17-1) unstable; urgency=low
* New upstream version.
* New maintainer.
* Removed sub-package librmail-ruby1.6.
2003-11-16 - akira yamada <akira@debian.org>
librmail-ruby (0.15-1) unstable; urgency=low
* new upstream version.  (closes: #220787)
* new sub-package librmail-ruby1.6, librmail-ruby1.8 and librmail-ruby-doc.
* Build-Depends on ruby1.8, ruby1.8-dev, ruby1.6 and ruby1.6-dev.
2003-08-29 - akira yamada <akira@debian.org>
librmail-ruby (0.14-1) unstable; urgency=low
* new upstream version.
2002-10-11 - akira yamada <akira@debian.org>
librmail-ruby (0.8-1) unstable; urgency=low
* Initial Release.
* uploaded to Debian, closes: #164164.

See Also

Package Description
ruby-rubypants_0.2.0-2_all.deb Ruby port of SmartyPants smart-quotes library
ruby-rubysl_2.1.0-1_all.deb Ruby Standard Library meta-spec
ruby-rubytorrent_0.3-5_all.deb BitTorrent library in Ruby
ruby-rubyvis_0.6.1+dfsg1-2_all.deb Ruby visualization toolkit
ruby-rufus-scheduler_3.1.10-2_all.deb job scheduler for Ruby
ruby-rugged_0.24.0+ds1-2_i386.deb Ruby binding to the libgit2 library
ruby-rugments_1.0.0~beta8-1_all.deb pure-ruby syntax highlighter replacement for pygments
ruby-safe-yaml_1.0.4-1_all.deb safer YAML loader for Ruby
ruby-saml_1.1.2-1ubuntu1_all.deb SAML toolkit for Ruby on Rails
ruby-samuel_0.3.3-1build1_all.deb automatic logger for HTTP requests in Ruby
ruby-sanitize_2.1.0-2_all.deb whitelist-based HTML sanitizer
ruby-sasl_0.0.3.3-2_all.deb SASL client library for Ruby
ruby-sass-rails_5.0.4-1_all.deb Sass adapter for the Rails asset pipeline
ruby-sass_3.4.21-1_all.deb powerful but elegant CSS compiler that makes CSS fun again
ruby-sawyer_0.6.0-2_all.deb HTTP/REST API client Ruby library
Advertisement
Advertisement