ruby-rspec_3.4.0c3e0m1s1-1ubuntu1_all.deb


Advertisement

Description

ruby-rspec - Behaviour Driven Development framework for Ruby - metapackage

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-rspec
Package version 3.4.0c3e0m1s1
Package release 1ubuntu1
Package architecture all
Package type deb
Installed size 25 B
Download size 3.31 KB
Official Mirror archive.ubuntu.com
RSpec is a Behaviour Driven Development framework for Ruby. It
provides a framework for writing and executing examples of how your
Ruby application should behave.

Alternatives

Package Version Architecture Repository
ruby-rspec_3.4.0c3e0m1s1-1ubuntu1_all.deb 3.4.0c3e0m1s1 all Ubuntu Universe
ruby-rspec - - -

Requires

Name Value
ruby -
ruby-interpreter -
ruby-rspec-core = 3.4.0c3e0m1s1-1ubuntu1

Download

Type URL
Binary Package ruby-rspec_3.4.0c3e0m1s1-1ubuntu1_all.deb
Source Package ruby-rspec

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-rspec deb package:
    # sudo apt-get install ruby-rspec

Files

Path
/usr/lib/ruby/vendor_ruby/rspec.rb
/usr/lib/ruby/vendor_ruby/rspec/version.rb
/usr/share/doc/ruby-rspec/README.md
/usr/share/doc/ruby-rspec/changelog.Debian.gz
/usr/share/doc/ruby-rspec/copyright
/usr/share/rubygems-integration/all/specifications/rspec-3.4.0.gemspec

Changelog

2016-03-13 - Matthias Klose <doko@ubuntu.com>
ruby-rspec (3.4.0c3e0m1s1-1ubuntu1) xenial; urgency=medium
* Merge with Debian; remaining changes:
- Ignore test failures for a first build.
- Remove build dependencies on coderay and ruby-aruba (universe), only
used for testing.
2016-03-02 - Cédric Boutillier <boutil@debian.org>
ruby-rspec (3.4.0c3e0m1s1-1) unstable; urgency=medium
* Imported Upstream version 3.4.0c3e0m1s1
* patches
+ refresh patches
+ don't apply autorun-load-configuration.patch (fixed upstream)
+ don't apply escape-path-in-match.patch (not needed)
+ add patch to skip some specs failing with coderay 1.1.x
+ skip specs using a running dRb server (stalling)
+ fix encoding issue in rspec-core tests
* Remove coverage subdir in rspec-support and other _* files when cleaning
* Bump Standards-Version to 3.9.7 (no changes needed)
* Use https:// in Vcs-* fields
* Fix reporting of upstream versions due to new output of uscan
2015-10-24 - Matthias Klose <doko@ubuntu.com>
ruby-rspec (3.3.0c2e1m2s0-1ubuntu2) xenial; urgency=medium
* Ignore test failures for a first build.
2015-10-24 - Matthias Klose <doko@ubuntu.com>
ruby-rspec (3.3.0c2e1m2s0-1ubuntu1) xenial; urgency=medium
* Remove build dependencies on coderay and ruby-aruba (universe), only
used for testing.
2015-08-20 - Cédric Boutillier <boutil@debian.org>
ruby-rspec (3.3.0c2e1m2s0-1) unstable; urgency=medium
* Imported Upstream version 3.3.0c2e1m2s0
* Add a task to repack the source in a unique tarball
* Refresh gemspecs
* Do not clean anymore tmp/ subdir in rspec-mocks
* Skip another test related to UTF-16LE encoding on ruby2.2
2015-06-15 - Cédric Boutillier <boutil@debian.org>
ruby-rspec (3.3.0c0e0m0s0-1) unstable; urgency=medium
* Upload to unstable
* New upstream version 3.3.0c0e0m0s0
- refresh gemspecs
- refresh patches
* comment more commands about previous git submodules approach
* Use a single tarball instead of a multiple tarball 3.0 (quilt) package
- remove create-empty-orig option
- update README.source accordingly
* Remove persistent statistics of specs under */spec/examples.txt when
cleaning
* fix fix-rake-task.patch
* Add failed_specs.patch to deactivate failing tests which need more
investigation
* Build-depend on git and coderay to satisfy some specs
* Depend and build-depend on ruby-thread-order
* Tighten version dependencies between RSpec components
* Install .rspec template in project_initializer to make rspec --init work.
2015-04-09 - Antonio Terceiro <terceiro@debian.org>
ruby-rspec (3.2.0c2e0m1s2-2.1) experimental; urgency=medium
Team upload.
[ Antonio Terceiro ]
* debian/patches/fix-rake-task.patch: fix path to rspec binary in rake
task. Closes: #782161
[ Christian Hofstaedtler ]
* debian/patches/autorun-load-configuration.patch: fix rspec/autorun
not honoring expose_dsl_globally default.
2015-04-09 - Christian Hofstaedtler <zeha@debian.org>
ruby-rspec (3.2.0c2e0m1s2-2) experimental; urgency=medium
Team upload.
[ Lucas Nussbaum ]
* Remove myself from Uploaders.
[ Christian Hofstaedtler ]
* Depend on ruby-rspec-support where needed
2015-04-02 - Cédric Boutillier <boutil@debian.org>
ruby-rspec (3.2.0c2e0m1s2-1) experimental; urgency=low
[ Jérémy Bobbio ]
* Create ruby-rspec, ruby-rspec-core, ruby-rspec-expectations,
ruby-rspec-mocks and ruby-rspec-support from the same source package in
order to avoid the painful circular build dependencies needed to run the
tests. (Closes: #677955)
The new source package contains in separate folders the content of the old
ruby-rspec* source packages.
[ Cédric Boutillier ]
* New upstream version 3.2.x
* Update build-dependencies to build correctly all the rspec-packages
* Various patches to accommodate the new build setup
* Bump Standards-Version to 3.9.6 (no changes needed)
* Create a debian/README.source file to document the workflow

See Also

Package Description
ruby-rsvg2_2.2.5-4build1_i386.deb RSVG renderer bindings for the Ruby language
ruby-rsync_1.0.9-1_all.deb ruby wrapper and bindings for the rsync binary
ruby-rt_1.0.3.0-5_all.deb RTTool library for Ruby
ruby-rubinius-debugger_2.2.1-1_all.deb Rubinius debugger
ruby-ruby-engine_1.0.1-1_all.deb Provides the RubyEngine constant
ruby-ruby-version_1.0.1-1_all.deb Provide the RubyVersion pseudo-constant
ruby-ruby2ruby_2.0.7-1build1_all.deb Generate pure ruby code easily from ParseTree's Sexps
ruby-rubymail-doc_1.1.0-2_all.deb MIME mail parsing and generation library (documentation)
ruby-rubymail_1.1.0-2_all.deb MIME mail parsing and generation library
ruby-rubypants_0.2.0-2_all.deb Ruby port of SmartyPants smart-quotes library
ruby-rubysl_2.1.0-1_all.deb Ruby Standard Library meta-spec
ruby-rubytorrent_0.3-5_all.deb BitTorrent library in Ruby
ruby-rubyvis_0.6.1+dfsg1-2_all.deb Ruby visualization toolkit
ruby-rufus-scheduler_3.1.10-2_all.deb job scheduler for Ruby
ruby-rugged_0.24.0+ds1-2_i386.deb Ruby binding to the libgit2 library
Advertisement
Advertisement